Polyphonic earthsea for trilogy/ansible and er-301/just friends/txo


#41

do you have anything else connected to the i2c backpack? or is it just teletype / ansible / just friends?


#42

aha! i failed to mention I have another ansible and a tx0 on the bus as well. Disconnected them and looks like polyearthsea to JF is working!

do you think the issue was the 2nd ansible?


#43

having other i2c devices shouldn’t cause problems (and i assume the same set up worked for you with teletype before?) although it’s possible that adding too many devices will cause i2c to become unreliable, which would cause tt to freeze and polyes not to be able to send anything. if it’s easy for you to try could you try different combinations - disconect tt, or have both ansibles connected but not anything else?

the biggest unknown for this implementation is how i2c will behave in very different setups, so any data we can gather will be super useful for improving it.


#44

i’m going to start adding various tips&tricks.
here is the 1st one: using patterns as x/y pad controllers

this system can work as a replacement for the original CV shapes but in some ways it’s a lot more flexible.


#45

for sure! thanks so much for your time!

connecting the txo again and it seems to respond to polyearthsea in conjunction with JF simultaneously, like in your video. guess for now I’ll leave the 2nd Ansible disconnected.

however, checking out the output paramaters stuff, as soon as I change anything in that screen, pattern playback stops and nothing responds to playing until power is cycled again.


#46

thanks for testing that!
do output parameters work with the 2nd ansible disconnected?


#47

appears not.

i’ve been leaving the 2nd ansible disconnected as that seemed to be the only way to get anything to work with polyearthsea on most basic level (will explore that later, maybe testing if teletype mode on ansible being on or off affects anything etc.)


#48

sorry, one more question, which i2c backpack do you use? is it like the top one in this pic?


#49

yep, top one 20chars


#50

Wow this is really cool – I’ve sometimes thought about continuing the fretboard analogy further, so that the same note played on different ‘strings’ would have a slightly different tone, and this would totally enable that kind of flexibility :tada:

Sorry if I missed this somewhere in the documentation, but is it possible to switch back and forth between poly / mono modes?


#51

there is no poly/mono switch but you can sort of achieve mono by using different patterns each configured to use a single voice.


@n-So - could you try this version with everything connected and see if it still freezes when you change any telexo output parameters?

edit: posted wrong version, removed for now

if it still locks could you try disconnecting telexo but leaving everything else connected and see how it works with that configuration?


#52

sorry for what might be a dumb question, but what are our options for connecting an ansible directly to a just friends without a teletype?

i have an i2c backpack, but it lives on the back of my teletype. seems as though additional backpacks are out of stock and TXb isn’t available yet. Are there any other ways?


#53

you can have everything connected to the same backpack and it should be fine (i’ve tested with this set up) as long as you don’t use i2c ops at the same time. it actually even worked with polyes sending to a telexo and teletype sending to telexo at the same time, but this might potentially cause tt to freeze as tt firmware doesn’t have the i2c tweaks.


folks who are able to run polyes with i2c enabled without any issues - if you’re comfortable doing so could you post your configurations? this would be super helpful for i2c troubleshooting. basically just the list of i2c devices and what i2c board you’re using.


#54

yea i’d actually like to try putting an ansible and a JF in a small case without a teletype so my question was more regarding what is needed in that kind configuration


#55

if you can find a used one any of the i2c powered boards will work (and you could use the teletype i2c backpack without connecting it to teletype - if you don’t have too many other device you could have them connected directly to teletype too). DIY is also an option:: https://oshpark.com/shared_projects/eVzh387f

hopefully txb module will be available soon!

i’ve documented possible i2c solutions here: https://github.com/scanner-darkly/polyearthsea/wiki/i2c-set-up


#56

My i2c configuration features a Monome Backpack on the Teletype connected to:

  • Two TXi’s
  • Two TXo’s
  • Whimsicalraps W/
  • ER-301
  • Just Friends
  • Ansible

Polyes is working for me.


#57

Crashed Ansible with Polyes.

I wondered what would happen if I plugged in my ARC, if all I do is swap plugs between GRID and ARC the Ansible continues to see the GRID after I plug it back in.

If I turn a knob and press the key next to the USB connector on Ansible while the ARC is plugged in and then I go to plug the GRID back in, the Ansible no longer see’s the GRID and I have to reboot my system.


#58

thanks for the bug report, will take a look! (i haven’t added arc support to multipass yet so not surprised it’s buggy when switching between grid/arc).


#59

working config:
teletype backpack (powered, but taped to the bottom of the case, no teleteype in this system. )
2x 6pin cables to connect a single ansible and a JF


#60

If I am running and ansible with the previous earthsea version and do not have any of the i2c modules is there any difference in this version?