Problem - Loss of monome connectivity to max patches devices are still present win10

Hey there - when switching back and forth between M4L apps from terms in live (flin,step,polyg) my lights freeze seemingly at random, but consistently within a minute or so… basically making it unusable - the pads are still responsive however in terms of the midi data coming across… for instance, the sequence may appear to be stopped but i can still “add notes” to it - same with flin, and i can also change up the pattern in polyg.

when i go ahead and disconnect and reconnect i end up seeing more and more instances of the grids and then things basically go expeditiously downhill.

i have tried a full reinstall of the various components… max/serialosc/ftdi drives etc. hopefully there is something woefully easy i am missing (yes transport is running hah) - there are no errors in the max console.

has anyone seen anything like this? i am trying to move everything into a tighter environment using m4l - i can go back to pages+ext patches but this seemed like the logical next step for my setup. anyway - any advice would be appreciated. i should note this is a new laptop so its all pretty crispy in regards to any leftover install debris etc…

I can repro on both live9 max7 and live10 M4L8 (which is indeed showing up in live10).

i can also detect both grids and they pass the monome patch “tests” when using the straight max patcher.

win10 64bit
live9 + live10

it appears that it has nothing to do with terms or m4l really… something is just not right with the detection/retention of my monome devices on this machine… i have the same strange frozen-drop-outs when using anything… like say for instance recording some scrubbing fun with capstarc. ive updated the title to better fit the issue.

has anyone installed the latest serialosc on win10 64bit? my other laptop that required me to have bonjour did not have these issues…

i have reinstalled again… i have manually removed the d2xx.dlls (as these are auto installed in the windows.exe both 32/64bit)… tried every usb port… wondering what i can do to better debug - the max console doesnt seem to care about it at all. also all 3 of the COM devices are present in the device manager, post drop out.

i have the exact same problem. also running W10

Similar issue - using grid with max on windows 10 I lose PC → grid LEDs connectivity whilst still receiving grid → PC button presses. This occurs apparently spontaneously after 15-30mins of use and is resolved by just unplugging + replugging the grid

ok then. glad to know that i am NOT unique in this :space_invader:

@Joakim @josephsomer - have you guys tried to troubleshoot the issue much? it basically renders my whole setup unusable… maybe i can change up the game and start doing micro performances. 1-2 min bliss noise performance. haha.

ok, over the next few days i am going to go back in time a bit and see if i can identify the point at which (from a serialosc perspective) this starts to occur. then move onto max, although i am not sure i have the legacy versions available to me… let me also try running the native apps available in pages and see if we can take max out of the equation.

kind of a crapshoot but with windows 10 i’ve had some issues with push 2 doing weird stuff like cycling the screen. I ended up having to go into device manager (not just the windows power scheme settings) and manually disable the power management on each device. The problem happens less but every once in awhile I have to go back into device manager and disable power management on a usb device (assuming it’s push 2) again. Not sure why it doesn’t persist. Might be worth a shot to see if it helps.

Hi all! Can anyone confirm that the problem happens with this build of serialosc?

Hey there - i am still experience the issue with the version above, =/

1 Like

that’s actually very interesting. does this happen only with M4L patches or with patches from monome package for max 7 as well?

@artfwo - i can repro with both m4l AND monome patches for max7.

If i use test grid from the BEAP collection, i also get the same results - essentially all looks good, things are checking out - and then wam - nothing, occasionally the /key data still works but /led and /tilt are completely frozen.

I was thinking that next up i could install a much older version of serialosc that still required the bonjour service or something to that effect and try on this same exact setup… but i am open to ideas.

Older versions probably won’t work. Would you be interested to run the attached Python test script and see if the behavior is the same? The procedure is to install Python 3.6, then unpack the attached archive and run Best version of serialosc for that would be 1.4.1-pre linked above. (7.3 KB)

The script will randomly light the grid and you can increase the framerate by pressing buttons from left to right. Please report back if the lights freeze at some specific column.

I can definitely give this a go. I have an update: apologies for the delay - it took me a second to recreate my old setup… right now, i can hot swap, toggle apps apps in m4l terms, leave the grid studies running and i am not experience any freezing/locking up or doubling and tripling of the monome device in the selection area.

I am testing my 256 and 128 sames cables/grids with the older serialosc that has the dependency on bonjour in the registry - which i think is the version prior to the 1.4 branch, but it is hard to tell - is there a way to see the version stamp that i dont know about?.. max 7.3.3 and ableton live 9.7.2 (not sure ableton’s version matters too much here as i can repro without it). both machines are win10. I have left the transport on for over 2 hours now without issue… unplugged and replugged, swapped out the grids/ports - added/removed patches/instruments - its magic.

now, this is not to say that i want to revert to the old, but it is nice to see it work =) - so, python test next on latest then?

To figure out the version you can run the following command from cmd:

"c:\program files\monome\serialosc\serialoscd.exe" -v

the output should be something like: serialosc 1.4.1b (fb9ecaf)

older versions might not have -v switch though. and yes, a python test on both machines could really help!

Missed this at the time, but I’ve installed the version above and the issue seems to be solved! Thanks so much.

(The stress test ain’t working for me - just flashes a command prompt window)

1 Like

Hi everybody, new to the game, got my first Monome 256 vari last week :slight_smile:
After countless hours of researching why I had such problems with disconnection (I had to powercycle constantly), I finally found this thread. The above mentioned beta nearly solved all my problems (the rest is m4l/ableton messiness), so I would humbly suggest to promote this beta and put it out there for everybody to find.

1 Like