Problem with github login

it looks like there is a problem with the lines github integration. i had to relogin on one of my devices and it seems i can’t use github login anymore, i get this message: Sorry, there was an error authorizing your account. Perhaps you did not approve authorization?

when this happened the first time i checked my github settings and lines was still listed as an authorized app. the url when i get the error message above is which seems to suggest the authorized urls are not properly specified - i wonder if maybe the https url is not included? i also tried removing authorization from github, and i still get the same error above.

could one of the admins look into this? thanks!

There was a github outage this morning – I wonder if that could have been the problem.

probably not related - i noticed it last saturday first and been trying it every day…

I’m guessing the https in the redirect url is probably the correct assessment. I’ve built some oauth2 login stuff before, and usually the easiest way to implement redirect uri checking is by a literal string match. I’m not 100% sure if this is how github does it, but it’s a reasonable guess.

“since saturday” also corresponds with the timing of this:

paging the @admins :slight_smile:

1 Like

yeah, i suspected it might be related and remember having the same issue with some of the oauth2 stuff i had to set up at work :slight_smile:

didn’t know we had a group for admins - that’s handy!

i’m probably the only person using github integration, but in case anybody else runs into this - i just used a password reset to change my account to a regular login.

trying to figure this out, re:

can you go into your github oauth settings and change the domain to https:// ?

where do i change github oauth settings?

lines was listed as an authorized app in my github settings but i don’t think there were any parameters to edit. when i tried to debug this i removed the authorization from github thinking maybe it would re-add it, but i don’t get asked again when i try github login, it just throws the error.

This is usually something that the owner of the oauth app within github has to do (adding the “https” variant as an allowed redirect uri)

I think the process for this is to go here:

Then click on the Discourse integration app, and update the Authorization callback URL to include https.

here’s the precise message that shows the github setup:

but this might be a deeper dig

that’s set by the oauth github app owner though, as @rknLA mentions above. i don’t think it’s set by the user.

you’re correct, apologies.

i’m actually not certain where you can even go in the user setup to re-enable github oauth, or change auth methods… still digging on the discourse forums now…

For some reason I can’t login to my lines account on my computer (using my iPhone to write this) It always auto-logged me in before, but somehow that stopped working.

In the login page, if I click ‘with Github’, an error message pops up saying “Sorry, there was an error authorizing your account. Perhaps you did not approve authorization?” If I click ‘with Google’ a different error pops up, but I used Github when I originally made the account.

Edit: Btw I’m using Google Chrome. Already tried clearing browser cache/cookies, but I still end up with the same error.

I’m having the same problem here. I tried the Google login as well, and received an incorrect URL error.

I made a new account to log in and post this.

Initially I was asked to log in to Github, which I did, and then received the error. I’ve tried clearing cached data, another browser, and incognito mode, and I’m receiving the same errors everywhere.

Screen grabs below.

Actually, because I’m a new user, only one screen grab.

I’ll try to repost the other.

Here’s the github error:

Oh, and just to note all steps taken, I revoked Github authorization for lines and I am still receiving the same error.

Didn’t see the original post and thread (maybe because I got there via search?), so all I saw was elquinto’s last message.

Anyways, reading through gave me the idea to try resetting my password w/ the email I use on Github, and that seems to have worked.

Or maybe I just made an account with that email at one point and forgot about it. Bad account hygiene here.

Anyways, maybe that’s a tip for someone in the future with the problem, but Github/Google OAuth integration definitely seems broken.

thanks for the tip. i know something has gone wrong with the github auth over the months.

Hey guys! Was just trying to log in via my normal @flyingoctopus account, which was using github oauth and now am getting an error, and when trying to reset my password, I receive no email to fix it. Is there anything else I can do to unlink what I’m seeing as github oauth from my account and setting up a standard password login? Thanks and cheers!

it’s time to reinvestigate this issue. check back in a few days.

1 Like