Problems with Ansible/Meadowphysics

Hey,

I’m mainly using Ansible in Meadowphysics mode to trigger four or eight voices. While doing so, I ran into some problems. I’m not sure if those are bugs, related to me being an Ansible noob or a combination of both. Anyways, here we go:

  1. The top row triggers all outputs.
    When in 2-, 4- or 8-voice mode, the top row triggers all other rows when it falls off the grid. All eight LEDs are flashing and voltages are sent. This makes the top row unusable. Also, for this row to work, retrigger has to be activated. Otherwise it just falls off the grid once and then stops. Don’t know if the latter is supposed to work that way.

  2. Rows 5-8 become inactive.
    When in 8-voice mode, the lower 4 rows stop working after a while. I believe this only happens when I don’t touch the grid for a while but I’m not 100% sure. In general, those four rows still are moving but nothing is sent to the outputs and the LEDs stay off.

  3. Grid becomes unresponsive after a while.
    Similar to the previous issue, sometimes the whole grid become unresponsive. Then, all rows keep on doing what they are doing but won’t accept any button changes.

If someone could share some info about this behaviour, I would be super thankful. I’m guessing Kria is the more popular mode but to me Meadowphysics is a dream come true if it works as it should.

As for grid becoming unresponsive, is it possible that you’re using an older firmware (see this thread where someone had a similar issue)?

Thanks for the reply. I bought the module and grid from another forum member and was under the impression that the latest firmware was installed. I will run the installer anyways, just in case.

which edition grid are you using?

and can you ensure you’ve flashed the newest ansible firmware?

Thanks for your support. I have a 2015 model of the aluminium grid that is currently available.

I tried to (re-)install the latest firmware but I don’t think that it worked. Homebrew was successfully installed beforehand but when I start the firmware installer, I get this message:

18

is there a way to find out which version is installed?

I managed to installed the new firmware.

The first problem that i described about the upper row triggering the ones below seems to have vanished. So I’m hoping that it will be the same with the others.

Very sorry for the confusion.

seems you installed homebrew but didn’t install the dfu-programmer:

brew install dfu-programmer

from https://monome.org/docs/modular/update/

Yes, that was the problem. Sorry for taking up your time.

good to hear.

the first issue actually just sounded like a saved preset. you can make MP do what you described with row configs

Ah, I see. Thank you. I’m trying my best not to be too dumb about this stuff, but obviously I don’t succeed all the time. :slight_smile:

no worries at all, these things are weird and complicated, which is why we have this forum!

2 Likes