Quence

What about having the twister change to a different CC when you press down on the encoder. That way, you wouldn’t have to switch banks and could have both available at once.

I’m not sure I understand your suggestion. I used pushing of the knobs to implement mutes and locking of each track. Also for global clock pausing.

I would update the code to 2.0, but I’m not sure how many people actually have both norns and a twister.

Here’s a demo of how it works:

7 Likes

I misread what script this was for and spoke out of turn, regarding the Twister Fighter. This looks sweet though and now I want to give it a shot!

1 Like

This sequencer is nuts! Just got around to trying this out, it’s so good to perform with. Would love the sequences locked to my loops and delays. Has anyone had the chance to look at adding a crow sync input?

1 Like

New build up; @e041dd0. If I understand correctly how this works, updating from maiden should pull down the latest.

New:

  • Ping-pong playback mode per-track
  • Per-track playback mode indicators on screen
  • Screen redesign
4 Likes

I have a norns and twister and would be interested

3 Likes

20 characters of same here.

2 Likes

Still having trouble getting crow to sync Quence. I tried to add the new beatclock-crow lib to try and get it to work but no dice.
@spunoza and @ground_state would one of you be able to have a look? Would be hugely appreciated!!!
Awake and Less Concepts have the beatclock-crow lib in there scripts if you need to find it. Hope you two can get it working!

Quence uses the new norns clock system, so you don’t need to do any extra coding to get crow clocking it.

  • Go into the parameter menu, and navigate to the clock menu.
  • Set source to Crow.
  • Clock input is input 1 on crow.

4 Likes

Thanks for posting that! Looks like my version wasn’t updating correctly. I can now see a change in the screen and crow clocks quence. I am noticing that quence is 1 bpm faster then PNW. I’ve tested it at different bpm’s but it’s always 1 bpm faster.
Another thing, can quence be reset by crow?
Or can it start when I start PNW?
I’m trying to get it in sync with the loopers on the 301 and some delays.

not at the moment, but it shouldn’t be a difficult add to, say use crow in 2 as a reset input. i’ll look into it.

maybe the reset input (crow in 2) could function as start if the sequence is stopped? i’ll have to think about this a bit.

edit: or maybe in 2 on crow could be a run input? gate high is playing gate low is stop? with only two inputs it’s difficult to decide what takes priority, starting on time or resetting lol

1 Like

Just what I was thinking!
Crow input 2 would make for an ideal reset input. I also like the idea about it acting as a start sequence option if Quence is stopped.

Another thing I was thinking about was an option to have JF cycle voices (poly mode) instead of assigning a track to one voice. Not sure how complicated it would be, hopefully easy.
I’ve just having too much fun using Quence to sequence the OP-1, JF and two other sources like mangrove and plaits via the crow outs.

Also do you have any idea why norns would be 1bpm more then PNW?
It could just be a redraw error because it still sounds like everything is in sync. Still going to investigate a little more.

this isn’t complicated, but the current implementation was a deliberate design choice :slight_smile:
letting JF handle note allocation for polyphony meant only using one output for all four tracks, assuming all four are set to JF ouput (which is my primary use case :sweat_smile:). the current way seems more flexible, and allows for incidental chords via notes from different tracks overlapping.

i could dm you this change if you want to play around with it, but will likely leave the current implementation in place.

this i’m not sure about, but if everything sounds sync’d… maybe it’s just a rounding difference in displaying the tempo?

Yup I totally get that design choice and it is a good one. Had many exciting chordal moments playing around so I think it would be best to keep it as is.
A DM version would be wonderful but I’m also happy to give it a go if you point me in the right direction.

I just did some more testing on sync and it’s definitely not in sync. With all the delays going it sounded ok but once I stripped it back to one sound from Quence and one from PNW, its clear they fall out of sync after a few loops. What odd is it sounds like skips a pulse at some point then Quence sounds off beat to PNW. I’m asumming there’s something more at play here somewhere in the beatclock but I could be wrong and it’s probably something in the Quence script.
Hopefully we can find what’s causing it.

i’ve seen some pam’s troubles before: ^^ crow help: general (connectivity, device q's, ecosystem)

what’s interesting is that the new clock module and beatclock are pretty different mechanisms — which makes me wonder if PNW isn’t somehow the trouble. does this happen with other scripts as well?

Just for clarity, Quence uses the new clock module. Beatclock was removed on May 7th.

1 Like

right, apologies for not being clear – the post i linked references troubles using pam’s new workout to drive the beatclock-crow version of awake. eventually, it gets to:

since the same “one less” trouble popped up using the beatclock-crow lib with awake last year, i’m assuming this isn’t a quence issue (since quence is using the new clock lib, which is a big improvement over the beatclock-crow lib) – the only common denominator is pam’s :confused:

1 Like

No that’s totally fine. Thanks for chiming in.
I’ve been testing things out and I think it’s just PNW giving an incorrect read out but the timing is fine. I slaved PNW to Ableton via the endorphins shuttle control and both Ableton and a Norns give the same readout but pams is “one less”. Audibly everything seems to sound in sync.

EDIT: After doing a PNW calibration, dropping 50 to 48, PNW and Norns both display the same bpm. So the issue is definitely within the apps.

I’ve just tested Awake, Animator, Quence, Zellen and Less Concepts.
So far Awake, Zellen and LC stay in sync but Awake and LC both use crow input 2. Awake doesn’t seem to respond to input 1.
Animator and Quence are the ones with issues, they both seems to miss a pulse and become out of sync. What’s odd is they both go back in sync after a while. So I’m thinking it’s missing a pulse after 16 steps or so and going in and out of phase.
I should also mention I’ve been syncing norns via ansible which is synced to PNW but I have tried PNW direct with the same results.

super odd — just to confirm, have you updated less concepts? i migrated it to the global clock system when it was rolled into norns about two months ago, so it shouldn’t behave differently from quence.

Just made sure LC was updated. Now it’s working with the normal crow clock on input one.
Still having issues with Quence and Animator both missing a pulse some how.