I’m not familiar with these scripts, but is it possible they are just trying to do too much work on the main thread? (Screen drawing or etc?)

We should add some big warning in screen when event Q is filled, like we had on aleph

No idea to be honest but if there is an issue with the event Q being filled, then adding a warning would be a smart idea.

I’m now thinking, as these scripts (Quence and Animator) have the ability to change the number or steps per track that they could be messing some calculations with incoming clock pulses?
I haven’t tried to change the step lenghts as I thought it would be easier to get to the issue by sticking to 16 steps.

Hey there…

So if I understand correctly, Crow outs are only CV, no gates?

I just made a discovery of sorts…I do now see that it’s the trigger that is coming out of out 2, however, it appears that the either the gate is too narrow, or the level is too low to activate some envelopes (Cwejman and Modcan) but others will see it (Intellijel and Makenoise). I’m sure there is a way to adjust his via Crow programming/settings. Any ideas?

Looks like you can change that on lines 137-138:


Try changing 5 to 7 (for 7 volts), if that’s doesn’t work you could trying changing 0.25 to 0.4 for a longer time ramping down to 0 volts

EDIT: this is the page to reference if you want to understand Crow commands on Norns - scripting with norns | monome/docs


@shoggoth hit it on the head :slight_smile:

is saying go to 5 volts in 0 seconds and then go to 0 volts in 0.25 seconds. change the first non-zero number for height/peak voltage and the second non-zero for width/length of the trigger.


That is so cool! Will try it now. Thank you!

Update: so I messed around with different values. Turns out that the above-mentioned command yields a sawtooth wave instead of a pulse. Either way, the duration of the ‘trigger’ was actually too long; so the first trigger that was seen would engage the envelope, but it wouldn’t fall low enough to become recognized as a re-trigger unless there was a long-enough time gap. I shortened it to .01, leaving the volts at 5 and now all of my envelopes are responding to even very fast 16th note triggers.

Additional update:

I got midi working back into my computer with the iConnectivity Midi2+. Capuring midi there, those notes are also very long…a sixteenth note is pretty much the entire length of note, which leads to unpredictable midi retriggers. I bet there’s also a line of code to adjust the midi note relative lengths??


This one isn’t so simple (to me at least) - midi works differently than a trigger because the script explicitly says ‘turn note X on’ and later says ‘turn note X off’.

It seems like the script turns the previous note off at the beginning of each step - so you are right in that the note length lasts the entire step. Perhaps try setting your midi device sustain to 0 and control note length with decay? Not sure how to help beyond this advice, hope it does indeed help!

1 Like

I got it working ok by adjusting the synth, thanks!

So I have Norns/Crow playing some eurorack and Norns/iConnect Midi2+ playing an Oberheim, all driven by Quence. Very ‘playable’ app. Here are some excerpts: