Raspberry Pi + Monome


#61

version 1.4 had a bug causing serialosc to crash sporadically on linux, so i’d suggest using the latest master instead.

you can as well use pre-compiled raspbian packages that are known to work on armhf, but remove serialosc that you’ve installed with ./waf install if you’re going to use those.


#62

hey thanks for your response! I was actually just trying to get your ppa going but theres no distribution template for raspbian/Jessie?

I suppose I should upgrade to Stretch?


#63

“bionic” dist works great with stretch, but i haven’t tested it with jessie.


#64

I have tried following the instructions very carefully and looked around the internet for help but I cannot get this done.

After I add the repository to my sources.list and run the keyserver command then when I try update I get:

The repository ‘http:/ppa.launchpad.net/artfwo/monome/ubuntu bionic release’ does not have a release file.
Updating from such a repository can’t be done securely and is therefore disabled by default.

I can see the signing key there on your page but I don’t know what to do with it!


#65

That should be ‘http:/ppa.launchpad.net/artfwo/monome/ubuntu bionic main’, have you copied the command to add repository exactly as it’s typed in the docs?


#66

Ah, it did say main but there was another typo (an extra ‘/’). Thanks for the tip!


#67

from here

I run ./waf successfully in /libmonome, but when I run ./waf configure in /serialosc, it throws an error:

Checking for libmonome : not found
The configuration failed

there is a config.log file, but I am not sure which bits are relevant to this discussion.

this is on a RPi 2 with Raspbian Stretch Lite.

ideas?

edit: this issue could be related to gcc-multilib? when I try to apt-get install gcc-multilib, it tells me:

E: Package 'gcc-multilib' has no installation candidate

#68

You could ls /usr/lib to check if libmonome is installed there properly. (that’s where it is on my pi 3)


#69

doesn’t look like libmonome is in /usr/lib. :confused:


#70

try ./waf configure and re-compiling libmonome again?


#71

Oh you could also try

sudo apt install libmonome-dev

Maybe this is a new package since that article was written


#72

recompiles successfully, but doesn’t create a folder in /usr/lib :confused:

returns E: Unable to locate package libmonome-dev

edit:

… I think the waf compiler is looking for monome.h but I’m not sure where it is looking :mag_right:

i’m just manually copying it to random directories and recompiling at this point

edit edit:

ok I just found this page - gonna give this a go


#73

So yeah - I realized the apt get libmonome is dependent on this first:

curl https://keybase.io/artfwo/pgp_keys.asc | sudo apt-key add -
echo "deb https://package.monome.org/ stretch main" | sudo tee /etc/apt/sources.list.d/norns.list

sudo apt install libmonome-dev

which is similar to that new link you posted


#74

for the purpose of this topic i’d recommend to use the PPA linked from https://monome.org/docs/raspbian/ because the norns repository doesn’t have serialosc binaries.