Raspbian+monome install instructions


#41

Ok, so the shouldn’t be any output from the script and the grid should react to keypresses. If that doesn’t happen, can you check if pymonome is at the right version, i.e. what’s the output from command pip3 show pymonome?


#42

The terminal reads the following:

Name: pymonome
Version: 0.9.0
Summery: a monôme serials client in python
Home-page: https://githib.com/artfwo/pymonome
Author: Artem Popov
Author-email: artfwo@gmail.com
License: MIT
Location: /home/pi/.local/libpython3.5/site-packages
Requires:aiosc


#43

your setup is good. does the grid react to keypresses or are there any messages in the terminal when you push buttons?


#44

The program runs but it looks like it just sits there as I press monome buttons before I use command interrupt.

when I plug the monome in it also says: [ 1429.033901] Under-voltage detected! (0x00050005). Does this affect anything?


#45

Okay, can you try the following?

cat ~/.config/serialosc/*.conf
OR
cat /var/lib/serialosc/*.conf

use the latter command if you’ve installed the debian package. you should see the contents of serialosc grid state file, which looks like this:

server {
  port = 12988
}
application {
  osc_prefix = "/monome"
  host = "127.0.0.1"
  port = 58986
}
device {
  rotation = 0
}

make sure you have liblo-tools package installed. then run the following command replacing <port> with the server port value from the grid state file and <prefix> with the application osc_prefix option value:

oscsend localhost <port> /<prefix>/grid/led/set iii 0 0 1

for example:

oscsend localhost 12988 /monome/grid/led/set iii 0 0 1

the led should light up. if it doesn’t, but serialosc reports the grid as connected, something is not right.

additionally you can run oscdump with the application port as the argument, for example:

oscdump 58986

push some buttons, you should see /grid/key events in the terminal. if you do not - again, something is wrong with your serialosc setup, system configuration or power/hardware.


#46

I’ve just tried using oscsend and the led does light up. However when I run the oscdump command, using the application port as its argument, I get nothing back from the terminal when pressing buttons, the program just hangs. So it seems that one way communication from host to device is working but the signals from the device are not getting back to osc application, is this more likely to be hardware or software issue?


#47

more likely a hardware issue, serialosc is known to work well on the RPi. try following this troubleshooting guide. hope this helps!


#48

I’ve since managed to make oscdump print the monome key presses, so now input and output are both functioning correctly. I then tried to run grid-studies-1.py but still the keys do not light up in response to key presses. The main function for the program as defined here https://monome.org/docs/grid-studies/python/, does not contain any calls to the grid_key functions, is there something which needs to be added to main whereby the grid_key function is passed to the event loop, such that it is called upon the event of a key press?

Running the script is definitely having some effect on the connected monome since if the script is run whilst also running oscdump, oscdump’s output changes from something like this “/monome/grid/key iii 12 4 1” to this "/sys/host s “127.0.0.1” or “/sys/port i 59898”


#49

No need to add anything manually, the library connects the events to the handler methods under the hood. It’s strange this doesn’t work for you, because I’m using the same version with my RPi and the grid studies example runs well. Have you tried running the other examples? Or examples from the pymonome git repo?


#50

Thanks for this thread i am grateful for this community, I am going to work on pd patches for the raspberry with a piSOund and a grids today so i am excited that this is here

TY!


#51

I have two versions of grid-studies-1.py the one from the zip file download and theres another one with variations from the zip download on the python grid studies page: https://monome.org/docs/grid-studies/python/
I’ve tried making both the files executables
when I execute the files like so: ./grid-studies-1.py
I get a couple or errors I hadn’t noticed before which say:

import: command not found
syntax error near unexpected token ‘(’
‘class GridStudies(monomer.App):’

when I run the files as:

python3 grid-studies-1.py

the file from the zip has an 'attributeError: module ‘monome’ has no attribute ‘Monome’

the file online doesn’t have this error of course where the code is adjusted and so runs but still with no result from the monome.

but does this have anything to do with the ‘import: command not found’ error that occurred using ./grid-study-1.py instead of python3 grid-study-1.py ?


#52

I still haven’t got a response from oscdump. my also runs but just sits there. I noticed during the trouble shoot you’ve linked I got some errors that stood out?

ftdi_sio ttyUSB0: usb_serial_generic_read_bulk_callback - rub stopped: -32

ftdi_sio ttyUSB0: error from flowcontrol urb

I don’t know what they mean but perhaps they have something to do with oscdump not running?


#53

…not sure how but my oscdump is working now


#54

Success! the hello.py patch works, I’m yet to double check why the grid1 doesn’t


#55

dear all,
to my knowledge this problem is not completely unfamiliar, yet i haven’t found a solution anywhere.

i have serialosc (or better to say “serialoscd”) running on an rPi 3. tested unter jessy and strech, i’m encountering a persistent problem: it’s very unreliable. the only thing i can observe consistently is that on every first boot of the rPi, serialosc seems to be crashing. ssh’ing into the pi and running “top” states a CPU usage of ~100% (see screenshot).

does anybody know how to fix this? or even how to find out, what’s going on? i’m terrible (!) with linux :blush:
thanks :cat2:


#56

I don’t know if @artfwo’s recent fix will help your issue but it might be worth a try. Raspbian+monome install instructions


#57

what?! it’s working! – i’ve been struggling with this for several months!
@jasonw22, i’m soooo thankful! (although i don’t trust it quite yet :upside_down_face:)


#63

I’m running pd vanilla on the Raspberry Pi 3 when I open gridstudies-2-1.pd

connecting to port 12002
netsend: Connection refused(111)

what does this mean?

I’ve attached a zip file with all the patches im using in case anyone can test it also on there pi?

Many thanks

edit : sorry here is the zip file now

gridstudies.zip (36.3 KB)

If its possible can someone check my serialosc.pd file in the gridstudies.zip file i’ve attached. The patch has been adjusted to work on pd vanilla but I’m still not sure why I can’t get values from the monome in grid-studies-2-1.pd (in the gridstudies.zip here)… Any help is very much appreciated, many thanks!

Has anyone managed to trial the gridstudies.zip file i attached?

Regards!

I hope I’m not pushing it with another post, I’m very keen to get the monome connected to pure data so I just wanted to make sure my posts are reaching anybody?

Many, many thanks!


#64

it usually means there is nothing listening at the other end, like serialoscd isn’t installed or isn’t running or is listening on the wrong port.


#65

i’ve been away from the RPI and monome for a couple months… I’ve followed the instructions to install serialosc (again) but I’m not getting any acknowledgment from serialoscd!? I’ve also run $sudo adduser pi dialout and user pi is already a member of the dialout group.
Why is this happening?

Many thanks