-re:mix- {m4l app}


#225

i’d try downloading the latest Max. (7.2.2) i don’t think anything is wrong with your loops if it doesn’t have the gap of silence every cycle.


#226

Updated Max. Fixed. :sweat_smile:
This setup looks to be really powerful. I lately had been dreading the idea of recording in loops to arrange them in Ableton. This opens up a world of spontaneity and fun.


#227

Maaaaaan @elquinto this is powerful!!! I spend the last night jammin with RE:MIX. Absolutely genius!
Some questions about the saving process:

  • the input 1-8 buffers will never show up after loading a set, right? I’ll always have to select the samples for the buffers?
  • how do I save to get the names of my sets in the setlist? I don’t get it? however I try to save the slot always shows ‘0-empty’

Best
KZA


#228

glad u dig it. : )

right, the input buffers are temporary slots for live recording so you’ll need to use the save button/symbol next to the waveform to export to disk.

-once u have your row config set up, u need to use the Insert dropdown to insert or overwrite to the selected preset slot in the list (bottom right). Then use the Set dropdown and save the set. Everything should load back up okay after that.


#229

I try to use remix with el capitan in ableton.
If i recorder a sub loop in one the four pattern recorder
is there a way to mute the pattern, listen the original loop and go back to the pattern ?
If i press the button the pattern recorder is deleted.
thx


#230

yes, holding mod 1 (7th button / top row) then pressing a pattern button stops playback without deleting, then pressing the button again resumes (with or without mod 1 held, it doesn’t matter).


#231

Cool, thak you. Seems to work.
I try something like a live looping setup, where i record some analog instruments live on the fly.
If i record for example my guitar live on the fly in ableton, i have no problems.
If i move this file to remix
Sometimes the recorded aif. file is not displayed and played back in remix.
(Dont know why, but most times it works)
But im trying since two days and able to get a tight recording in remix.
No matter wich pre value.
If i hit go and start playing, in 10 out of 10 times the recording in remix is to late or to early.
Maybe its a strange latent from the input moduls to the remix ?
Recording direct to ableton works without problems
Is there something i can do ?


#232

Work-around for air file not showing and playing: uncheck and check corresponding number in input.amxd.

It starts looping the exact number of beats from when you press go. It does not work as ableton’s looper. I use a click in my in-ear to make sure I use the correct downbeat. So 2 bars really equals 8 beats.


#233

i record in ableton live on the fly with a footswitch
to the metronome direct in clip slots.
No timing problems.
I mapped the remix go button to my footswitch.
And try to record the same way with metronome.
But cant record in time.

Dont know how the night button should work.
But if i press the button my monome doesnt light up.
If i press abutton on the mono with night enabled the button will light up.
Is thats the right behavior ?
I have a walnut 128


#234

when u record to clips in ableton, what do u have your global quantization set to? in re:mix it quantizes record go to the tame tick your samples are triggered by (unless u have quantize off). do u notice a pattern with the timing of your recordings? one beat early or late?

the night button only works with newer monomes with variable brightness. it makes it so that any off LEDs will light up dimly instead.


#235

regarding the .aif issue, i haven’t noticed this myself, but if u drag any audio file to re:mix and it isn’t displayed or played back, its probably an issue with the file name or the name of some folder in the file path. if it happens again, try checking for symbols or characters that might not be supported like * . " / \ [ ] : ; | = ,


#236

the problem is the same no matter if i turn quantize on or off in ableton.
No matter what i am doing it seems that the remix doesnt catch the first milliseconds of my recordings
So my recorded loop starts a little too late ( but in this case is to early)
If i hit the button a little bit earlier than i have a little silence at the beginnig ( so its too late in playback)


#237

After testing some days,
i had a lot of strange problems.
Maybee its because im on ableton 9.6 and el capitan.
recording seems out of time.
Sometimes loaded samples are displayed correct, other times loaded samples have only names and no waveform.
Sometimes the app crashes my system wich never happened before.


#238

I’m on el capitan / Live 9.6 too so i don’t think that’s it. U may want to double check Live’s audio settings / buffer size and make sure its not set to something too high. 64-128 is usually best. Also double check what it says for overall latency. Should be in the 6-12ms range. Besides that i’m not sure what it could be. I’ll try doing some recording later and see what i find.

The issue with loaded samples only having names and no waveform is most likely an issue with the file names or the name of a folder in the file-path (i’ve seen this before, so that’s my best guess right now). First i’d check for symbols/characters that might not be supported by Max.

Any idea what could be causing it to crash or does it seem random? What version of max are u using? The most recent is v7.2.3


#239

were some ramdom crashes, but every time i tried to use the monome inside of ableton with remix and some instances of terms.
Have to test a little bit.
For the recording latenz problem maybee it is because i try to record live input.
I monitor before ableton.
It would be cool if you can test recording a little bit.
Can i hit the go button from the monome ? mod 1 and mod 2 seem not to work.
Can i use Terms Time together with Remix ?


#240

Sorry for all my messages :slight_smile:
But i try extensivly to get this stuff working.
I noticed that there is a problem with every file i record or drag to the Remix.
First i thought i cutted my samples not good enough but i have noticed
That Ableton i playing a loop perfect. If i add the loop to remix everytime
the audio file loops there is a little hang on the first beat.
I made a short viedo here
http://www.file-upload.net/download-11607650/Remix.mov.html


#241

i believe i know what’s happening in the video. Live plays back the file okay because of your loop start/end points, but i think the actual file is slightly longer. (it looks like it extends a bit beyond your end point) next time before u drag the file to re:mix, try right-clicking on the clip and choose Crop first.


#242

oh and to answer your other question, u can trigger record go from the monome (but 128/256 only). u press both preset buttons at the same time. (buttons 13/14, top row)


#243

Ah, ok, mod Buttons 3 and 4 are working ( tried with one and two first )
I will try not to ask too many stupid questions.
But can you tell me something about the sends 1 to 4 how they work ?
Can i assign a send automation to every step in row or only one value for each the 7 tracks ?
Do i have to record the automation in ableton or in the monome remix ?

And a little questions about the files i try to input. I only try to understand whats happening.
I picked for example an aif. drumloop from the ableton libary, drop it in remix and the wave form will not be displayed.
If i move the drumloop to an ableton track save the project and reopen it than the remix will display the wave form if i move the file to it.


#244

The 4 send values can be individually set for each row, but not for each step. I’m not too sure there’s a way to record the automation. Because of the way m4L works, u can only record a max device’s audio by routing it to another track first and by then the automation data is lost. U would need to be able to record directly to the device’s track to be able record the automation with it, which isn’t possible unfortunately. I know this isn’t ideal, if i think of a better way i’d definitely do it, but for now really the best way to record sends while you’re playing is by routing their output to another track (or tracks) and record the audio there.

Next time u drop in a file and u can see the name but not the waveform, save a copy of the set and pm me a copy of the .flist file. That would help me to see what’s causing the issue.