-re:mix- {m4l app}


#245

Made two little videos.
One with the recording problem. i maped a switch for ableton recording and remix go button.
And compared the two recordings.
I switched monitoring on my desk before ableton and in ableton with low recording latenz monitor switch on, off, auto
the remix recording seems to be to early
http://www.file-upload.net/download-11621574/Remixrecording.mov.html

And a video with the file loading problem.
I tried an aif. file from the ableton libary.
http://www.file-upload.net/download-11621585/loading.mov.html


#246

thx for the videos. the reason why the .aif file won’t import properly is because it’s part of a Live Pack and Live packs are installed on your computer as package files. (in finder, u need to right click on the pack and ‘Show Package Contents’ to see the subfolders and audio files) for this reason, i don’t think its possible to import samples directly from Live Packs.

i did a bunch of recording the other day and i didn’t have any timing issues, although i did notice the pre-roll values are all double what they should be. 1-bar seems to actually be 2 bars, 2 bars is actually 4, ect.

record go is quantized to the global quantization in re:mix (in your case 16n), and the way it works is when u press go, the next quantization tick that passes through triggers recording. if u try to press it at the exact moment the tick occurs it becomes much more likely you’ll miss it / be too late could this be what’s happening? it looks like that may be the case in your video.


#247

Thx for your answer.
In the video my pre recording value in ableton and remix was about two bars.
So hitting the go button to late isn’t the problem.
With 16 quantization it could be that i pressed to late.
But with this long pre recording value this should not be the problem.
But i will try :slight_smile:


#248

the pre-roll works a little differently for Live clips. if u have your global launch quantization set to 16n it’ll be the same, but for longer values like 1-bar it’s not.

for Live clips, with global launch quant. at 1-bar, it always starts recording on the downbeat (the higher-pitched sound in metronome), but in re:mix, there really is no set downbeat. so with a pre-roll of 1 bar, it just waits 1 bar after u press record go, then lets the next quantize tick through, which is what triggers recording.

…however… if u enable the punch-in checkbox in the input.amxd, that makes it so that u can set the downbeat manually and have pre-roll work basically the same way it works with Live clips. u press the little button next to where it says punch-in to set the downbeat. (midi/key-mappable if u need)


#249

Ok, i think i can handle it with the punch in on downbeat.
But i cant fugure out why some samples ( wich i recorded in ableton ) wav.
sometimes are not displayed. Maybee i have to send you a file.
And an other question… a lot of times the samples in remix are played back with the wrong pitch ?


#250

not sure if I have said it already, but you are good people, @elquinto :heart:
thanks for re:mix and for staying in touch with the users!

EDIT:
oh and by the way… where are the INPUT-Recordings saved? LOL
seriously is there a kind of cache-folder or something or do i have to be careful with recordings to keep my harddisk clean?

EDITEDIT:
I AM EDITING MYSELF TO DEATH

EDITEDITEDIT:
Ok last one for today… How To Delete Recorded Inputs??


#251

Pardon me if this has been covered or is seemingly obvious, but I’m trying to trigger samples (as though I was hitting the first button of rows 2 to 8 on my 64) using a Keith McMillen 12 step footcontroller. I’ve got Midi Out turned “on” and midi in set to “trigger” in the settings. re:mix is otherwise working fine. Live is showing midi activity on the re:mix track midi input when I press a button on the 12 step. the “name piano roll.adg” isn’t showing any midi activity though (shouldn’t it?).


#252

@Flamusic
There’s no timestretching, so if your sample is a different tempo than Live’s, it’ll sound re-pitched, that’s normal. Best thing to do is use Live to timestretch / pitch-shift samples, flatten the audio, then import to re:mix.

@Birdster
u have to manually save them using the save button/symbol in the main device. also u can choose ‘Collect all and Save’ from the Set menu and it’ll export all the files at once. (including ones you’ve imported)

u can re-record over recorded samples, but there’s no way to delete them. (unless u choose Set->New Set, which deletes everything)

@SolidMaster
i think it might need to be the first device in the rack to show midi activity. the purpose of the ‘name piano roll.adg’ is just to name the piano roll with the row/buttons for easier editing, so it doesn’t really matter if it shows the midi activity. if u want it to though, place it in front of re:mix on the rack.


#253

@elquinto
Thanks for the quick reply. I’ll definitely try moving the piano roll around.

I suppose I’m still stuck in regards to setting up the Keith McMillen footswitch to remotely trigger my monome while my hands are busy elsewhere. Would you mind giving quick instructions on how this can be done? I already checked the forum somewhat and the help information included with the app.


#254

First u need to know what notes correspond to the buttons u want to trigger. One way to do this is drop the name-piano-roll.adg on a track, create a new midi clip, find the buttons on the piano roll and use the pen tool to add placemarkers. Then delete the .adg from the track so when u go back to the piano roll your place markers will be labeled with notes. Once u set up the 12step to trigger these notes everything should work as expected.


#255

Can you tell me how i can record the midi from the mono to ableton and play it back ?
I tried to route the midi to an other midi track but no notes going on between the monomer and the midi channel. Have set midi to on. Its an 128.

Do you know if the terms time app has influence on the remix app for better timing ?
My triggering is sometimes less precise than my recording :slight_smile:

Is there a way to delete the samples in remix ?


#256

yeah, to record midi from the monome and play it back, first u need to have midi out enabled in the setup tab, then route the midi to another track you’ll use to record (place the “name-piano-roll.adg” on this track), then route the midi back to re:mix. that should be it.

terms time won’t have any influence on timing.

to delete samples, make sure the floating window is the active window, hover your mouse over a row and press delete.


#257

Thank you for all your super fast reply.
Think i got everything to work.
Maybe a feature that it will always auto sync on the downbeat would be cool.
And one last question …
Can you explain me the snap to options (grid, zero, none)
I can imagine what they are doing but would be nice to know it exactly.
Is it how the sample will be cuttet to the monome grid or is the sample start point after recording ?


#258

Ideally “punch-in” mode would always sync with the downbeat when u stop/start the transport. I tried do this before but for some reason i couldn’t get it to be reliable… sometimes it would be one beat too late. i’ll revisit this again once i get the chance.

When u drag to select parts of the waveform, ‘snap to’ will make the start/end points snap to a grid, zero-crossings, or to turn snap-to behavior off, select none. Use the “grid” dropdown to choose how many subdivisions for snap-to-grid.

if u haven’t seen it already, there’s an ‘info’ button in the setup tab with some useful tips and keyboard shortcuts for things like snap-to-grid and zoom.


#259

if i record a little performance on the grid to a midi track and play it back the grid is triggered to late ?
HAve you noticed that or did i something wrong ?


#260

yes i’ve noticed this. because of quantization, if the first note starts on the 1 in the arrangement or a midi-clip it’ll trigger late. u must press a pad ahead of the quantization tick for it to trigger and it works the same way for midi. (if u set quantization to none you’ll notice the first note triggers on time)

after u record the midi from a performance to Live’s arrangement u can shift everything over by 1-bar and everything should trigger on time, but i’m afraid saving patterns as midi clips isn’t going to work well unless it’s unquantized.

unfortunately i haven’t come up with a good solution to this yet.


#261

i was just doing some testing and i found a way to make it work (for midi clips too)… :slight_smile:

glad u reminded me about this, it’ll be fixed in the next update.


#262

No problem.
Recording the midi is not so important.
Creating something spontaneously is more important and that is working.
The only thing i have noticed today after jamming around for two weeks is
that not the recording isnt to late or has a latenzy.
Its the downbeat sync problem. I havent noticed it before.
But also if i press the downbeat sync perfectly in time…
A lot of times its syncing a little bit to late…so the recording starts a little too late.
If i press the downbeat sync a little in front of the first click, the recording will sit perfectly.
But 8 out of 10 times i miss the right downbeat.
So for fun its better to record in ableton and drag the samples over.
I was hoping that i can use it for a live situation to record on the fly realtime audio in the remix.
Its working…but a lot of times im not on the right beat when i start recording
and in a live situation it has to be easier… i think


#263

i hear u. i think i thought of a way to get punch-in mode always synced with Live’s downbeat. try this and let me know what u think.

edit- i uploaded the wrong file by mistake :confused:

here is the right one. https://dl.dropboxusercontent.com/u/35035949/input.zip


#264

After the first 10 recordings
9 out of 10 were in time. (The one was my fault :frowning:
Seems to be much better … thank you very much its much easier to work now.
So i think i can press recording without check the downbeat box and click the downbeat.
Thats what ive done… and it seems to work very good.
The downbeat symbol seems to click not on the right downbeat… but recording will start right.