Recent grid 128 - no LEDs lighting - Mac OS 10.13.2

I’ve just bought a second hand grid - I know from the seller it was working when it left however I’m not getting LEDs lighting

I’ve connected it to Max - I can see the grid - all the buttons generate appropriate messages as expected

when I plug it in I get a quick flash of LEDS at the top left corner but it doesn’t go further

Any thoughts - am I doing something wrong? is there anything I can look at inside ?

(edit - running off one of the main USB ports on a 2015 mac book pro - running High Sierra 10.13.2

Have you installed serialosc? You need that for the monome and computer to talk to each other.

Edit - if you’re seeing button presses in Max you likely have - sorry!

yeah - serialosc working - I’ve got it recognising the device and button presses being recognised

if you get the LED blip at the beginning it suggests the LEDs are working.

which os version are you on?

have you tried the monome max package? it has a grid_test patch (though yours looks good at first glance)

just added that to my post - 10.13.2 on a 2015 MacBook pro

edit - the grid test works much as mine does!

ok more weirdness - plugged it into my rPi/pisound norns - and it DOES work - I recognise that pattern - its the foulplay UI!!! (it also promptly crashed - but there was no screen plugged in and I’m sure thetechnobear said something about grids not working properly - debugging one thing at a time…)

So something on my Mac - I realise I’m on an older high sierra - I’m trying the combo update to 10.13.4 which someone on another thread (which I guess this one should merge with) says is working for them

updated - installed 10.13.4 - no difference

remove a bunch if kexts (audio and filesystem stuff) - no difference

Serialosc is the only thing that has it open

eight:Library markwilliamson$ lsof | grep usbserial
serialosc 987 markwilliamson 3u CHR 21,6 0t424 715 /dev/tty.usbserial-m1000318

serialosc itself has a whole bunch of things open including, possibly interestingly, /dev/null

at a loss what to poke at now - feels like time to look at source code see what’s missing but not sure where to start on that

ok - serialosc uses a UDP port listening on serialosc - could it be weird binding caused by me messing about with networking at somepoint? which would explain messages coming out but not in - following that line of reasoning for a bit

edit - not this - have been talking to the grid using aiosc in python

incoming message from ('127.0.0.1', 12002): /serialosc/device ('m1000318', 'monome 128', 14008)
incoming message from ('127.0.0.1', 14008): /sys/id ('m1000318',)
incoming message from ('127.0.0.1', 14008): /sys/size (16, 8)
incoming message from ('127.0.0.1', 14008): /sys/host ('127.0.0.1',)
incoming message from ('127.0.0.1', 14008): /sys/port (13288,)
incoming message from ('127.0.0.1', 14008): /sys/prefix ('/monome',)
incoming message from ('127.0.0.1', 14008): /sys/size (16, 8)
incoming message from ('127.0.0.1', 14008): /sys/rotation (0,)

sending it a direct /grid/led/set,1,1,1 does not do anything even though it responds to /sys/info

OH!

sent /monome/grid/led/level/all

and it worked - should it have a prefix? edit - yes it should and I’m using that in max too. hmm - weird

ok - this works - but the bpatcher serialosc does not!! ok - feels like i’m getting closer.

18

it’s not something stupid like the name of the grid is “monome 128” with a space in it ? (but you don’t seem to be able to change that so I’m guessing not)

fwiw - the Monome Home patch has been super helpful to me in debugging.

Also test-grid.maxpat which is here with serialosc.maxpat I think

Ah. That looks very useful. Thank you

ok - it seems to be because it opens serialosc from BEAP which for whatever reason isn’t working with my grid

those two that @okyeron posted both work for me!

Now struggling to stop it loading it from BEAP - it picks that one even if I have the one from serialosc.maxpat loaded. scratches head

ok mystified - I’ve got a few bits working by hacking in the serialosc posted above.

Non of the max for live devices work from the ableton pack - and yet if I go into them they are connecting and if I hack in a message to set an LED they seem to work. So all odd - I’m connecting to it, get messages but somehow all the max for live devices and most of the max patches I have are somehow not sending the right messages to light LEDs…

It feels like the grid is in some odd mode or something is changed from factory settings - I’m not sure that that is a thing though.

anyone else any thoughts?

i had to re-install my serialosc from monome site to get it to be recognized by serialosc patches in BEAP [windows] I’ve abadoned mac

Maybe you have mutiple serialosc binaries installed?

I don’t remember now what I used to find the duplicates, but I think I had a similar problem on RasPi.

hmmm possibly - oddly after closing everything and restating - max for live devices working - so progress!

1 Like