Reels

I’m not close to my norns right now, but I think you can slow the loop down to 1/4 which would give you 4 minutes I guess. But the audio quality is probably going to be more grainy, haven’t really tried though.

1 Like

same here,
can i rec from track 1, 2 and 3 in track 4?

I can’t get this to load on my Norns Shield. error: load fail

Are you running the latest firmware? Can you connect to maiden and paste the error output here?

Yeah, it’s the latest firmware.

# script load: /home/we/dust/code/reels-master/reels.lua

# cleanup

# script clear

ERROR (i2c/hp) failed to write

### MISSING INCLUDE: reels/lib/libreels

### SCRIPT ERROR: load fail

/home/we/dust/code/reels-master/reels.lua:15: MISSING INCLUDE: reels/lib/libreels

stack traceback:

/home/we/norns/lua/core/norns.lua:136: in function </home/we/norns/lua/core/norns.lua:136>

[C]: in function 'error'

/home/we/norns/lua/core/startup.lua:47: in function 'include'

/home/we/dust/code/reels-master/reels.lua:15: in main chunk

[C]: in function 'dofile'

/home/we/norns/lua/core/script.lua:172: in function </home/we/norns/lua/core/script.lua:172>

[C]: in function 'xpcall'

/home/we/norns/lua/core/norns.lua:137: in field 'try'

/home/we/norns/lua/core/script.lua:172: in function 'core/script.load'

/home/we/norns/lua/core/menu/preview.lua:21: in function 'core/menu/preview.key'

/home/we/norns/lua/core/menu.lua:139: in function </home/we/norns/lua/core/menu.lua:116>

# script clear

ERROR (i2c/hp) failed to write

Just rename your script folder from reels-master to reels and it should sort it out :slight_smile:

1 Like

Thanks, and sorry I’m new to this stuff. Just finished my Norns Shield build last night!

2 Likes

no worries! we were all new to this stuff once! :smiley: congrats on the successful build, and welcome to norns :partying_face:

5 Likes

Hey there!
I have problems with saving presets since I installed the new version of the Norns system.
First I had to reinstall Reels 'cause the older one didn’t work anymore, then everything was fine beside the presets savings.
Any clue?
Thank you for any tip!

@its_your_bedtime it may be me… but I can only seem to play loaded samples on track 1 (not 2,3,4). It’s the first time i’ve used this script so it’s very possible I’m missing something. Excited to dive in though, this is exactly the kind of thing that got me into norns.

EDIT: actually I can load samples on tracks 1 and 3. Perhaps this is expected behaviour.

First of all, thanks @its_your_bedtime for this great script. :orange_heart::orange_heart:

I don’t own an OP-1 but I would love to!!
Meanwhile, I thought I could use my little Casio and Reels to make something similar…(not really)

9 Likes

Since the latest Norns update (on a diy norns shield) I get 'error: init" when trying to run Reels :frowning:

Tried deleting and re-installing but no joy

Here’s what I see in Maiden:

# script load: /home/we/dust/code/reels/reels.lua
# cleanup
# script clear
ERROR (i2c/hp) failed to write
including /home/we/dust/code/reels/lib/libreels.lua
# script run
>> reading PMAP /home/we/dust/data/reels/reels.pmap
m.read: /home/we/dust/data/reels/reels.pmap not read.
Engine.register_commands; count: 0
___ engine commands ___
___ polls ___
amp_in_l
amp_in_r
amp_out_l
amp_out_r
cpu_avg
cpu_peak
pitch_in_l
pitch_in_r
# script init
### SCRIPT ERROR: init
/home/we/dust/code/reels/lib/libreels.lua:374: attempt to index a nil value (global 'mix')
stack traceback:
	/home/we/norns/lua/core/norns.lua:138: in metamethod '__index'
	/home/we/dust/code/reels/lib/libreels.lua:374: in field 'init'
	/home/we/dust/code/reels/reels.lua:19: in global 'init'
	/home/we/norns/lua/core/script.lua:105: in function 'core/script.init'
	[C]: in function 'xpcall'
	/home/we/norns/lua/core/norns.lua:139: in field 'try'
	/home/we/norns/lua/core/engine.lua:91: in function </home/we/norns/lua/core/engine.lua:89>
1 Like

from Norns: update 201113

deprecated
for scripting, mix is deprecated. please use:

params:set('output_level', value)
params:delta('output_level', delta)
params:get('output_level'

lines 374 and 804 of /code/reels/lib/libreels.lua should be changed from
mix:set_raw("monitor", rec_vol)
to
params:set("monitor", rec_vol)

maybe more after that, not in front of norns

1 Like

Ughh. This is why I never update anymore. Shit always gets broke

2 Likes

quick correction, these param addresses all end with _level, so monitor_level, etc

looks like a fix already got in, threw up a PR with correct syntax, should be only a little bit before reels is up and running again :slight_smile:

4 Likes

Thanks @dan_derks and @speakerdamage, all should be fine now! :slight_smile:

2 Likes

things like this are usually resolved quickly, and should be expected every now and then with so much continued active development taking place. plus, even if you don’t have a background in coding it’s a good exercise to try to troubleshoot things like this using maiden output and going from there. (I accidentally “liked” this post and can’t undo it for some reason)

2 Likes

I’m performing next month and was planning on using reels as a live looper and I’ve noticed sometimes when I record a loop it makes the end point - whatever number and it kind of glitches.

Is there anyway to keep the start and end points consistent and not have it change after recording to a track?

hi @its_your_bedtime wondering if it’s possible to allocate a specific 60 sec chunk of a sample in reels rather than the first 60 seconds? would be nice to be able to choose a desired segment from a longer pre-existing recording

1 Like

was wondering if it’s possible to add end of splice gates for each of the 3 reels for crow outs 1-3? reels is my favorite script and i think this would lead to some interesting/useful synced events with the modular :slight_smile: or if anyone knows of any other scripts that implement this behavior, i’d be happy to mess around with it. thanks

1 Like