Samsara: a minimalist looper



Samsara is a minimalist looper that invites you to slowly layer in new material as old material fades away. Toggle recording on and off easily while the loop plays, or use one-shot record mode to precisely record a single phrase. The loop duration is set in terms of tempo & beats, making it simple to integrate into other musical contexts (it uses norns’ clock system, so you can use MIDI clock & transport messages, Ableton Link, or Crow). Tap tempo is also available via K2+K3, and a click track is available via K2+E3.

You can also easily extend the loop. Say you have an awesome 1-bar drum pattern, and now you want to add harmonic content. Your harmonic phrase is probably longer than that one bar, so just hold K1 and tap K2 to double to two bars, and then again to double to four bars. Now you can layer a 4-bar harmonic phrase on top of that original 1-bar drum loop and keep everything moving.


Short version:

  • K2: Start/pause playback
  • K3: Arm/disarm recording

Please visit the wiki for full documentation: samsara | norns community


  • norns (update to software version 200424 or later)
  • Audio in (stereo or mono, select via params menu)


Latest version: v1.1.0 (8a0d38b)
Install by visiting http://norns.local/maiden when your norns is on WiFi and typing


into the command entry box at the bottom of the screen.

Also available as a direct download. Unzip it, rename the folder to just “samsara”, and put the whole folder onto your norns inside the /home/we/dust/code folder


you’re about to be my best friend

thank you!


20 chars of gratitude!

1 Like

nice work! looking forward to giving it a spin :smile:

1 Like

thank you! is it possible to make this part of the pedal script?

1 Like

Can’t wait to put this in the send/return of my mixer, thank you for this!


Wow. Absolutely brilliant. The UI, the implementation, the concept, the code. Amazing work.


That’s the plan, yup :smile: I wanna get this to a good place, and also make sure it doesn’t hurt Pedalboard’s CPU too much (Pedalboard is already pretty CPU-hungry, depending on which effects you use). Also I’ll have to think about how the controls map over (E1 is reserved for page changes in Pedalboard)… but yeah hopefully soon!


such a fantastic idea to capture another artist’s workflow which inspires you inside of a script of your own design :slight_smile:

thank you for sharing it and for working through the script out-loud for others to trace the pathways!


yesssss!! cant wait to use this. such a great idea. cant wait to bang out some weird drum beats by passing my SP-303 through Samsara.


Holy SHit this is ACES! Thanks so much for sharing. WOWZA

once I remembered to restart after the install all seems good.

1 Like

first impressions are ‘wow, yay, this is great, damn, thanks!’

I’ve just been playing with loop length on a JF poly patch all evening – haven’t even gotten around to drums yet…

EDIT WOW, was unaware of pedal and it looks like much of the feedback I was looking to give (ex: fade to noise rather than silence, a mono mode with an open feedback path) is totally subsumed by the idea that this would be part of pedal. This is the Norns script I’ve been waiting for, man damn.


Really digging this so far…thanks!!

1 Like

Can’t wait for this to appear in maiden.

Are there going to be an option for cross-fading start and end point of the loop?

This uses softcut, so the loop naturally has a small crossfade

1 Like

Just spent about an hour with this. I love the simplicity. Really great stuff here.

One question, for Tempo adjustment, I couldn’t change via K2 + E1 and haven’t quite figured out entering tamp tempo mode either (K2 + Tap K3). Maybe I’m missing something.

Something silly but could it be set coded as to where the paused and playing could match my daw. It stops and starts with my transport but doesn’t seem to update the display on my norns. Not a big deal but helps when I’m not wanting to use a monitor

Interesting, it works just fine on my end. You’re holding down K2 while turning E1? And you have your norns clock set to “internal”? My bet is your norns clock is set to follow midi/link/crow. I’ll update the UI to make it clear when the clock is a follower.

My bad! I forgot to call the UI refresh when you use transport messages to pause/play. Should be simple enough to fix.

1 Like

Yes, it was set to Crow. Not sure why I didn’t notice that. Thanks!

Version 0.2 (5b8df87) is ready! ZIP file

This fixes the two bugs just reported:

  • When trying to change tempo while the norns clock is following an external device, an alert is shown explaining that you need to go to params to change your clock source
  • UI should now consistently update when play/pause/whatever-else happens, no matter where that change came from (MIDI messages, params menu, whatevs)