Serialosc frustrations?

Hi guys, long time user, don’t really post. Issues Im having are Max 7 being super clunky and also my grid is never detected despite instances of serialosc running in activity monitor. the only way to get the grid to show up again is to reboot my mac?
Any ideas? Mac OS X 10.11.6.
Reinstalled serialosc, tried deleting it altogether as per new set up with max 7 and unpacking the monome info. Not too sure what to do? Had grids for years, but have very little time to spend making music, and when I do there always seems to be some technical issue that kills my motivation. Love the girds, and all seemed to work fine many moons ago.

1 Like

did you delete the FTDI driver as per documentation (assuming that you’ve upgraded from an earlier version of OSX)? made a big difference in stability on both my imac and my macbook.


I’m having minor connection issues in a similar situation. I followed the setup guide to uninstall the ftdi driver. But how do I know I no longer have the driver? Honestly not sure if I even had the driver, I just fllowed the instructions as a precaution.

if you want to be 100% sure, just go and manually delete the file below, reboot, done.

1 Like

Thanks for your help all. Had forgotten to get rid of the FTDI. done…However, when I switch apps via the monome package in max7 as outlined in the set up page, my grid isn’t recognised. serialosc 1.4 downloaded? feel kinda stupid as Ive had a grid for years, but things keep changing all the time and I’m not too technical… any thoughts? Only a reboot seems to help. i have instances serialosc showing up in activity monitor as well?

Ok, after years of trying to get some stability with this I’m pretty much done. Still nothing shows up. Device isn’t even recognised on Max 6?

Tried now with my 128 and my 256…no joy, it recognises the first one that is plugged in when i boot the computer but when i hot swap, nothing, and when I have apps open the lights don’t correspond to any button presses and everything is sluggish…

did you do a direct install of serialosc?

with grids plugged in, open a terminal and type:

ls -lrt /dev

do you see tty.usbserial-m128-000 or similar?

Correct tehn I did, and it appears that i do see that when opening terminal request. It all seems to be working fine, apart from in monome sum, there is no connection to any devices? Basically, if i don’t use Max 7 everything works fine in Max 6. So, I uninstalled Max 7. Also someone gave a beatstep controller which if plugged in seems to make a difference? weird huh? anyhow, for now I will avoid Max 7 and continue working as i did before, that seems to be the only solution. When I opened all the apps with the monome package it was hit and miss whether my grid would be recognised? Running latest version of OS X. Hot swapping between two monomes is a no no, as I have to restart mac when using max 7. Running myr’s monome home app and hot swapping two grids using max 6 seems to be fine?