SerialOSC installation Windows 10 64bit

I am having the same exact issue. Were you ever able to troubleshoot/resolve this?

apologies for the delay-- i’m looking into it now

1 Like

Same for me. I’m running a 40h kit under win 10 64bit. Only way for me to see it connected is the old monome serial where it appears. Suggestion: I tried to install ftdi drivers and realized, that win10 obviously does have a sort of ftdi drivers already on board. Tried to manually override them, but i’m not sure if it worked. However, serialoscd.exe says: [!] running in debug mode, hotplugging disabled
serialosc [m40h1230]: connected, server running on port 17714. Hope you’re able to fix this … ;). Greetings


I’d like to have a Windows serialoscd binary that is not in debug mode and that has hotplugging enabled, if possible.

My C skills are limited but I have Visual Studio at work. If someone could give me some pointers perhaps I can help out in some way…

After some investigation: found out, that the serialosc service isn’t running. If i try to start it manually, it “says”, it isn’t possible cause the required dependent service isn’t running, but win10 didn’t mentioned which one this could be … any suggestions? THX!

For me serialoscd works on Windows 10, but hotplugging is disabled (so all devices needs to be attached prior to launching serialoscd.exe) and it is in debug mode. I’m getting the same output in the console as you:

[!] running in debug mode, hotplugging disabled
serialosc [m40h1230]: connected, server running on port 17714

For me it’s not a big deal to start serialoscd.exe manually (as opposed to have it automatically started / as a daemon of sorts), but I’d like hotplugging so that I don’t have to have all devices plugged in before starting serialoscd.exe.

hey, the main issue here is that the serialoscd service isn’t starting correctly. “debug mode” is just the message you get when running the executable directly (rather than as a service), and hotplugging is disabled because in earlier versions of serialoscd I hadn’t figured out how to make a non-service receive device arrival notifications. I’ve since figured out how to do so, but again the primary issue here is that it’s not running as a service.

I think the root cause here is that I’ve got something wrong in the service dependencies that’s preventing it from starting. I’ll find some time later this week to investigate.


Great News! Looking forward to it … :wink: .

Any news about that? Greetings ;).

For everyone who is looking for a solution to get the monome 40 (kit) working on Windows10: Here is my little solution that worked for me -> How to install Monome 40 (kit) on Windows 10 64bit

Just wanted to give an update. Everythings working fine with hotplugging!

Im not sure if it was a new Bonjour installation or not, but after uninstalling all traces of monome related applications, it looks like we’re up and running again.

Not sure what has changed since my original attempt to get my MK working happily :smiley:

I’ve been having issues with hotplugging on Windows 10 too. I just did a clean install a couple weeks ago and it’s still not working. What’s most frustrating is for some reason i lose connection sometimes when going from M4L edit mode back to Live so I’m having to restart the service a lot. :confused:

Yeah I do have the same issues, weirdly enough hotplugging seems to work more regularly on my tower computer than on my laptop so I really don’t know where it comes from. Very strange.

Do you start serialoscd.exe yourself or run it as a service/daemon?

Was there ever any solution found to this problem? While preparing a live set I went back to my laptop, tried to solve it by reinstalling everything, with absolutely no luck. The problem seems to be that no matter if I check the “start serialosc service” box, it doesn’t run as service (it actually shows the service is not running when I check in msconfig), and it’s not starting automatically when I launch windows which means I have to run it manually using the exe. Which means hotplugging doesn’t work. Other than that, still absolutely 0 issue on my tower computer, hotplugging works like a charm, serialosc running as service as expected, it’s realllly confusing.

it was weird, i was on my windows 10 system yesterday to test something, and the monome worked fine… it showed up in the serialosc box like it should and i never had to start the service manually. i unplugged/ re-plugged the device several times and it re-connected perfectly.

maybe a windows update fixed it? i have no idea…

1 Like

Yeah it’s rather puzzling that all the people who were able to solve the problem don’t seem to have any idea how they did it! It doesn’t help much as to what I can try to do. Could it have something to do with Windows UAC? I know it’s disabled on my main computer for plugin wrapper issues, and that’s the only difference I can think of that would make a difference but it seems unlikely…

OK So what I found out is that some installers (can’t remember which because I’ve tried so many combinations…) install useless files, probably obsolete, in the “ProgramFiles/monome/serialosc” folder, and after they’re installed, even if you just uninstall serial osc and other monome applications, they stick in that folder, so you have to uninstall everything AND delete the monome folder. Once that’s done, just install bonjour and serialosc manually, check the monome/serialosc folder and make sure all you see there is “libmonome.dll” “serialoscd” “uninstall” and a folder called monome with 3 protocoles.dll in it. I don’t know if it’s making a lot of sense and it sure was a very unacademic way to correct the problem, but after hours of trying, I found it was the only solution to get serialosc to automatically run as a service at the start of Windows and detect my monome easily. Hope it helps.

1 Like

Just want to give another trace. Win 10 is installing a ftdi driver on its own. Maybe this Win Uac Version is causing troubles. :wink:

Adding this link here since the solution seems directly related to the problems reported in this thread.