SerialOSC not locating monome

I’m new to all this.
Anyway, my first question was: Why isn’t Pages connecting to my Monome via serialOSC? It was connecting to Terms in Ableton. But now after trying a few things, I now find that serialOSC is not detecting my monome 64. When I run serialOSC with my monome plugged in it reads:

osc server error 9904, “cannot find free port” ((null))supervisor: couldn’t create lo_server

Before it was giving me a port number. I have tried reinstalling a few times but still nothing.

IF we can solve that issue, I would also love to get help for my first questions:

I cannot get a connection to my monome from Pages. In the SerialOSC setup in Pages, I have tried entering the port number that is displayed in the serialoscd.exe, and I’ve tried both Apple and JmDNS options. There is a slight pause when I hit Discover Devices on JmDNS but no devices show up.
I am running Windows 10. I am not trying to run pages and terms simultaneously.
Really appreciate any help!

A frustrated noob


I don’t have direct experience of your issue as I use a Mac, but there are these threads which may be helpful.

Good luck!

Thanks for the reply. I uninstalled everything monome related and reinstalled and it seems to be working now! Pages also discovers the monome through serialosc. I think my issue was that I thought serialOSC had to be opened to run and I think that may have been messing something up.
Now to figure out how to get my midi out from pages to work…