Setting up Duplex (Renoise 3.0)

Hey, thanks for fixing that and letting us know!

Phew, it has been a busy last couple of weeks !
But I finally managed to take a fresh look at Duplex yesterday, and came up with a fix for the ‘NIL’ error.

You can grab the tool from here:

To install, drag the .xrnx file over the Renoise application and select one of the monome configurations from the application menu
Tools > Duplex > Monome > …

Next, click ‘Settings’ in the tool dialog and specify the port, prefix from there.

Note that it’s an alpha release which contains additional code for tracing/debugging. Assuming that the fix is working, I will then release a ‘clean’ version (as always, the full source code is on github)

Also, I added a few instructions for windows users like me who prefers to run serialosc with fixed ports: