Software Meltdown after attempting to use pages

Hi there, to get right to it: I recently set up a 128 grid on a Windows 7 Laptop. I got serialosc running and got sum making some great stuff which I have since sequenced and am very happy with.

I never was able to use monome with any max patches other than sum, maybe there is an obvious reason for this? In fact I never saw a drop down menu to select a device.

I tried doing a whole bunch of stuff with the intention of moving past sum: using pages, zeroconf, using a virtual midi channel program, all to get monome working in ableton and or max.

At this point everything stopped working, sum and serialosc seem to be completely out of whack and the computer is not recognizing the hardware anymore.

I tried uninstalling everything and starting over, and now I can’t even get serialosc back working again.

I’m not a computer person, merely a musician. And if it weren’t for the brilliant sounds I found with such ease, I probably would have jumped off a bridge by now, so to speak.

I would greatly appreciate any ideas. I have put off posting after trying to fix this on my own for many hours.

Thanks so much.

After uninstalling and and restarting multiple times everything seems to be working properly. Does anyone have any resources or advice for setting up pages with a virtual midi channel in ableton 9? I thought I had everything right but maybe its a 32/64 bit version problem? Or perhaps something is out of date? I understand I need python and java environments to have everything running. Thanks for anything!