[SOLVED] Any USB MIDI interface issues with latest Norns update 210701?

Hey everyone,

I am running the latest Norns update and I seem to be encountering some issues with dropped, delayed, weirdly advancing notes. I am using a Korg SQ-1 sequencer > DIN MIDI out > Roland UM-ONE MK II MIDI USB interface DIN MIDI Out > Roland UM-ONE MK II MIDI USB connector > Norns USB.

If I disconnect the MIDI USB interface from the Norns and from the SQ-1 and plug it back in to any of the USB inputs on the Norns the dropped, delayed, weirdly advancing notes occur as the sequence continues to advance. Also returning from sleep, if USB MIDI interface is fully plugged in, this issue occurs.

It seems like the only way I can resolve it is to restart Norns without the MIDI USB interface connected on either end, load e.g. Molly the Poly, plug in the MIDI interfaceand the issue goes away. But when I try this procedure to “fix” it it doesn’t seem to always resolve the issue (but it could just be me trying too many things…).

Is this Norns? Something specific to the MIDI USB interface? Or how the SQ-1 sends out MIDI?

Any advice on how to resolve or address is greatly appreciated :raised_hands:

210607 isn’t the newest— run SYSTEM > UPDATE and let us know if the problem persists

Oops - deep apologies @tehn - I am running the latest update (210701) and this is stock Norns. I pulled that version # from the docs page. I will update the subject line of my post.

it does sound like a bug, possibly with unhandled events that are blowing up the event queue.

the chain description is a typo right? you’re just going SQ1 → UM-ONE → norns?

@zebra that’s correct.

If there’s anything I can do on my end to confirm this, please let me know. Thanks!

Checking in about next steps here @zebra @tehn : Would it be best to report this as an issue on the GitHub repo or would it be helpful to provide more info?

i will look when i get a chance, but have not been able to in the last 23 hours at the start of the day-job work week.

yes, it would be nice if you could more explicitly describe your use case. if i understand correctly:

  • you are running stock norns
  • MIDI to norns from SQ-1 is being used as clock source… is that right?
  • the symptom is that clock seems irregular for unmodified sequenced scripts like awake… and this is not observable in the same conditions prior to june update (or some time)?
  • all scripts are affected? (issue is with MIDI systm clock, not note handlers?)

we can deal with managing GH issues but we like to have a good repro case first.

i just tested these steps with a UM-ONE MK II receiving data from a Blockas midihub + Ableton Live without being able to reproduce the issue – the sequence from Ableton → midihub → UM-ONE → norns (running Passersby) stays consistent (with or without MIDI clocking enabled), so i’m curious if the SQ-1 is sending some additional events beyond note on, off, and clock.

to augment your repro case, it might be worthwhile to try using something like MIDI Monitor on a laptop / desktop to survey the MIDI data coming in through the SQ-1 → UM-ONE part of the chain and share that info back here. either way, if i can find my SQ-1, I’d be happy to try and repro this with the additional detail Ezra’s asked for :slight_smile:

Thank you @zebra . I totally understand and no worries. This is not time sensitive by any means but the issue was glaring since it didn’t occur before this most recent update.

All of this is correct. I didn’t try on awake but I can confirm this on molly the poly and passerby. It seems it is a MIDI system clock issue and not note handlers.

@dan_derks thank you. I will use MIDI monitor and share the MIDI data from the SQ-1 asap and follow up here . Much appreciated yall!

ok thanks. thanks @dan_derks . i don’t have an SQ1. maybe it is sending active sensing or something. (seems weird. also not sure what changes could have affected how this hits us.)

as far as debugging, you could add something like this to norns itself to see all the bytes that are making it to lua. (with the understanding that something could conceivably be borked before that point in the data flow.)

in norns/lua/core/midi.lua:


-- handle a midi event.
_norns.midi.event = function(id, data)
  local d = Midi.devices[id]

  -- debug -------------
  local data_str = ""
  for k,v in d do
    data_str = data_str .. string.format("%02X "), v)
  end 
  print(data_str)
  ---------------------
...

and finally, an obligatory question from occams razor:

are we 1000% sure that the configuration of everything is exactly the same as when it was working before the update? like you can switch between good and bad behavior just by checking out and rebuilding different versions of norns?

1 Like

I have an SQ-1 and an iConnect Mio, so I can approximate your setup. With norns 210607/passersby, I can’t reproduce the stuck rapid state you describe, but I can briefly get a rapid cycling note by repeatedly unplugging and plugging in the TRS jack into the SQ-1 midi out. If you describe your steps-to-reproduce in detail, including your norns clock settings and your SQ-1 configuration and sequence, I can try to reproduce with 210607 and 210701.

1 Like

Ok, sorry for the delay in getting back everyone. Here’s a quick sample of the MIDI monitor output with only the SQ-1 and the Roland UM-ONE MK II connected on Mac:

09:37:31.444	From UM-ONE	Clock		
09:37:31.569	From UM-ONE	Clock		
09:37:31.694	From UM-ONE	Clock		
09:37:31.819	From UM-ONE	Clock		
09:37:31.944	From UM-ONE	Clock		
09:37:32.069	From UM-ONE	Clock		
09:37:32.194	From UM-ONE	Clock		
09:37:32.319	From UM-ONE	Clock		
09:37:32.444	From UM-ONE	Clock		
09:37:32.522	From UM-ONE	Start		
09:37:32.523	From UM-ONE	Clock		
09:37:32.524	From UM-ONE	Note On	1	C3	64
09:37:32.541	From UM-ONE	Note Off	1	C3	0
09:37:32.648	From UM-ONE	Clock		
09:37:32.773	From UM-ONE	Clock		
09:37:32.898	From UM-ONE	Clock		
09:37:33.023	From UM-ONE	Clock		
09:37:33.148	From UM-ONE	Clock		
09:37:33.273	From UM-ONE	Clock		
09:37:33.274	From UM-ONE	Note On	1	D3	64
09:37:33.291	From UM-ONE	Note Off	1	D3	0
09:37:33.398	From UM-ONE	Clock		
09:37:33.523	From UM-ONE	Clock		
09:37:33.648	From UM-ONE	Clock		
09:37:33.773	From UM-ONE	Clock		
09:37:33.898	From UM-ONE	Clock		
09:37:34.023	From UM-ONE	Clock		
09:37:34.024	From UM-ONE	Note On	1	D♯3	64
09:37:34.041	From UM-ONE	Note Off	1	D♯3	0
09:37:34.148	From UM-ONE	Clock		
09:37:34.273	From UM-ONE	Clock		
09:37:34.398	From UM-ONE	Clock		
09:37:34.523	From UM-ONE	Clock		
09:37:34.648	From UM-ONE	Clock		
09:37:34.773	From UM-ONE	Clock		
09:37:34.774	From UM-ONE	Note On	1	A3	64
09:37:34.790	From UM-ONE	Note Off	1	A3	0
09:37:34.898	From UM-ONE	Clock		
09:37:35.023	From UM-ONE	Clock		
09:37:35.148	From UM-ONE	Clock		
09:37:35.273	From UM-ONE	Clock		
09:37:35.382	From UM-ONE	Stop		
09:37:35.398	From UM-ONE	Clock		
09:37:35.523	From UM-ONE	Clock		
09:37:35.648	From UM-ONE	Clock		
09:37:35.773	From UM-ONE	Clock		
09:37:35.898	From UM-ONE	Clock		

Here’s when I encounter the issue on Norns 210701 with the following chain: SQ1(clock source) → UM-ONE → norns.

Here are the steps:

  1. Awaken norns
  2. Select Molly the Polly,Passerby, FM7 etc
  3. Power on SQ-1 with UM-ONE connected
  4. Connect UM-ONE USB to norns
  5. PARAMS → CLOCK → source → MIDI (also occurs when set to internal).
  6. Press play on SQ-1 everything ok
  7. Press stop on SQ-1
  8. Unplug UM-ONE from Norns USB and re-plug in same USB (or any of them).
  9. Press play on SQ-1 = wonky norns clock

To “reset” things and get things back to expected behavior, it seems like I have to first set the MIDI device back to “none” (remove the UM-ONE) on norns, reset norns and then it retuens back to expected clock behavior. The video shows what happens after you stop the SQ-1, unplug the UM-ONE from norns, re-plug the UM-ONE, then press start on the SQ-1 again.

1 Like

rad, thank you for the clear repro steps!

EDIT: oh duh, your video.

i think i remember where my SQ-1 is and should be able to run an identical setup to yours later today!

Sure thing :raised_hands:

If I understand what you are asking, the answer is that I am not sure as I haven’t tried it on Awake for example except after the issue occurs with the clock. I tried to test Awake just now but I am unable to get the norns to behave with trying to reset as I outlined above. :upside_down_face:
I’ll try in a bit and see what’s what…

HUGE Thanks for tracking down your SQ-1 and going down the rabbit hole…

UPDATE:

I can verify this issue is happening with Awake on my norns.

Curiously, when the clock gets wonky, while the sequencer clock is running into norns (awake or molly the polly for example) setting midi out on norns to the UM-ONE port resolves the issue and then turning back off it goes back to wonky behavior…

suuuuper weird (to me), especially since that clock out from norns isn’t really going anywhere – for those who don’t have access, SQ-1 only has output via TRS MIDI so the clock from norns would just head to the UM-ONE and then to nothing. but I’ve not been able to repro these issues with just the UM-ONE. curious!

also, I apparently have the wrong type TRS MIDI dongle for Korg standard, so I’m ordering one rn – it’ll be here friday!

I have not been able to reproduce this behavior with an SQ-1 and iConnectMIDI Uno using 210607 or 210701, which might suggest the issue relates to the UM-ONE rather than the SQ-1.

rad, thank you for the data points, super helpful! i’m curious if it’ll prove to be the combo of the two — i’ve never had clocking issues with the UM-ONE with norns and a handful of other MIDI devices :confused:

sounds good yall & thanks for the efforts in testing so far! so curious if you will be able to repro with UM-ONE and SQ-1 combo @dan_derks

I will throw this into the mix for more info: prior to updating to 210701, I upgraded my norns to the CM3+ and then flashed with the norns201202 image and updated to 210701 from norns. I then copied over my dust backup. I thought about doing a fresh install since this issue, but I will wait to see if you can repro the issue with the UM-ONE / SQ-1 combo :raised_hands:

dang, UM-ONE + SQ-1 combo isn’t giving me any trouble with these steps:

i only get a slight difference when pressing play on the SQ-1 (tempo 83 will shift up to tempo 86 for a beat until it averages back to tempo 83, where it stays).

i even tried clogging up the DEVICES > MIDI with weird UM-ONE multiples and odd numbering, etc. nothing strange.

since I can’t repro the issue, a fresh install seems the best next step i can think of to get you back to a clean slate :confused:

2 Likes

Oh wow! Ok, on to fresh install it is then! Thank you so so much for trying to repro. I’ll report back when I am back up and norns’n :raised_hands:

1 Like