[SOLVED] Crow – dfu-util problems/error (firmware update help)

EDIT: i solved the issue myself just after spending hours trying to fix it and finally posting the question here. simple overlooked user error hehe. I simply did not put crow in bootloader mode :crazy_face: :shushing_face: :upside_down_face: :woozy_face:
–––––––––––––––––––––––––––––––––––––
hi!
i’m pulling my hairs trying to update crow with the latest firmware. i’m on macos 10.13.6.
crow connects fine to my computer over usb, i can use it with druid no problem.

i had a lot of problem installing dfu-util though. it wouldn’t work simply using brew or ports, giving me all sorts of errors “(Error: dfu-util: no bottle available!)”.

i then tried building dfu-util from source according to these steps and it seemed to install successfully.

now when i run the firmware_update command i get the following errors:

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
dfu-util: No DFU capable USB device available 

any suggestion or directions would be greatly appreciated! thanks!

2 Likes