<SOLVED>Dfu programmer - device not present

Hi,

It seems I cannot update Ansible to FW 2.0.0, I get the following error

dfu-programmer - device not present.

I have the latest version of homebrew installed, I’ve updated FW previously and I have even tried 2 USB A-A cables, I follow the instructions on the page to the letter, I’ve even looked at other posts to see if I could get install tips. still nothing.

Are there any other prerequisites required to update FW on Mac? What am I missing?

thanks

So the procedure that was works reliably for me is:

  • power off the rack
  • connect the USB cable to PC
  • connect the USB cable to Ansible
  • hold the panel button next to the USB port on Ansible while powering the case on.
  • run update commands.
  • disconnect
  • power cycle Ansible

I am typically on a Windows machine but just tried on a Catalina MacBook that had not been set up to work with Ansible before, ran brew install dfu-programmer, and can read/write the hex file from the command line. I found that if I forget to do exactly this sequence I always wind up getting Ansible in an odd state.

Worth also trying

dfu-programmer at32uc3b0512 read

in the terminal to see if it can find it that way? I am unfamiliar with OSX in the extreme but it would at least be a very Windows thing to decide to sandbox scripts that are double-clicked instead of running from the command line.

You also may want to try ioreg -p IOUSB after holding the panel button and powering on, to confirm that the USB device is found. For me this lists:

AT32UC3B DFU@14100000 <class AppleUSBDevice, id 0x1000022bc, registered, matched, activr, busy 0 (1 ms), retain 11>
1 Like

Hi Thanks for all the help,

However still nothing, it looks like the Ansible goes into the bootloader stage( if I unplug the USB A-A and plug in grids nothing happens) but the Macbook cannot locate the programmer, could this be fried Ansible in anyway?

I can’t see any damage on the boards, so i’m pretty much stumped. I’ll keep searching.
Let me uninstall brew and try from scratch.

Thanks

So I got this working now, it seems Xcode command-line tools needed to be updated,

If anyone comes up against this problem in future please follow the below process.

  1. Uninstall Brew
  2. Re-Install Brew - Xcode will update command-line tools to specific MacOS
  3. Re-Install dfu-programmer
  4. Run the command dfu-programmer at32uc3b0512 read
  5. Follow the Ansible update instructions.

Thanks again
Craig

2 Likes