[SOLVED] error: DUPLICATE ENGINES

I’ve just installed a bunch of apps from maiden which worked perfectly fine on first launch however after I put it to sleep and restarted I am greeted with the message error: DUPLICATE ENGINES and none of my apps (new and old) will load. I assume I’ve accidently downloaded something twice but I can’t seem to find where abouts it is.

Nevermind, fixed it :slight_smile:

awesome! lmk if it was something weirder!

also, mind if we close this topic out since it got resolved?

Yeah no worries! All I had to do was delete my duplicate applications which I installed outside of maiden.

2 Likes

I have just plugged my shield in and got the “duplicate engines” error. Yesterday I installed a few scripts that appealed to me…but if maiden is telling me what is installed and what isn’t, then how is it possible to duplicate? I obviously only clicked on scripts that had “install” next to them. Now I don’t know which scripts I have “duplicated”! How do I find out?

sorry to hear about the trouble! maiden should report on which engine is duplicated and where, inside of the REPL window, eg.

DUPLICATE ENGINES:
/home/we/dust/code/ack/lib/Engine_Ack.sc Engine_Ack.sc
/home/we/dust/code/we/lib/Engine_Ack.sc Engine_Ack.sc
### SCRIPT ERROR: DUPLICATE ENGINES

(from help | monome/docs)

to track it down, which ones are listed when you attempt to load which script?

2 Likes

Thanks Dan. Let me just have a look at maiden now…

1 Like

Fairly new to Norns myself; this error and the method to resolve it is clearly outlined in the help docs. I’ve only had to do it once but from memory I seem to remember that “;restart” in maiden lists the duplicates?

1 Like

Thanks. Where is the restart button in maiden? can’t see it

you’ll want to type ;restart in the “matron” window (pictured above)

2 Likes

Hang on…now it says “supercollider fail” @dan_derks @rcf

3 Likes

ah dang! hmm. how did you resolve the Mx.Samples duplicate issue? you might just need to power norns down and reboot.

further troubleshooting from help | monome/docs

This indicates that something is wrong with SuperCollider, which could be due to various issues. First always just try rebooting via SYSTEM > SLEEP.

If you’re able to load maiden, there are two tabs in the main REPL area (above the >> prompt at the bottom of your screen). The first tab is for matron, the control program that runs scripts – the other is sc for SuperCollider. Click into the sc tab and type ;restart into the REPL. That should show you what is going on inside of SuperCollider.

Thanks dude. I have to go pick up my son now…will try in a bit…

1 Like

Sooo, I actually just ran into this same issue. I’m not a coding person by any stretch of the imagination. So I have no clue what any of this means. Any ideas/help?

matron
supercollider
Found 716 primitives.
Compiling directory ‘/usr/share/SuperCollider/SCClassLibrary’
Compiling directory ‘/usr/share/SuperCollider/Extensions’
Compiling directory ‘/home/we/.local/share/SuperCollider/Extensions’
Compiling directory ‘/home/we/norns/sc/core’
Compiling directory ‘/home/we/norns/sc/engines’
Compiling directory ‘/home/we/norns/sc/ugens’
Compiling directory ‘/home/we/dust’
Open ended comment started on line 142 of file ‘/home/we/dust/code/lissadron/lib/Engine_Lissadron.sc’
ERROR: duplicate Class found: ‘Engine_Phyllis’
/home/we/dust/code/phyllis/lib/Engine_Phyllis.sc
/home/we/dust/data/phyllis 2/lib/Engine_Phyllis.sc
ERROR: duplicate Class found: ‘Engine_Fiahod’
/home/we/dust/code/fiahod/lib/Engine_Fiahod.sc
/home/we/dust/data/fiahod 2/lib/Engine_Fiahod.sc
ERROR: There is a discrepancy.
numClassDeps 1499 gNumClasses 2994

hey hey!

for sure – this is the important chunk:

ERROR: duplicate Class found: ‘Engine_Phyllis’
/home/we/dust/code/phyllis/lib/Engine_Phyllis.sc
/home/we/dust/data/phyllis 2/lib/Engine_Phyllis.sc
ERROR: duplicate Class found: ‘Engine_Fiahod’
/home/we/dust/code/fiahod/lib/Engine_Fiahod.sc
/home/we/dust/data/fiahod 2/lib/Engine_Fiahod.sc

that’s two sets of errors – one for phyllis and one for FIAHOD. supercollider is thankfully telling us exactly where those duplicated engines are:

/home/we/dust/code/phyllis/lib/Engine_Phyllis.sc <~~~ normal
/home/we/dust/data/phyllis 2/lib/Engine_Phyllis.sc <~~~ unexpected

and

/home/we/dust/code/fiahod/lib/Engine_Fiahod.sc <~~~ normal
/home/we/dust/data/fiahod 2/lib/Engine_Fiahod.sc <~~~ unexpected

so, if you delete the phyllis 2 and fiahod 2 folders completely from code, you should be able to restart to a clean boot :slight_smile:

Aayyyeeee it worked! :raised_hands::raised_hands:
Thanks for the help!

1 Like

Hello dear Sirs! Fist time user here ) Please help

I updated all scripts on a DIY shield bought online and before that scripts would load. Now any will just print “loading…” forever. AND I get the “error: DUPLICATE ENGINES”.

Here is what maiden prints:

please help

LC

swtich to the SC REPL tab, type ;restart and then quickly hit the “reconnect” button. you should be able to catch the supercollider startup error which reveals the name of the colliding class.

1

2

3

4

5

return {

– Table: {1}

{

},

}

matron

supercollider

; restart => unrecognized operation

No space in ;restart :slight_smile:

By the way, you can wrap your text in ``` on either side to make it look

like this