[solved] Issues with update "disk full. need 400m"

I had to reboot, using the white button on the underside of my Norns.
I can now install and update scripts via maiden, and functionality seems OK. However, when I check SYSTEM->UPDATE

I get the message : “disk full. need 400m.”

Have i corrupted the drive ?

hi hi!
your norns storage might just be approaching full — if you hit K2 on the SELECT/SYSTEM/SLEEP menu, that’ll toggle some system stats. what number do you have next to disk?

“cpu 3 2 0 0 59c
disk 0M”

the “disk 0M” … could that be an issue ?

I also just tried to install a script

;install GitHub - schollz/norns.online: online norns with norns.online


install failed: mkdir /home/we/dust/code/norns.online/.git/refs/remotes: no space left on device

So perhaps I do not have space left on device. Is there a process to remove scripts to make space ?

ah, yep! disk always displays the amount of storage left, so your device is totally full.

you can manage the storage of your norns via the steps listed in the transfer section of the norns wifi+files docs. scripts are super tiny, so i’d recommend transferring any downloaded audio libraries (eg. the mx.samples script can encompass a few gigabytes of audio if you’ve downloaded all of those offerings) or your TAPE recordings first --these files can be quite large.

edit: if you just want to go the delete route (so no backup), you can also remove files via maiden – just highlight the file you want to nuke and hit the - icon in the filebrowser:

let us know how it goes!


Tapes was the issue, I deleted the directory after doing a backup. I now have 1783m
You were correct, I must have been recording without realizing.

Thank you for your help, much appreciated :slight_smile:


Hello everyone,

I have run into the disk full issue with my norns when trying to update and have started following the steps on the website. I now cannot get my norns to turn on or do anything when the switch is in disk mode. When in run mode it still powers on correctly. Any ideas/advice?

you shouldn’t need to switch to disk mode— try switching it back to RUN, boot normally, turn on maiden, and delete some TAPE files as shown above.

Yes, I have deleted everything from the memory including all apps. Thank you!