[SOLVED] Midi connection problems with norns shield

Hi everybody! I’ve just got my Norns Shield. I’ve tried to connect my controllers to the USB ports, but I cannot get a sound. :frowning:
What I’ve already tried:

  • I tried Arturia Keylab 88, Arturia Minilab, Arturia Beatstep pro
  • Norns Shield is updated to the last OS version
  • I can see my controllers recognized in the “Device - Midi” section of Norns
  • My controllers are also well recognized inside the parameter editing of the scripts in norns
  • My controllers work perfectly with other devices
  • When I try to map, I see it changes CC assignement. It seems to work. But again no sound when I press a keynote on my controller, in any script available.

I’m quite desperate. Thank you for your kind support.

Do scripts that make sounds without midi work? You could try showers to test.

This will help us figure out if the problem is with your MIDI or your audio out.

And just to rule out one simple possibility - you do have headphones or a speaker plugged into the audio out port, right?

also for most script you need to select the midi device to bind to in the PARAMS menu (they’ll generally default to the first entry).

some other scripts will only bind to the first declared midi device in the DEVICE > MIDI menu.

Hi. Thank you for your kind reply. I list my comments:

  • All scripts make sound correctly. The problem is only on midi coupling
  • I have headphones or speaker connected, yes
  • After several trials I could get a response, but it looks like there’s a sort of bug.
    I mean, Icarus script doesn’t work connecting my controller, I only see the visual, but no midi signal working. I’ve tried molly the poly, but also awake, and finally I let it work, but only going to the edit parameters, where my controller was correctly mentioned, and changing setting of device and channel twice. Once settings were exactly like at the beginning it started working. I even tried a script to test midi port, and again it didn’t work, even though it found “arturia minilab mk2”, but changing device selection and selecting back “arturia minilab mk2” it started to respond to midi commands, showing me all midi details in real time.
    That’s really strange. And not all the script support the possibility to set it. My idea is that the device is recognized, but something is blocked when passing this info operatively to the scripts. Then refreshing this setting on the script parameters it starts working (not always, and not for all the scripts).

PROBLEM SOLVED! I’ve just disabled the passthrough and everything has started working perfectly! Thank you

1 Like