[SOLVED] Monome 128 and 64 not showing up on OSX sierra

**Hi, I read through as many searched articles as I can and can’t find a solution. My 2 monomes are consistently not showing up in a variety of max 8 and max4live patches. Sometimes they do, then they don’t, I reboot and they work again, 10 mins later gone again. I have the latest serial osc from github, I’ve tried everything on the serialosc setup page and I’m getting the; **
ls: /dev/tty.usb: No such file or directory **
response to ls -lrt /dev/tty.usb

but I have confirmed no conflicting ftdi drivers (Response is AppleUSBFTDI.kext only)
I have tried ** ** launchctl unload /Library/LaunchAgents/org.monome.serialosc.plist** ** launchctl load /Library/LaunchAgents/org.monome.serialosc.plist** **
but this changes nothing.
I have tried multiple usb cables. Gridtest max patch tells me serialosc is running but no grid shows.
Very glad to have ansible right now, but was looking forward to learning some max with grid during lockdown.
Maybe @tehn has a fix for this?
Thanks

edit; rebooted yet again and grid is recognised in terminal, then unplugging/ replugging even once means that the grids are no longer recognised (in terminal and max)

hey! sorry to hear about the trouble.

this is where things are getting hung up – your grids are not being recognized as a present device by your Mac.

working on this through email will be best: help@monome.org

some quick ideas: if you have any TouchOSC drivers or configs, those might be consuming the ports that the grid needs to operate.

also, does an Activity Monitor search of serialosc return similar?:

hey @dan_derks
thanks for the reply. Did you see the edit in my post? unplugging seems to kill something. Weird

just did. hmm.

let’s move to email:

  • are you using USB-C, by any chance? some hubs + dongles simply won’t work with serial on later MacOS’s.
  • can you send me a screenshot of what you see when you navigate to About This Mac > System Report > Hardware > USB > monome?
  • in Terminal, what returns from ls /Library/Extensions ​?
  • what returns from ls /System/Library/Extensions ​?
  • what returns from ls /usr/local/lib ​?
  • and ls /Library/Application\ Support ​?
  • try killing serialosc’s processes in Activity Monitor, then plug in the grid and see if they repopulate + if Max/M4L sees them.
  • confirm you have no TouchOSC or Wacom drivers installed?

i dont get serialosc-devic like on your monitor but do get the other 2

ok I’ll take to email, thanks

1 Like

resolved through email, so closing the public loop!

Wacom’s MacOS drivers have started conflicting with monome device connectivity. if you run into similar trouble and have installed drivers for a Wacom tablet, try removing it using these steps:

1 Like