[SOLVED] Norns engines not available

Somehow I can not use any scripts, since the engines are not availible.

tab.print(engine.names) returns 1 Ack 2 None, even though e.g. the we package and passerby is installed.

Does anybody have an idea?

did restart after installing scripts

Multiple ones. Still not working…

How did you install the engines (and scripts)?

What are the file paths in dust/code?

What norns version are you running? (Is this after an update? And we’re they working previously?)

1 Like

Right now I removed all the scripts via maiden (and removed the all the respective files from dust/data/)
Then only installed ack via maiden, which makes the engine availble.
I then installed awake via maiden and via ssh with git clone directly from the repository. In both cases the PolyPerc engine did not become availible.

/home/we/dust/code/awake
(I do not know if I understood the question corretly :slight_smile:)

I updated to the current version (200604) when I tried the scripts today. I also manually reinstalled the current update.
Nevertheless, the engines might not have worked before the update - I only tried it once the last weeks and iirc I had the same errors…

Thank you! :slight_smile:

And then… how are you restarting? Are you doing a SLEEP cycle or ;restart in maiden? If the later - are you also doing ;restart in the SC REPL tab?

Supercollider needs a full restart for engines to be properly included.

1 Like

I did SLEEP cycles. But right now also tried restart in maiden of matron and sc (without any success)

are you using a stock norns? or shield?

either way, i think a fresh install might help get to a good square one to troubleshoot from. https://monome.org/docs/norns/help/#fresh-install for stock, https://github.com/monome/norns-shield for a fresh shield image

2 Likes

I have a stock one - alright, will go with a fresh install!
Thank you!

1 Like

The fresh install did the trick. Thanks all! :slight_smile:

2 Likes