[solved] norns fresh install trouble

I want to do a fresh install on my norns as all other ways I tried for reliable saving an arcology preset failed.

Unfortunately, my norns is not recognized by my computer, Etcher is trying to initialize the device “Computer Module” for a while without progress, then the line with “Computer Module” is gone and I can’t move on.

Please, can somebody help?


sorry to hear about the trouble! i was able to repro the line trailing across and vanishing, but then i always get this after a few seconds:

curious about:

  • is the light on the rear of the norns is illuminated at the end of this process?
  • while norns is connected in DISK mode, please open terminal and execute diskutil list
    • do you see a result for an (external, physical) device similar to the following?
/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *31.3 GB    disk2
   1:             Windows_FAT_32 ⁨boot⁩                    45.2 MB    disk2s1
   2:                      Linux ⁨⁩                        3.9 GB     disk2s2
                    (free space)                         27.4 GB    -
  • does the issue persist if you’ve restarted your machine, toggled norns back to RUN, connected norns to your machine and flipped the switch to DISK to try again?
  • what MacOS version are you running?

for what it’s worth, i was just able to copy/paste the MacOS commands listed here to reflash a stock norns via the command line: norns-image/readme-usbdisk.md at main · monome/norns-image · GitHub. i know this can feel a bit more involved, but the instructions do work!

Thanks for your help – the rear light was lit, I did not see an external device in Terminal > diskutil list, restarting norns did not help, I run macOS 10.14.6.

My last resort was to try different USB cables: All of the cables I tried worked when charging my norns or connecting my grid to the norns. But only the third cable I tried allowed Etcher to connect to the Compute Module – from there on everything went smooth.

I will now mark this cable, put it into a safe, and felt the urge to tweak these lyrics:
What price the crown of a king on his throne
When you can’t connect your monome?

2 Likes

ah yep! the cable would’ve been my next guess with this news – fantastic that things worked out without much more prodding!!

edit: i ended up recording a quick walkthrough of the command line fresh install process for Mac users with stock norns, in case it helps future travelers:

3 Likes

Was pulling my hair out trying to get my norns to initialize. After finding this thread it was a simple case of combing through the usb cable drawer to find one that worked. And I did. And it does! So thanks both!

1 Like