[Solved] Norns "preparing..." hang on update

Hello good monome folk,

I was attempting to do a system update from norns today, haven’t updated it in quite awhile and am hoping to play with it more now that I’ve got my system set up again. I must have done something wrong because it’s hung up on “preparing…”

I found an old update topic that suggested doing an ssh into it and running some code. Is there a step-by-step on how to do that if one’s knowledge of Terminal is a little loosy goosey? Is to turn off the norns or do I have to let it drain the battery?

Thanks for any insights anyone can give.

[Update: found an old-school paperclip kill switch on the bottom of norns, so I got it shut off.]

[Update: After starting up my norns again, I successfully did the ssh into norns thingie. Went to my Mac’s Applications/Utilities folder and fired up Terminal. Then followed the instructions here: Norns: help - #84 by adrianf]

[Update: Having made it to the prompt via ssh I modified the manual update advice in this post: Norns: update 200424 - #5 by tehn to point at the latest non-beta version at the monome norns github releases page – basically grabbing the link for the tgz and then swapping in the relevant release date numbers for the other lines of code for the manual update.

When I updated this way I got a couple errors, something about maiden and maiden-rpl File exists but when I rebooted life was good.

After rebooting my norns now reports that it is “up to date.”

I’m leaving this topic here as a Problem Solved and reminder to myself if I need to do this again sometime. Thanks everyone for leaving enough breadcrumbs that I could figure this out on my own!]

2 Likes

Here’s the step-by-step version for people on a Mac based on the contributions referenced above

Situation: something went sideways while updating a norns and you’ve been looking at “preparing…” for a very long time.

  1. Turn off the norns: on the bottom is a little hole with a button inside, stick a paperclip or something similar into that and press the button until the screen goes dark. The norns is now off.
  2. Turn the norns back on by pressing and holding k1 as you normally would. It’ll be just like it was before you started the update process. Since the built-in update failed it’s probably best to do a manual update.
  3. Make sure your norns is connected to your network by looking at the systems parameters. Also, have your computer ready to go. We’ll be using the computer to do stuff with norns.
  4. On your computer, open Applications/Utiliities/Terminal. This is a text interface to access all kinds of interesting things on your computer and elsewhere. We’re going to use it to communicate with norns.
  5. Copy/Paste the following into Terminal:
    ssh we@norns.local
    This code is telling Terminal that you want to be working with your norns.
  6. You will be asked for a password to log into norns. The password is: sleep
  7. You are now logged into norns. Hooray!
  8. Paste the following code into Terminal:
    cd update
    This tells Terminal that you want to “change directory to” (aka “go to a folder named”) update.
  9. In order to update we need to know what version we’re updating to. All of the updates to norns are over on GitHub at this page: https://github.com/monome/norns/releases/download/ Keep in mind that this includes beta versions (versions that might still have some bugs). Go to the page and scroll down until you find the most recent entry that isn’t a beta. At time of writing this the little Tag icons on the left include “beta” for beta versions. So look for the most recent entry that doesn’t have that tag.
  10. Now that you’ve found the entry you’ll need to know the address of the tgz (a kind of compressed collection of all the software you need to update). I found it by clicking the little triangle next to “Assets” and then then copying the link (right click/command-click/two-finger click) for the tgz entry. Once you’ve done that, you’re done with Github.
  11. Back in Terminal enter the following:
    wget then a space and then paste the address you copied in step 10.
    When I did this process this is what I entered, yours will be different if you’re installing a version that is more recent:
wget https://github.com/monome/norns/releases/download/v2.5.4/norns210706.tgz
  1. Notice at the end of that address, the file name is “norns” plus a string of numbers. That’s a date (yearmonthday). You’ll need that for some of the next steps.
  2. Now in terminal enter the following:
    tar xzvf then a space and then filename you noticed in step 12. When I did this step it looked like this:
    tar xzvf norns210706.tgz
    I think this is telling norns to unpack all the files bundled in the tgz thingie. There may be lots of scrolling in Terminal as it upacks everything. Let it finish and return to the prompt before continuing.
  3. With everything unpacked, we need to go to the folder on norns that has the update. Enter the following in Terminal:
    cd and then a space then just the date numbers you noticed back on step 12. When I did this step it looked like this:
    cd 210706
  4. We’re ready to actually do the update! Enter the following in Terminal:
    ./update.sh
    A bunch of stuff might happen and it might take some time, wait it out. There might be an error or two. But probably nothing worth worrying about. Just let it do its thing. When it’s done restart the norns.
  5. You are now updated! You can confirm this by going to the systems parameters and checking for new updates. If everything went as planned norns will tell you that you’re up to date. Congratulations! Now go have fun with sound! :slight_smile:
3 Likes

Thank you so much! Very helpful guide and now I finally have a fully updated norns shield again :sparkling_heart:

Hi, I have the same issue, trying to update from an older version.
I followed all the steps above (trying to upgrade to 220802).

When executing the update.sh script, I’m getting the following error:

192.168.2.65 ~/update/220802 $ ./update.sh 
needs new disk image, aborting.

Hi Martin! The error makes it very likely that you need 220306, which requires you to reflash your norns with the new disk image before you can then upgrade to 220802. I believe the instructions for reflashing norns are linked in the thread above, but you can also find them here.

1 Like

Oh… Thanks a bunch for those instructions.
I will reflash Norns with 220306 and then run update again.
Cheers

UPDATE:
Upgrade to 220802 successfully done along with file expansion.
Note: I had to use Etcher as Pi Imager was unable to detect the Compute Module.

Thanks again. :+1:

1 Like