[SOLVED] Norns shield sd card almost full.... fat 32 issue? Help please

Setting up norns and load up my sample lib re arranged to fit timber but now in samba, finder shows norns has only 250mb space left while hardly 2gb of the 32gb sandisk are used…

I read here to format to fat 32 wich i did, is this a limit? Is there a workaround?

eep! have you given expanding the filesystem a shot?

1 Like

Thanks, is that a pre or after method? .: )

it’s an after! give it a go!

1 Like

Lifesaver!! Thanks for the linkup

oh, awesome, worked out??

Yup, easy peasy if just knowing what to do…i thought corrupted files first.
Btw got supercollider error at reboot, bit back to normal after 2nd reboot

1 Like

This happens to me and is usually a sign that your power supply isn’t quite up to the task. You can do a System->Reset instead to clear it without fully rebooting.

Also check dmesg | grep -i volt to confirm it’s a power issue.

[edit because i think it’s valuable info and i just like sharing it everywhere: System->Reset just uses systemd to reset the Norns services. It’s a reboot of the monome stuff layered over Raspbian!]


Hi Dan. At the risk of sounding like a real dummy (which, when it comes to terminal and lots of other things, I am), I’m giving this a go right now and terminal is returning: zsh: bad pattern: /dev/tty.usb[tab

Some deets:
-The rpi is connected to my computer via USB at the pi’s USB mini port and is powered on
-I’m entering this exact text, which is probably wrong: screen /dev/tty.usb[TAB KEY] 115200
-I had pizza for dinner
-This is the end of the list


the tty.usbserial format only applies on mac

if linux, it’s ttyUSB something

on windows should show as a COM port in putty or &c

on lnux or mac, type ls /dev/tty* to get a list, look for anything that isn’t just a number like tty23, or anything that disappears / reappears when you unplug/replug the pi

in fact, you’re saying zsh makes me guess this is a new account on Catalina b/c they have made it the new default. i guess they could have changed the device string pattern for usb-serial devices.

I am indeed on Catalina.

ls /dev/tty*



/dev/tty /dev/ttysf
/dev/tty.Bluetooth-Incoming-Port /dev/ttyt0
/dev/ttyp0 /dev/ttyt1
/dev/ttyp1 /dev/ttyt2
/dev/ttyp2 /dev/ttyt3
/dev/ttyp3 /dev/ttyt4
/dev/ttyp4 /dev/ttyt5
/dev/ttyp5 /dev/ttyt6
/dev/ttyp6 /dev/ttyt7
/dev/ttyp7 /dev/ttyt8
/dev/ttyp8 /dev/ttyt9
/dev/ttyp9 /dev/ttyta
/dev/ttypa /dev/ttytb
/dev/ttypb /dev/ttytc
/dev/ttypc /dev/ttytd
/dev/ttypd /dev/ttyte
/dev/ttype /dev/ttytf
/dev/ttypf /dev/ttyu0
/dev/ttyq0 /dev/ttyu1
/dev/ttyq1 /dev/ttyu2
/dev/ttyq2 /dev/ttyu3
/dev/ttyq3 /dev/ttyu4
/dev/ttyq4 /dev/ttyu5
/dev/ttyq5 /dev/ttyu6
/dev/ttyq6 /dev/ttyu7
/dev/ttyq7 /dev/ttyu8
/dev/ttyq8 /dev/ttyu9
/dev/ttyq9 /dev/ttyua
/dev/ttyqa /dev/ttyub
/dev/ttyqb /dev/ttyuc
/dev/ttyqc /dev/ttyud
/dev/ttyqd /dev/ttyue
/dev/ttyqe /dev/ttyuf
/dev/ttyqf /dev/ttyv0
/dev/ttyr0 /dev/ttyv1
/dev/ttyr1 /dev/ttyv2
/dev/ttyr2 /dev/ttyv3
/dev/ttyr3 /dev/ttyv4
/dev/ttyr4 /dev/ttyv5
/dev/ttyr5 /dev/ttyv6
/dev/ttyr6 /dev/ttyv7
/dev/ttyr7 /dev/ttyv8
/dev/ttyr8 /dev/ttyv9
/dev/ttyr9 /dev/ttyva
/dev/ttyra /dev/ttyvb
/dev/ttyrb /dev/ttyvc
/dev/ttyrc /dev/ttyvd
/dev/ttyrd /dev/ttyve
/dev/ttyre /dev/ttyvf
/dev/ttyrf /dev/ttyw0
/dev/ttys0 /dev/ttyw1
/dev/ttys000 /dev/ttyw2
/dev/ttys1 /dev/ttyw3
/dev/ttys2 /dev/ttyw4
/dev/ttys3 /dev/ttyw5
/dev/ttys4 /dev/ttyw6
/dev/ttys5 /dev/ttyw7
/dev/ttys6 /dev/ttyw8
/dev/ttys7 /dev/ttyw9
/dev/ttys8 /dev/ttywa
/dev/ttys9 /dev/ttywb
/dev/ttysa /dev/ttywc
/dev/ttysb /dev/ttywd
/dev/ttysc /dev/ttywe
/dev/ttysd /dev/ttywf

sorry, i realized that i don’t totally understand what you’re trying to do. i assumed you were using some additional hardware to connect to the UART pins on the raspi. but reading again it sounds like you’re trying to power the pi from your host computer USB (not a good idea in itself) and also use that usb connection for communcation (which won’t work.) i’d recommend searching on the raspi fora / docs on how raspi UART works if you need it.

the instructions you reference are for installing an upgraded compute module on factory norns, which includes a dedicated serial-miniUSB adapter on the PC board.

if you just need to login to the pi for troubleshooting network (or whatever), the easiest way is to just attach an HDMI monitor and USB keyboard.

if networking is set up, and you can shell in with ssh, you can access raspi-config that way to expand the filesystem or whatever


ah, that was missing from my understanding of the process – apologies! i didn’t realize the steps outlined were only for factory norns.

which makes me wonder – @Hlp, how the heck did you do this using those steps?

That’s what I tried first, and I got as far as being asked for the password in terminal. I tried “sleep” and “nnnnnnnn” and neither worked. But also, was at the end of a very long day, and sounds like I just need to poke around a bit more. I assume there’s a Dummies guide to all of this somewhere online. Will report back if I have success. Thanks guys.

My old macbook runs capitan still and i used wifi to ssh, no idea where the issue might be, worked perfect for me.

So I think the (embarrassing, albeit honest) reality here is that I don’t know how to SSH into norns.

The docs take this knowledge for granted, and maybe that’s fair. Apologies for the hand holding.

I’m entering ssh IP.IP.I.P in Terminal on my Mac running Catalina (but, like, the IP address listed under "wifi: on norns. Terminal then asks for the password. There’s an icon of a key, and I can’t see what I type from that point forward. But I’ve tried “sleep”, “nnnnnnnn” and “raspberry”.

There’s some info regarding ssh access that suggests altering the root image, but I’m assuming this is moot since the norns image is much different than Raspbian, et al.

Anyway, let me know if what I’m doing is way off base. And pretend you’re talking to someone who is technically proficient in the meat world but inexperienced with terminal/coding/etc.

  • open a terminal
  • ssh we@norns.local
  • pw: sleep

the instructions for disk expansion should be changed to use ssh instead of serial connection as it applies to both shield and norns

1 Like

You did turn on wifi on the norns and tried it via wifi right?
When logged in you should see green numbered IP adress right after password was entered

1 Like

Ah, thank you @tehn. This worked like a charm. I am expanded and flush with disk space.

1 Like

I would humbly request that the docs include these instructions when they read “ssh into Norns”. For people at my, uh, skill level. :smile:

1 Like