[SOLVED] Norns Shield wifi/wired connection and midi

Hi All,

I just put together a Norns shield and a have a few basic questions. I would be particulary grateful to anyone on Windows here.

  1. My Windows 10 desktop has a wired internet connection. I don’t have a laptop. I have connected my Norns Shield to my Wifi. I’ve tried the steps on the wiki but the basic issue is that my PC is wired and my Shield is wifi. So the crux here is they won’t be able to see each other yeah?
  2. Also, If I try ‘update’ it just hangs there ‘checking for update’ and doesn’t do anything… So how do I know if the wifi connection is working ok on the Norns Shield? Is there some kind of check possible?
  3. Assuming I get the communication thing sorted, I really want to be able to send midi in and out of Norns. How is that done when the Norns usb connection is not recognised by my PC, i.e. the small USB connector is power only and is not recognised as a host USB device? I have an old Midisport USB 2x2 and but that needs drivers. Any idea how are they put onto the Shield/Raspberry Pi?

Would I be correct in saying that midi out and using Norns to control other instruments is really not what it was designed for. And also, it’s really not friendly with PCs either?

First of all, starting your Norns, check in the settings if is connected to your wifi network.
If yes, then try to browse the Norns address from your browser on your PC, eg: http://192.168.0.100; be careful that both devices are in the same subnet … but these are always the usual Windows problems …
The Maiden management interface should open for you; this means that your Norns surfs the net, probably accesses the internet and therefore you can potentially update it.

1 Like

I think the basic issue is you’re connecting two USB hosts when going Norns <-> PC. For example see 2host - a DIY USBMIDI host-to-host adapter, search around the forum with those terms for more info.

That said I use midi out from Norns though to a hardware synth. I think if you get your USB host issue sorted you’ll be set.

2 Likes

1+2. Look up how to SSH and then see if you can SSH into the shield. You’ll have to know your local IP to ssh or use maiden if you’re on Windows. If you can do either then you’re connected to WiFi, and then you’ll know where it’s hanging when updating.

  1. The usb-c connector will work as an otg on the Pi4 but you’d have to finagle some stuff that wouldn’t be particularly easy on the norns image. 2host as mentioned above would work but honestly I bet that midisport will work, especially if it’s class compliant.

Hi guys,

Thanks so so much for all the help. I have now managed to get Norns/Maiden to connect to my Wifi and desktop. All working 100% on Windows.

  1. For getting midi in and out of Norns, as I said, I have a Midisport 2x2 but it is not recognised by Norns. Could anyone give me a few details on getting a USB midi interface to work with Norns, e.g. an example of a USB interface they have that works with the Norns (Shield) system?

Thanks

Drew

class compliant devices (not requireing firmware/drivers) should Just Work.

basically if it is supported out of the box on linux it will be supported on norns.

linuxaudio.org maintains some information on devices with linux compatibility, e.g.:
M-Audio Midisport 2x2 [Linux-Sound]

(this page claims that the oldest versions of midiport 2x2 required drivers but newer revs are class compliant.)


ok some caveats / pitfalls:

  • devices / endpoints which expose only a midi out, and no midi in, will not work at present. (known bug in norns software.) the only time i’ve actualy seen this is with the korg sq-1, which enumerates as separate devices for input and output. but i’m sure it happens other places.

  • there is a limit to how much current the raspi can provide to bus-powered devices.

off the top of my head, i have successfully used these things as USB midi endpoints with norns:

interfaces:

  • roland um-1 (1x1)
  • m-audio midisport uno (1x1)
  • DOREMiDi Hub 3 (2x4)

controllers:

  • arturia beatstep pro
  • korg sq-1 (input only)
  • various other USB keyboards

synths:

  • korg minilogue xd
  • moog grandmother
  • roland se-01

but the bottom line is that i have had very few instances of devices which didn’t work, and in all those cases (besides the output-only issue as mentioned) the device did not properly implement the USB midi spec and did not play nice with linux either. (looking at you, “logidi UMI3” foot controller.)

Zebra - my Midisport is an old batch, but just tried a few other keytboards I have, Arturia and Yamaha YC and they both show up as midi devices so I’m sorted!
Thanks so much again for everyone’s input. Such nice people!

1 Like