[solved] Norns wifi issue: string syntax error in maiden

this might not belong here but the norns:help thread appears to be locked. i recently got a secondhand norns and on the wifi menu the status and ip address are blank. i also had to use nmtui over serial to set up the wifi connection. this is obviously not catastrophic–i was able to ping norns.local to get the ip address etc.

but if i open the wifi menu while i have maiden open i get a repeated error message (repeated as in every couple seconds ad infinitum):

sh: 1: Syntax error: Unterminated quoted string

i poked around looking for a likely culprit wifi-handling script in the filesystem but came up empty. where can i poke around to find this missing quote?

Obvious dumb question… do you have the WiFi usb “nub”?

OG Norns does not have WiFi built in.

1 Like

yup, i’m on wifi, communicating via maiden, ssh, osc no problem besides the syntax complaint in maiden and the incomplete information display on the norns screen. there’s intermittent connection issues requiring a restart too that i suspect are related.

are you on the newest update?

i am, i ran the update via wifi earlier today

haha i figured it out, i have an apostrophe in the name of my wifi network. going into nmtui and changing the connection name fixed it right up.

1 Like