(SOLVED) Please help me find a good linux audio distro for my netbook

As the title says, I’m looking for a decent audio distro that can run on my older eeepc and since many on this forum seems to know their way around linux I thought I’d ask.

What my setup looks like (both mostly live oriented):
I basically have two setups right now:

  1. modular+octatrack
  2. octatrack+looper+some desktop synths and fx

What would I need the eeepc for:

  • To load and manage samples on the OT
  • as a sequencer with Seq24 or one of the newer forks
  • To record multi-track audio (4 tracks using a Zoom H5)
  • with setup nr.1 to play long audio files (field recordings) and apply some fx to them.

Right now I’m running a stock Linux Mint on it, but maybe something more audio-optimized would spare me some time setting things up to work properly… but there’s really a lot, and trying them all out myself isn’t really a great idea. so if anybody has a suggestion, let me know!

2 Likes

Don’t use linux myself but bumped into avlinux the other day…

1 Like

Yes, that one looks interesting. It ticks many boxes, I only have to see if it’s lightweight enough. KX also seems interesting but it uses KDE and that might not go along well with my netbook.

1 Like

Regardless of what you will choose, I recommend you install the KXStudio repositories anyway. I recommend you try both the AV Linux live ISO and the Ubuntu Studio live ISO and compare the performance. Hardware compatibility might be a bit better with the Ubuntu Studio 16.10.

(I’m running vanilla Ubuntu 16.04 with the KXStudio repositories, I have no first-hand experience with those two.)

1 Like

I had Ubuntu Studio with the KX repos installed on a first gen Dell XPS laptop and the performance wasn’t the best. It’s probably not going to work really well on a low-spec eeepc. I was hoping to find something more minimal…
But I totally agree about the KX repos!

Did you check with top what was hogging the memory/CPU? In my experience, it’s usually the WM. So, a minimal one like Awesome is a good pick with old laptops. Haven’t bothered to compile custom streamlined kernels since the 90s. =)

Slightly off-topic - interested which looper you use, whether you currently use the octatrack as looper-synced performance sequencer?

This idea is fascinating to me, but for a long time struggling to realise an implementation with useable workflow, just decided to give up & go deeper into the ‘nonlinear’ (as in nonlinear editor) possibilities of boomerang looper, forgoing any sequencing possibilities.

For now, I view a ‘sequencer rig’ as separate project to my ‘looper rig’, try to have more of a composition-driven setup for my modest collection of cheapo midi synths. From a little play last night, seq64 seems most intesting in this respect (I mean the composition side of things).

As for linux distro well like many others on here I eventually gave up on debian-based distros & now do all my work on super-minimal arch linux setup running linux-RT & tiling window manager (currently dwm). Bit of a rabbit-hole I guess but works for me!

1 Like

In 2009 I used Pure-Data for recording and triggering of 1-48 audio samples of arbitrary length simultaneously. I was running Fedora with Xfce on an Asus Eee PC seashell notebook (these were $2-300 at the time) with an Edirol-Roland UA-25ex audio interface.

I have a Boss RC-505 and it’s synced to the OT. For that set I use the OT mostly for drums/percussions and the looper to loop short bits of melodies, build up drones and stuff like that. (example: https://soundcloud.com/kvsu/lxj133-swimmingpool-version-live)
I don’t use the sequencer on the OT mostly because I don’t need it for the way we play live. I do everything with the looper and the only sequenced stuff is the drums. My bandmate does use all sorts of sequencers (the one on the microbrute, plus the tape stuff on the OP-1) but he has to do the vocals as well and he can’t do everything.
This said, for other projects I have in mind I might as well try the sequencer on the OT, since it’s pretty cool and you can do all sorts of tricks with it.

I eventually gave up on debian-based distros

What made you give up on it, if I may ask?

yes that’s the eeepc I have (more or less). I really need to get back into PD… that would make so much sense on linux…

3 Likes

Realised all the cool kids had moved onto arch! Seriously though, think the real turning point for me was when canonical added that notorious ‘amazon spyware’ feature into their default ubuntu install.

Ever since the switch, I’ve had a much easier time compiling new software off github or whatever from source. Arch linux package maintainers are much more ‘hands-off’ - you seem to pretty much get the upstream, bleeding-edge releases of all software without compiling everything manually like in ye olde slackware days.

A potential downside for some people is that you end up building half your system from scratch with arch linux. Of course if you intend to use some weird tiling window manager, rather than a ‘regular’ desktop environment, this is a feature not a bug!

1 Like

As an avid and very happy Debian user, i want to state that Debian has nothing to do with all the bizarre and discutable choices made by Canonical !
In its standard form Debian explicitly refuses any non-free software.
(a minimal debian install + fluxbox would be my try on an eeepc).

3 Likes

Apologies I shouldn’t say ‘debian-based distros’ when really I mean various ubuntu flavours…

1 Like

I’ve run the AVlinux liveISO and it looks decent. I couldn’t get any sound out of it as usual though :smiley: will keep trying…

1 Like

Yes, in theory, this would make sense. However, when I last looked into it (about a year ago), it wasn’t really straightforward to use the KXstudio repositories with a bare bones Debian install. (I forgot the exact details.) Maybe things have changed.

So… first try was a waste of time. installed AVlinux, but the sound wouldn’t work (not with the built-in card nor with the H5). The H5 wasn’t picked up at all…
I’ll try something else… thinking about it, I guess I don’t need an audio-optimized distro at all. I’m not doing anything that will need low latency or audio-specific stuff.

Alter a bit of late-night tinkering I’m starting to feel this is going to be a dead end.
as previously mentioned AVlinux had a problem with Alsa not detecting the audio hardware.
Tried Puppy Studio, but it wouldn’t boot from the USB stick. The official Puppy would boot, but not install. KXstudio is way too bloated, mostly due to KDE, which is even worse than I had remembered. Plus the colour scheme they chose is terrible usability-wise. Tried XFCE Linux Mint (that at least would run properly) removing Pulseaudio, and adding the KX repos. Audio works fine, even with Jack, but a lot of software wouldn’t be installable, and I keep getting errors about broken packages, unretrievable dependencies. etc. So I see nothing has changed with linux in the Last years. :slight_smile:

So now my ideas are two:
a) I keep Linux Mint and build myself a wav player and some other utilities with PD (but I need to get back into it) and see if I can get it to work with my MIDI controller. Btw. I tried to compile both Seq42 and Sequencer24… but somehow when I type ./compile it will complain about not finding it… but doesn’t matter.
b) I ditch the idea and do some of what I wanted to do with an Axoloti… which has the advantage of being a lot smaller and more purpose oriented and use the netbook just to manage samples on the devices.
I’ll probably go with b… since I forsee myself getting frustrated pretty quickly with PD…

This sounds all-too familiar but the linux experience can be rather different under arch. Since there are no ‘releases’, all libraries seem to stay up to date & I have yet to experience full-blown ‘dependency hell’ a full year after switching to pacman/yaourt (arch’s package tools). As I warned earlier, though, system setup is laborious, requiring lots of (well-documented) terminal wizardry.

I mean, linux still sucks in many ways but definitely tearing my hair out less over pointless crap these days…

this blog post helped me install arch on a macbook air, no problems:

3 Likes

I think my problem is mostly that I’m trying to run linux on an old and kind of crappy hardware (at least so it seems). I used to have Ubuntu Studio on a XPS laptop and that worked mostly fine. The XPS was sold with Ububtu preinstalled at the time, and the hardware is pretty well supported, so that makes many things a bit easier. At the time I gave up on it, because I wanted to use my firewire interface with it, but enabling firewire audio in Jack would then conflict with ALSA midi… plus the firewire chipset on the XPS is crap and was creating audio dropouts (not a linux problem though= plus there were a bunch of other deal-breakers, which made me give up at the end.
I actually would go through all the terminal wizardry, not that I have a problem with it… but this whole netbook project was mostly for convenience, and because I had a spare one lying around. It was worth a try, but it’s def. something that is taking more time than it’s worth (I guess naively thought it would be an easy walk, like with the XPS).

Thanks! If I ever give it another try, I’ll def. check this guide. Well actually, I’ve browsed through it and the sheer length of the page proves that this is not something I should do now… :slight_smile:

1 Like

yes it took a while. not click-install at all. but i’m super happy with the install now that it’s on.

1 Like