[SOLVED] Teletype - Just Friends i2c not working

Hi everyone, today I received some jumper cables to finally connect teletype and just friends but doesn’t matter what I do, they won’t speak to each other.
I tried different length cables on every pin both on JF and TT with no luck.
Every cable ‘testing’ consisted in an INIT script that should have switched mode on JF and a simple JF.TR 0 1 to fire all JF’s trigs.
My just friends is from one of the latest batch from the factory, I got it in January 2021, works flawlessly, just updated the firmware to the latest release.
Teletype is actually a diy Terminal running v 4.0.0 (assembled by a very reliable builder)
Any idea what can I try next?
What might be causing the issue?
Perhaps do I have to enable something?

I can only think of two things

  1. make sure your i2c connection is correct, sda, scl and ground connected to each other
  2. sounds like your teletype hasn’t been confirmed as having a working i2c, maybe it’s something to do with the build

Then there’s the user :grinning: it sound like this is your first i2c with teletype, if so, I’d be extremely systematic in testing. I often accompany script debugging with TR.P 1 through 4 in the same script so I can see when/if the teletype actually is running the code.

Maybe you could upload the script you’re using for testing (through USB stick export to avoid any typo confusions), that would make it much easier than talk about this potential part of the problem.

Hi thanks for the answer

Definitely my first i2c experience but i checked the SDA/SCL/GND connection literally 40 times (all cable/i2c port combination possoble) but perhaps it was wrong all along so see the following pic - GND red / SCL orange / SDA yellow -
The builder says he’s sure the i2c on teletype is working.

The test scene I’m running:

INIT.

JF.MODE 1

JF.VOX 1 N 0 V 5

JF.TR 0 1

TR.P 1 100 (just for visual feedback)

Have you tried skipping the init script and just entering the JF.mode commands from live mode?

Agreed w/ @Justmat, try inputting commands from Live mode. Your I2C looks good.
Try JF.TR -1 1 on the Live screen in case you’ve accidentally got JF set to its secondary address. You might want to update the JF firmware, too.
Is there any other I2C modules you could try? Ansible, Earthsea, etc, can be made to lead the I2C bus and send notes to JF.

Yep tried different commands in the live mode but none is having any effect.
Even JF.TR won’t work.
JF.CURVE always returns 0 as well as JF.RAMP.
“IIA” is returning -1, not sure if that’s relevant

Nah, that’s for the generic I2C OPs. JF has a full suite of its own OPs.

Tried JF.TR -1 1 and other commands, nothing happened.
Already updated JF fw twice.
Unfortunately I don’t own any other i2c enabled module.
I think the problem might be my Terminal, even though it is brand new i’ll try flashing its firmware.
Or might be a faulty JF?

Flashing the TT firmware isn’t going to do anything so don’t bother.
The homebrew TT is more likely to be at fault than the JF, here. Can you check to see whether resistors R5 and R16 are populated?
I think the best thing for your situation would be to find someone nearby who can help you test using additional modules, or to send both your JF and TT to the builder for them to determine the issue.

R5 and R16 are populated Σ('◉⌓◉’)


The builder told me the Terminal was industrially populated by a pick & place machine so it should be fine. Or at least i hope so! The worst scenario is JF being faulty because that would mean sending it overseas (i’m in EU). Gotta find someone with some i2c modules to test JF i2c functionality.

Thanks for your answers and support guys!

1 Like

Just a little note, the new JF production units have a suite of automated tests run at the factory that are managed via the i2c port. Thus it’s very unlikely that the i2c port is at fault on JF, so i would focus on the Terminal.

1 Like

The simplest test I can think of is this:

#1
TR.P 1
JF.MODE 1
JF.NOTE N RND 20 V 5

Connect mix out from just friends to speakers and repeatedly press F1 on the teletype keyboard. On every press you should see a blink in trigger 1 on the teletype and hear a random note. The sound of the note is determined by the setting on just friends, with all knobs to noon and “mode” set to transient (all the way left) and sound/shape set to sound (up) you should short harmonica-like sounds with the trigger lights on just frindst skipping one ahead on each press…

NB: To make sure no funny init is disturbing the test, save the above in #1 in a blank scene and reboot teletype + just friends to make sure you’re starting from scratch setup…

1 Like

Thanks for chiming in. I have no doubt your modules are carefully tested and I am 99.99% sure the problem is my teletype. But will test JF with other modules if I find somebody willing to help me in my area.

Created a scene exactly as you said, when I press F1 TR1 blinks, just friends doesn’t react at all.
I’m done for today, thank you all for the support!

Sorry to hear that, hope you get it sorted!

All I hear is that there are production units in existence! :partying_face:

Hi everyone, just wanted to update you guys I figured out what was causing the issue (helped by the builder).
It was caused by two unsoldered pins on the microprocessor (SCL and SDA pins).
The pins were first soldered and the builder tested the i2c connectivity using a 16n but somehow the solder detached after the test.

These are the pins after a soft touch of soldering iron to resolder them.

Thanks everyone for the assistance.

5 Likes

Glad to hear you got it sorted! Happy teletypin!

1 Like

sorry to bump an old thread, feel free to move this if theres a better one - just ran into an issue where Just Friends entirely stops responding to i2c.

i was using it with teletype and had a script going which was reading the value of JF.TIME (admittedly, with a lot of reads in a short period) while playing notes via JF.NOTE. notes dropped out and then suddenly JF stopped responding entirely. after a power cycle, it does not respond to any i2c commands, JF.MODE does nothing, etc. my entire setup is teletype → JF → disting EX → nearness; the disting EX still works completely normal through the i2c chain of teletype into JF into EX. and JF’s non-just type functionality seems to work as normal, so it is solely i2c being problematic.

my teletype was bought direct from monome, and is not on the latest version, but is on (what i believe is) the latest beta before the full 4.0 release? and the JF is secondhand and has the gold clouds pcb, and up to this point it has been working fine over i2c for the past 6 months i’ve had it.

things i’ve tried:

  • power cycles
  • unplugging EX from the i2c chain
  • using entirely new i2c cables
  • switching to the other set of i2c pins on JF

and still nothing; anyone have any guidance?

I would try to reflash the firmware on both jf and teletype, I’m not an expert but this doesn’t sound like an hardware issue as everything was working just fine before