Solved: Using an audio interface with Supercollider on Ubuntu

Anyone here use Supercollider on Ubuntu (vanilla) with an audio interface??

I’ve spent a few hours on this and I suppose I don’t know enough about Ubuntu or Supercollider to really be able to figure it out.

Anyways it seems no matter what I do with settings in Jack the sound from SC still comes out the speakers on my computer. As fas as I can tell all I have to do is to get the SC server on boot to go to “Acquire audio card Audio1” instead of ‘Audio0’. I’ve checked in a few spots and the internal card is labeled as zero and the interface is labeled as one. If I go into audacity I can easily get sound routed in and coming out of the audio interface and choose to go to the computer speakers if I please.

I’m using an M-Audio fast track ultra…if it makes a difference. On Windows 7 it came out the interface no problem I guess because Asio4all just takes over everything.

It’s been a few years, but if I recall correctly, whatever you assign Jack to in QjackCtl, should get the audio from SC server. Things are different, if you are running Pulseaudio too, that might be the problem. I solved the problem by not running Pulseaudio by default. For “normal” desktop use, I start pulseaudio manually, and for music production, I start Jack manually. It’s been a few years, so there might be more elegant solutions nowadays. I didn’t have much luck running Pulseaudio through Jack. Hope this helps.

Setup in QjackCtl solved this for me. Just choose your interface from the hardware list.

What’s interesting is I have two computers running ubuntu, on the first one SC always boots to my settings from qjackctl, but on the second (the problem one) it seems like none of settings are carrying over to the SC boot. I have the interface set but also the sample rate and period and none of those match when I boot SC. It seems like it’s going to some default settings and ignoring my changes in qjackctl.

After trying many different tactics…I found this to be the only solution: I run the command at the bottom and keep the terminal window open and jack uses my interface with no problems. Everything is set to default in qjackctl with the sample size and buffer size set. So it seems that I was not able to prevent alsa from grabbing the interface from qjackctl, but with the terminal commands I can get around this.

I also was able to determine it was not a conflict with pulse-audio, as I did this setup: which seems to prevent pulse-audio from accessing my interface at all…it doesn’t pop up in the system sound settings any more so it seems to be effective.

1 Like