SSSR Labs SM010 and Teletype

#5

a sort of full recall ! this will be huge… thanks

0 Likes

#6

i just receved mine :wink: it sooo long ! i order it one moth ago !
but it’s a great matrix module, i can’t wait to have some OPS to work with it !
any news of the new firmware ?

1 Like

#7

he just posted a new 1.2 firmware on the web-site which includes i2c support. the teletype side of things is also done, i will post a beta later this week, just trying to finish a couple of things before i do.

to connect use the connector marked CN1 REMOTE, the legend is below. please note SCL and SDA lines are swapped on SM010 compared to TT, make sure to connect everything correctly! (ground to ground, SCL to SCL and SDA to SDA).


list of ops:

MA.SELECT 1..3
set current matrixarchate module. all other ops work on currently selected matrix.
(you can connect up to 3 matrixarchates to one teletype, selectable in settings)

MA.STEP
advance program sequencer

MA.RESET
reset program sequencer

MA.PGM pgm
select current program (1-based)

MA.ON x y
connect row x and column y in current program
(rows/columns are 0-based)

MA.PON pgm x y
connect row x and column y in specified program

MA.OFF
MA.POFF
same as above but disconnect

MA.SET x y state
MA.PSET pgm x y state
if state is 0 disconnect,
otherwise connect

MA.COL col
MA.PCOL pgm col
read specified column
(treat returned value as 16 bit unsigned where each bit represents a connection)

MA.COL col value
MA.PCOL pgm col value
set specified column (you can copy columns this way)

MA.ROW row value
MA.PROW pgm row value
same for row

MA.CLR
MA.PCLR pgm
clear all connections

3 Likes

#8

This is great ! Thank you ! It will be a great to the teletype Familly !

0 Likes

#9

arfff i need a programmer to update it :frowning:

0 Likes

#10

for reference the teletype version that supports matrixarchate is posted here: Teletype 3.0

0 Likes

#11

Just installed !!! and it’s works great :slight_smile: thank you !

1 Like

#12

heads up - if anybody is considering getting matrixarchate it might be a good idea to hold off for now. there are some hardware issues that need to be resolved first (teletype integration works, the issues are related to matrix operation itself).

sssrlabs posted some info in their MW thread, i would check there or contact them to confirm if the issues have been resolved before ordering.

there were 2 issues i found:

  • if nothing is connected to input 13 but row 13 is connected to other inputs via the matrix it will bring their voltage down to zero
  • if +9.9V or higher voltage is applied to an input it will generate significant clock noise (over 0.5V) on unconnected outputs
2 Likes

#13

I can confirm that my new unit has the same issues. :frowning:

0 Likes

#14

Whoa. Thanks for the heads up on this. Was looking to get one soon so this is good to know.

0 Likes

#15

Thanks for this thread. I almost bought a second hand one, but sounds like I should avoid for now.

0 Likes

#16

i don’t know if all units had the problems i ran into (or if the problems were fixed) - might be worth checking with sssr labs.

0 Likes

#17

I did :grinning: Both the >9.9V and the row 13 issues are present as a result of the switch chip used and cannot be fixed in software. They commented that attenuating the inputs (10V would be pretty hot even for eurorqck right?) and avoiding the other issue mean that the modules are still usable. I dunno, I’m still thinking about whether to proceed with buying one.

0 Likes

#18

yeah, the 10V issue is probably not as critical but the row 13 issue means you can’t use that channel at all. if you’re planning to use it with teletype you could just program it in a way that would prevent row 13 from being connected to anything.

worth mentioning that i didn’t do any extensive testing of the module, so can’t confirm there are no other issues.

0 Likes

#19

Well if you make sure there’s awlays a signal into input 13 wouldn’t that solve the problem?

0 Likes

#20

i checked my notes and yes, my records say if something is connected to input 13 it fixes the problem.

1 Like

#21

Were the hardware issues fixed? I’m quite tempted by the DIY kit.

0 Likes

#22

any news on this front?

0 Likes

#23

have you tried contacting sssr labs?

0 Likes

#24

Anyone know if this is fixed? I was interested in buying one when someone on the facebook quadraphonic discussion group pointed me over here to this thread. TIA.

0 Likes