Stock Norns - Black Screen Issue

Hello,
My Norns screen became black after a power cycle.
Trying to launch scripts from maiden they seem to ‘work’, but no visual feedback…
I’ve used Norns every day and till a hour before the issue.
Tried with power or battery, with or without grid or other controllers, crow connected and not connected… same results.

That’s what Maiden tell me at start up:

warning: didn't find SoftCut voice method: post_filter_fc_mod
warning: didn't find SoftCut voice method: post_filter_fc_mod
warning: didn't find SoftCut voice method: post_filter_fc_mod
warning: didn't find SoftCut voice method: post_filter_fc_mod
warning: didn't find SoftCut voice method: post_filter_fc_mod
warning: didn't find SoftCut voice method: post_filter_fc_mod
available engines (46): 
  Glut
  Showers
  PolySub
  Synthy
  Shepard
  SimpleDelay
  Sines
  Pixelbangs
  Greyhole
  KarplusRings
  Ack
  Glacial
  Phyllis
  DemonCore
  MGlut
  Decimatec
  SimplePassThru
available engines (46): 
  Glut
  Showers
  PolySub
  Synthy
  Shepard
  SimpleDelay
  Sines
  Pixelbangs
  Greyhole
  KarplusRings
  Ack
  Glacial
  Phyllis
  DemonCore
  MGlut
  Decimatec
  SimplePassThru
  Haze
  Timber_Gridstep
  Dronecaster
  SimpleDelayKolor
  EasyGlut
  MollyThePoly
  Decimator
  R
  PolyPerc
  Icarus
  YggdrasilSynth
  Benjolis
  Timber
  Autumn
  Odashodasho
  MxSamples
  Amen
  Haze
  Timber_Gridstep
  Dronecaster
  SimpleDelayKolor
  EasyGlut
  MollyThePoly
  Decimator
  R
  PolyPerc
  Icarus
  YggdrasilSynth
  Benjolis
  Timber
  Autumn
  Odashodasho
  MxSamples
  Amen
  Passersby
  Pools
  Timber_Takt
  MxSynths
  TestSine
  Thirtythree
  ZGlut
  PrimitiveString
  BandSaw
  None
  Thresher
  Lissadron
  Passersby
  Pools
  Timber_Takt
  MxSynths
  TestSine
  Thirtythree
  ZGlut
  PrimitiveString
  BandSaw
  None
  Thresher
  Lissadron

Help :slight_smile: !!