a collection of pattern recorders

strides is a collection of 16 pattern recorders.
8 are norns focused, expressed as encoder recorders sending midi cc’s.
8 are grid focused, allowing for finger drum style recording and looping (with optional midi note out).

strides uses the Ack engine, written by @jah


Norns 2.0
Grid 128 (vari-bright)


Click here.


v1.4 - strides


Between this, the shuttle control mapping and a new system I literally do not know what I am doing but I’m digging these aliens in caves sounds!


WIll this run without vari-bright? Assuming it just means that there is some issues with information being imparted by the grid.

It will run, but all of the dimly lit LED’s will be off. You could probably use the images in the docs to navigate, but it wouldn’t be as easy for sure.

editing the script might be better. would just need to change the g.led calls.

1 Like

Yeah, I wonder if something like a fast lighting cycle on the LED’s that would be “dimly lit” would be a way to simulate this effect. There is someone on this board creating custom chips to upgrade old monome’s to varibright. If so, that would greatly help.

This is something I am very much looking forward to. I have an old walnut 256 that I want to revive :slight_smile:

It might be simpler to make all the dim LED’s fully on, then blink off to indicate a press/trig.

1 Like

Good call on the LED layout. I haven’t tried editing any scripts with lua before. Maybe this would be a good first shot at something one to get my feet wet.

As well, I’m assuming then you are following the guy making these upgrade chips for the old Grids. Looks like a slam dunk project to me.

1 Like

Does this still work with the current norns version? Doesn’t seem to load up for me.

I just loaded it up and it seemed to run fine. Tbf I don’t have much connected right now but hope this helps.

1 Like

It should still be working. I will give it a look over this morning and report back. @static, are you getting any errors on load?

edit: it seems to be working for me. Though, it could definitely use some love/an update.

I apologize, but I was mistaken. Strides loads just fine!

The script that I could not get to load was Seaflex.

1 Like

Has anyone tried using Strides with a Launchpad?

1 Like