Strum

norns
#1

Strum

A plucky little pattern sequencer

This 16-step sequencer offers random note generation, 4 choices for pattern play - forward, backward, ping-pong, and random. Adjustable pattern length, scale, key and tempo. Pattern and synth params can be saved and reloaded.

Two versions are available: one using KarplusRings and the other PolyPerc.

Requirements

norns (v2.0)
grid 128

Documentation

docs located here

Download

v1.0.0 - download link

17 Likes

#2

Updated for requirements of norns v2. Thanks.

1 Like

#3

Hey, thanks for doing this. I just updated to 2.0 and added all the new scripts including Strum. I followed your instructions in the read.me but keep getting “no script information” errors. I tried resetting the audio which worked for many of the other scripts but not this one. I’m brand new to Norns and am thinking that maybe I don’t have the engines? If so, could you explain to me how to find them? thanks :slight_smile:

Edit: If I click encoder 3 on the PolyPerc version, it goes to the strum screen and works! Still not working with karplus rings though. I also seem to be missing a Params menu for all scripts

0 Likes

#4

The 2 Strum scripts (strum_kr.lua and strum_pp.lua) should be installed in the code folder on your norns. You don’t have to have them inside any other folder - I like to do this so I don’t have a long list of scripts to scroll through.

You say you see ‘no script information’, but at what point do you see this?

0 Likes

#5

When I select Strum from the menu page. It says no script information. Then when I click the 3rd encoder it just takes me to the screen with the photo I attached!

0 Likes

#6

Let’s keep this discussion to one forum thread… :stuck_out_tongue_winking_eye:

0 Likes

#7

We’ll stick with this one! I’ll delete the others :sweat_smile:

0 Likes

#8

This is how it looks in my code folder. Not sure if that’ll help. I’m running maiden now

0 Likes

#9

code folder looks fine

0 Likes

#10

So I just hooked up my grid and it’s working great with Poly.Perc. From the select screen by pushing button 3 I get “no script information” then I press button 3 again and it goes to this screen:

This is what shows on Maiden while on the screen from the photo above. My grid does not light up at all when I select KR…

0 Likes

#11

Right. I’m going to have to pass this one up the food chain. Sorry, I don’t have a clue.

@tehn any idea why on this?

0 Likes

#12

we’re missing the top of the stack trace so can’t see why banging the parameter set is failing - probably while calling a param update func.

@samule.edmoon it would be good if you could post more of the matron output, preferably as text instead of a screen photo.


one possible (likely) reason is that you don’t have PolyPerc installed. (it’s installed by awake now.) the stack trace would be consistent:

### SCRIPT ERROR: init
/home/we/dust/code/strum/strum_pp.lua:632: attempt to call a nil value (field 'pw')
stack traceback:
	/home/we/norns/lua/core/norns.lua:185: in field 'pw'
	/home/we/dust/code/strum/strum_pp.lua:632: in field 'action'
	/home/we/norns/lua/core/params/control.lua:76: in function 'core/params/control.bang'
	/home/we/norns/lua/core/paramset.lua:272: in function 'core/paramset.bang'
	/home/we/dust/code/strum/strum_pp.lua:646: in function 'init'
	/home/we/norns/lua/core/script.lua:71: in function 'core/script.init'
	[C]: in function 'xpcall'
	/home/we/norns/lua/core/norns.lua:186: in field 'try'
	/home/we/norns/lua/core/engine.lua:83: in function </home/we/norns/lua/core/engine.lua:82>
>> reading PMAP /home/we/dust/data/strum/strum_pp/strum_pp.pmap
0 Likes

#13

The PolyPerc version of Strum works for him. It’s the KarplusRings version that throws the error.

0 Likes

#14

ah right, sorry. in that case maybe KarplusRings is missing (it lives in we/lib, since its author has not claimed it) - the stack trace would be similar. both versions work fine for me with the engines installed.

2 Likes

#15

Both versions are working fine for me.

This happens for me as well, but pressing key3 loads the script…

0 Likes

#16

oh right: ‘no script information’ is due to the leading whitespace (typo) in the first comment line of the scripts.

2 Likes

#17

Ok. Will fix this in repo.

Edit: updated.

0 Likes

#18

I think I may have deleted the we/lib by accident. Is there any way to reinstall it?

0 Likes

Norns: help
#19

Not sure. Ask in the help thread.

0 Likes

#20

@carvingcode, strum is super fun! can’t believe I waited so long to play with it :slight_smile:

Edit: realized that this was solved in another thread :slight_smile:

2 Likes