Teletype 3.0 Release Candidate 5

teletype

#190

yeah, it’s likely that it’s not properly connected.

could somebody who uses a similar set up post in more details how exactly you have it connected? also, is the arturia adapter available for sale separately? i can try and get one and document the process.


#191

It is.

Arturia adapter

Can’t think what I’d have wrong. The connection that normally goes to the PC is going to TT. The connection that would normally go to Beatstep is going to the grid. The only new piece is the micro->mini adapter. The rest is known to be working.

Thanks for helping think through it.


#192

and it works when you connect it this way to the PC?


#193

Hadn’t thought to try that since it hasn’t quite registered with me yet that grid could be used in a non-modular context. :slight_smile:

No, it doesn’t see it. Also connecting it to ansible this way doesn’t seem to work - I don’t see the any buttons lit there either.

Reconnected the BSP to the PC and it recognized it immediately. Reconnected grid directly to ansible and it works as expected. I guess I’d have to conclude it’s a bad micro->mini USB adapter if this is working for others.


#194

sorry it doesn’t work - it’s weird that such a simple part would fail but i had various luck with usb cables as well…


#195

Yep. This is why I was trying to find the adapterless solution! I’ll take it back and exchange for another or see if they have a different brand. I’ll get there! Thanks again.


#196

Yep. Faulty USB adapter. New one of same model, and I’m in the Grid Ops business!


#197

20 characters of awesome!


#198

release candidate 2 - this fixes bugs in RAND, RRAND and R:

teletype.zip
teletype.hex


#199

When I hot connect grid to teletype to test some grid ops on the hardware, the teletype seems to halt activity for maybe 100-200ms and then resumes. Not a deal breaker or anything but just wondering if that’s expected.


#200

yep, that’s normal. not sure if that’s something that could be improved.


#201

This is exciting! I’ve been too busy to work on any music and now that I have a little time, a new present. Thanks to everyone who is working on it.

I think I can help test the RC some tonight or tomorrow. Are there any areas that could use some attention? FYI, I’ve only got the Teletype at the moment.


#202

anything listed in the top post would be a good area to test, but even just using it normally and seeing if anything doesn’t seem to work would be really helpful. i would say definitely keep an eye on script editing - multi line selection, moving lines, copy/pasting.


#203

Vim ops, one step closer :smiling_imp:


#204

Cool, I’ll start with seeing how my most recent scene works and then test out the new stuff. Thanks again!


#205

So far so good for me. Love the new parameter ops!

Tomorrow I want to see what I can do with the Grid ops despite not having a Grid. I might have missed it in one of the 2.3/Grid Ops related threads but is there an updated list of the keyboard commands? I found this:

and I just wanted to be certain I wasn’t missing anything.


#206

i can’t remember if i documented it elsewhere, i really should. the above still applies, but instead of CTRL it’s now ALT and there is another shortcut, ALT-\, which will toggle the control view on and off (which shows the outline of grid controls).


#207

oh by the way, I’m pretty sure I left my synth on and untouched for 90 minutes the other day, but no screensaver came up.


#208

Funnily enough, I left mine on yesterday (2.3 RC2) and when I came back, it was flipping through the script pages very quickly, as if a square bracket was held down.

I thought it was probably just haunted, but now you mention it…


#209

did you have grid connected at the time? was it in grid control mode? also, when screensaver wasn’t working - what screen was it on?