Teletype 3.0

no changes in presets

1 Like

just tried updating the firmware and no warnings.

can you double check if you’re updating it with the right command? is it possible you’re using ansible command instead? should be this:

cd "$(dirname "$0")"
dfu-programmer at32uc3b0512 erase
dfu-programmer at32uc3b0512 flash teletype.hex --suppress-bootloader-mem
dfu-programmer at32uc3b0512 start	

Aha! Yes, I was using “at32uc3b0256”. Thanks for the help, as always!

1 Like

I wasn’t sure which thread to place this question but I figured here might be good because it might turn into a feature request.

Is there currently a way to recall the stored patterns in a scene without having to reload the init script?

I’m planning to use the modular in a live situation and I like to randomize the patterns but then I also want to be able to suddenly go back to the pattern officially stored in the scene without having to run the init script.

My solution at the moment is to basically save a duplicate scene without the extra stuff in the init script and to load that instead.

Still could be a cool function to be able to load the stored patterns separately or individually.

no way to do this currently, but here is a workaround: add BREAK as the very 1st line in your init script. then if you do want to run the init script after loading the scene navigate to the init script, disable the 1st line with alt-/ and execute the script with F10 (and re-enable the line before you save the scene).

i’ll start a new thread for feature requests!


thread for feature requests / discussions: Teletype 3.+ feature requests and discussion

Thanks so much for the idea. I’ll give that a go. Thanks again for all the development work you do!

thought of a better idea. add this as the first line in the init script:


now when you load the scene I should get initialized with 0, so it will skip the rest of the init script, but on repeated script execution I will be non zero, so the rest of the script will execute. so just load the scene and if you need the init executed press F10.


oh man, I love this solution!

Why not just:



I figured out another solution to my dilemma and its a real face-smack.

I’ll just reserve sections of patterns. Steps 0-15 can be reserved for randomization while 16- 31 can be part 1 of song, 32-47 can be part 2 of the song and I can even set 48-56 and 57-64 as little 8 step breakdown moments.

Then, I’ll just have to figure out how smoothly adjust pattern start/end and index number to jump to the different parts of the song.

Albeit, pattern recall would still be a cool feature. Thanks again!


Help. I’m not sure how this has happened but I have lost all my scenes using 3.0. I have been using another case today which power cycles at the same time as the case with TT in it. I’ve come to do some work on Teletype and there are no scenes in any of the slots… Can i undo this or revert to a previous state (if I haven’t saved the scenes)? What could I have done?? so as to avoid ever making this mistake again.

was the teletype on when this happened, or did it happen after a power cycle?

assuming this somehow happened while it was on then turning it off and on again should load what’s stored in flash, unless the flash memory itself failed somehow. i can’t think of any other reason that would cause this though, it’s possible a single scene would get wiped out if you used INIT or INIT.SCENE (especially in a script), or when loading from a usb stick, but there is no code that wipes out every single scene.

if you do get them back after a power cycle make sure to back them up to a usb stick just in case.

Thanks for responding. Not sure exactly when it happened as I had not been using it or anything connected to the scene for the last couple of sessions. I tried to restart and nothing is there. Even the default scenes with the 3.0 firmware are missing. It’s strange… if there’s no “clear all” operation I’ve accidentally done (not likely as I wasn’t using it) then it’s just erased the memory on its own. Could this imply a hardware issue?

it’s possible there is some firmware bug that causes it but i can’t think of a possible scenario. if it was just one scene then maybe something called the code that reinitializes a scene, but for all scenes to get erased - i can’t think how it could possibly happen.

another reason why a firmware bug would be unlikely is that it didn’t just erase all scenes but saved that to flash, since it’s still empty after a reboot. the only time tt saves empty scenes to flash is after updating firmware. that’s only done when you boot it up after you reflash firmware, that code doesn’t get called anywhere else.

so yeah, sounds like it might be a hardware issue. have you tried saving a scene and see if it’s still there after a power cycle?

Thanks, I’ll try that and let you know. Whatever it the reason it makes me a little nervous…

definitely - i would be nervous too! hopefully we can resolve this.

so to confirm, it was on with a scene loaded, and there were other scenes saved, then while it was on you turned on another case and when you checked the tt the scene was empty and other scenes were empty as well? and this happened while the tt was on, not after turning it off and on again? did you have grid or keyboard connected to it at the time?

I can’t be sure exactly when it happened as I had been focused on another case for a couple of sessions and had power cycled both cases in between a couple of times so it could have occurred at some time over the last 2 or 3 days. The keyboard has been plugged in the whole time.
I’ve just saved a dummy scene and power cycled and that is saved

@tehn is it possible for flash memory to fail somehow? or for f.fresh to get reset?

i don’t think this is flash failure. it’d be incredibly weird for scenes to be lost but not have a section of the firmware get corrupted.

f.fresh could indeed get messed up with a firmware flaw— some memory addressing failure, but this seems incredibly unlikely, as it would need to get explicitly set to 0x22 this seems the only thing that would clear the whole thing out, as at startup . @yoyosandshoes did you actually witness the TT restart? ref:

that said, i doubt this is a hardware failure. but i’ve also never seen this happen, ever, with hundreds of units. try not to be nervous, but also back up your scenes.