Teletype 3.0

probably just enough to hold 7 lines and just update it dynamically when it’s scrolled up/down. can just ignore blank lines. another question is how to treat selection - for multi line implementation i changed the copy/paste buffer to be able to hold up to 32 lines (thinking this would be needed in case you want to copy/paste a scene description). i think i’ll leave it at that, and if you copy more than what a script can hold it will just shift everything down and discard any lines after 6 (which is how multi line copy/pasting works right now).

of course, there is a temptation to allow editing in this mode as well, so then you can edit all scripts together on one screen… :slight_smile: just a though really as this would require its own screen and proper script validation etc. i do think that multi line editing will be super handy whenever we get to the timeline feature (especially moving lines up/down - i imagine you’d do that often when editing the timeline).

i meant this thread: (Teletype) USB Disk Mode Interface it mentions script copying among other things.

The key combos for manual execution of scripts don’t seem to be working for me.

I’ve tried every combo of Win / Fn / Ctrl / Alt / Shft + a number / an F key.

Only Fn + F3 and Fn + F4 work - triggering Scripts 3 and 4, as expected.

I can’t trigger any other numbered script or “I” using any combo I’ve been able to find documented in previous versions.

EDIT: OK - I now see F1, F2, F3, F4 and F10 work without a key combo - but F5, F6, F7, F8 don’t. I hope I haven’t added to the confusion. Basically - there should be one key combo that works for each script - and that isn’t the case currently

Mutes all work - except for Ctrl + F9 for M, which is intermittent - ie. If I hold Ctrl and repeatedly press F9 (not too fast), it doesn’t always toggle the mute status of M. (Also the small letter M in the bottom left corner of the Mute Script screen does not reflect its Mute status as the similar numbers on other Script pages do.)

I’m on the stock chiclet keyboard.

Am I missing something?

Regarding the ALT + UP black screen of death - it happened once today in about 3hrs of Teletyping. I was on a blank line on the 6th row of a 5 line script. After re-booting, I reloaded the script and tried to repeat the crash - but no such luck.

i just tried triggering scripts with F keys and it works fine. could you try it with older firmware and see if you can reproduce? i have a feeling there is something else going on. also try replugging the keyboard several times.

I was editing my post as you replied, I think.

Does F5 to F8 work for you, to trigger the relevant scripts?

EDIT: OK, they seem to be working now. I think I may have a problem with my chiclet! I’ve had other intermittent problems with it… I’ll grab another USB keyboard to see if that is the problem. Thanks for your patience.

yeah, all F keys work for me. CTRL-1 etc is not used anymore. are you using this key reference?

it’s outdated (ver1.3) and shouldn’t be used anymore (@tehn - the main teletype page should be probably updated to reflect that, not sure if there is a new version of key reference?). this doc should have the proper key shortcuts:

it won’t have the 2.3 shortcuts yet (there are new shortcuts for grid visualizer and multiline editing) but i think it should have the 2.2 shortcuts.

1 Like

20 characters of done!

1 Like

Is the 2.2 or 2.3 documentation available for review anywhere? I just spotted a couple of typos in the 2.1 commands pdf.

you can see the docs for 2.2 here and for 2.3 here (no html/pdf version yet, the official doc is updated as part of a release).

since it’s in 2.1 version it should probably go to the 2.2 thread since 2.2 hasn’t been officially released yet. or better yet, if you’re comfortable with git you could fork and make the changes yourself and submit a pull request.

were you able to find a working keyboard? and have you had any more issues with Alt-<up> freezing teletype? i wonder if that was also due to the keyboard. regardless there are indeed some other bugs you mentioned, i got sidetracked by other stuff and haven’t had a chance to look into them yet. hopefully this weekend.

@scanner_darkly sorry I haven’t been much help with this, too many (happy) life changes at the moment!

But, if you ever need any help getting the PDF or HTML docs running, tag me and I’ll free up some cycles for it.

1 Like

Thanks - I’ll reply over there. I looked at github a few years back, became confused, gave up. I should revisit it - I’m sure there is a step-by-step guide to getting set up.

were you able to find a working keyboard?

The only other USB keyboards I have include hubs, so don’t work. I have ordered a small, mechanical replacement which arrives tomorrow.

and have you had any more issues with Alt- freezing teletype?

Yes. I now try to avoid using ALT + Up as I have lost work a few times. Hoping the new keyboard fixes it - but there do seem to be some other problems with the way the line moving / commenting works.

i got sidetracked by other stuff and haven’t had a chance to look into them yet. hopefully this weekend.

I can’t believe how much work you and others have put into this. The Teletype is becoming an even more incredible module with every new version. I’ll help where I can, even if it’s only stress-testing and proof-reading.

And good luck with the job interviews!


just uploaded the 2.2 docs to the monome site


i really need to get latex set up on my machine so i can post beta manuals as well… thank you, will ping you if i run into any issues!

your help is very much appreciated! maintaining documentation is one of the most difficult aspects of software development.

will be taking a close look at multi line editing, thinking about it more it doesn’t sound like a keyboard issue, i assume the module was frozen to the point where the front panel button didn’t work either.

1 Like

I’ve just spent an hour playing around with Moving and Un/Commenting lines in Script Edit and there’s a bunch of funky stuff happening that is probably all related to a single section of C code.

I’ve had one freeze with the new keyboard but it wasn’t the ALT+ UP freeze - despite trying to get it to happen.

I know you are busy playing Shop :wink: but when you get a chance to look at it again, let me know and I’ll send some details of my findings in case they are of use.

1 Like

A small issue I ran into the other day. Using P.HERE / PN.HERE to assign a value does not visually update on the pattern page while its value is stored correctly in TT. A simple test which illustrates this (at least on my TT):



PN 0 0 RAND 100

If you then flip to the pattern page and trigger the scripts form the keyboard Script 1 will not cause updates on the pattern page until you either flip to anotherå page and back to the pattern editor or trigger Script 2/3 which I’m assuming redraws the contents of the pattern page. In contrast, both Script 2 and 3 perform their function and provide visual feedback on the pattern page.

Not a deal break by any means, but my assumption is this is not the intended functionality as all the other pattern ops I tried visually updated immediately.

1 Like

yep, it’s a bug. easy fix, will include it in the next beta!

1 Like

thank you for both of these snappy replies!

snappy in the quick sense

no prob! glad to finally have the time to work on firmware again, really want to push it closer to a release. should be able to post a new beta tomorrow which will include fixes for multiline editing as well.

ha, i didn’t even think of the other meaning :slight_smile:

and it made me look this up:


hahaha so i guess there were a number of ways that could have been taken :joy:


Found a bug in the current firmware, although it might be more for @Galapagoose

I was following along with the excellent Just Type studies by @dan_derks. Study #6 works fine when implementing it. However, if you save it, shut down your system, and reboot… Teletype will lock up after about 30 seconds or so. If I change scenes before the freeze, the TT won’t lock up. Interestingly, if I change scenes and then change back to JT #6, it won’t freeze. It only seems to occur if you boot with #6 and leave it running.

For reference, here is the file:
tt17s.txt (1.5 KB)

EDIT: If it helps, here’s everything on my i2c bus: ER-301, 1x TXi, 2x TXo, Just Friends