Teletype 3.0



I think it was always just in the Live screen whenever I left it alone (don’t have a grid, so no to those questions)


@scanner_darkly For me, I think keyboard was connected and not in grid control mode. I will try leaving it on again.


i’ve posted the updated shortcuts for the grid visualizer here:

i’ll update the video as well when i get a chance, since it still references the old Ctrl shortcuts.


Im in a bit of a pickle and @facetimecontinuum said it best in the Ansible Earthsea thread when he wrote:

"Im a bit embarrassed to ask you to walk me through this considering how much time and effort you’ve put into this project but… Im struggling with the hex file. I know basically nothing beyond the most basic functions of a computer so i’m most certainly missing something (many things) i’m on a mac by the way.

I did a few quick searches in the forum and the wider internet and it seems (perhaps) a zip file with the flash command would help?

I have successfully updated ansible firmware in the past with a command file.

i’m not confident that im using these terms correctly so again I apologize for asking you to hold my hand through this"

Im having a hard time finding a file type that I’m familiar with.
Can someone please point me in the right direction - whether its somewhere to learn about the .hex file or possibly another file that I overlooked?
Thank you so much!


so first step, download one of the official release zip files. when you unzip it you should have the command you need. all good so far. now, replace the teletype.hex file that was packaged in that zip file with the one from the release candidate. make sure that it is named teletype.hex. Finish up by running that command.

in short, the .command file is agnostic about the contents of teletype.hex, it just wants a file named such to be in the same folder.


Holy Mackerel, thank you so much!
i . am . so . excited . for . this!

Beyond basic internet searches, computers go beyond me but im trying to learn!
Tons of appreciation sending your way.


@alanza - thanks for helping with this!
for future beta/rc releases i’ll make sure to include the update command.


let’s see if this fixes the screensaver issues… also added a fix for PARAM returning 0 when used in the init script and IN and PARAM being reset to 0 after INIT.DATA (thanks to @rikrak for finding these!).

release candidate 3:



Is there anything in particular you’d like to have tested at this point? Or is it more do what you’re going to do and report any problems if they come up?

Do the grid ops for XYP and GOL work at this point? They say work in progress so I wasn’t sure if they were going in to 2.3. Was thinking about having a go with the XYP.


Has anyone else has been able to update to 2.3 release candidate 3? For some reason the update command just exits for me.

Other teletype.hex versions update with no problems, so it doesn’t seem like it’s the .command file or the USB connection… :thinking:


i’d say both, although the new fixes/features have a higher chance of having bugs in them, so would be good to give them more attention.

planning to add them in a future version. there is an op for x/y pad but it’s not finished, so it’s not included in any of the docs.

line ending differences between unix/mac/windows are a pain in the neck… can you give this one a try? (159.6 KB)


Thanks for the quick fix, this one works!


Once you’ve got the docs working locally, you can type make release in the root of the teletype folder to build a zip file with everything included. Saved me loads of time when I was constantly uploading new versions of releases.


the problem is the line endings conversion. make will include the local copy so it’ll have windows line endings and i’ll still need to update it manually. i need to look into my git settings so that it doesn’t convert (i use notepad++ which can be configured for whatever) but i had some issues when trying to do that with a repo that was already cloned.


So I did encounter some kind of unexpected event. This was in 2.3 RC1. I don’t know that it was actually a crash so I will describe.

I had a couple of lines each in Init and 2 scripts. Init script created a few faders and buttons (G.BTX and G.FDX). Script 2 was the specified script for the faders, and I had it up on the screen. There were no other hardware ops in place. Script 2 was just setting some variables so I could see what values the faders were producing.

I had script 2 up on the screen and unplugged the qwerty and plugged in the grid. It had been working fine previously, but this time It didn’t light up or respond. So I plugged the qwerty back in and it didn’t respond either. Tried a couple of swaps - same result. Then I plugged in a USB drive. The Teletype switched over to the live variables display. That was the last response I could get out of it.

After a power cycle all was fine again. Haven’t reproduced it since, but thought I’d log it.

I’ll now upgrade to RC3.


Also, not sure if this is a bug or a pebcak. Using 2.3 RC 3 now.

G.FDX 1 8 0 8 1 0 3 2 1 4

Y SCALE 0 16383 0 7 G.FDRV

Setting the a fader to each of 8 possible values yields Y of:

0 0 1 2 3 4 5 7

I was expecting:

0 1 2 3 4 5 6 7


Y SCALE 0 16383 0 7 G.FDRV

gives the expected result, though the fader max seems to be 16383.


it shouldn’t have. what happens if you move the update command from the previous release into this folder and run it? my understanding is it should work fine if you do


I just saw your suggestion a few posts up, I’ll try that with the current 2.2 release that’s worked for me in the past. Thanks!

Edit: That worked!


i have a guess at what might’ve caused it, and some changes in RC3 might address that.

this line is the same as above - is it supposed to be different?
i’ll take a look at why it scales this way. as a side note you can also use G.FDRN instead, it gives you fader value in “buttons”.


Yes, sorry, 16383 should say 16320 in the edit.