Teletype 3.0

teletype

#291

documentation is done. let me know if you see any typos / formatting problems etc. huge thanks to @jlmitch5 and @alanza for their help!

cheatsheet.pdf
teletype.pdf
teletype.html


Grid ops / integration
#292

Excellent! To whom should we PM re any typos we find?


#293

you can PM me or just post here


#294

Do we want to either link or somehow pull info about the github grid integration wiki into the teletype docs? I remember you had done some teletype control mode stuff, but it took me a while searching for the info after looking at the docs (where it wasn’t mentioned in the grid integration section).


#295

the github wiki grid studies are linked already in what’s new, grid ops and the grid integration section under advanced, but yeah i think i should expand the grid integration section to provide a bit of overview and direct links to the grid visualizer and grid control mode pages, will add that!


#296

ah cool yea. I think I kept skimming for “grid control” and then thinking the wiki was (just) about shared community scenes, I went in there and didn’t see grid control within them, I got confused.

Once I saw the navigation within the wiki for the other pages, I was good.


#297

One thing I would love to see in a future firmware is an easier to see cursor in the script editor. Maybe I’m alone in this but I often find myself typing a character to see where the cursor is!


#298

Nice job everyone.

Do you want to add a page break to the cheatsheet before the grid ops? Then they’ll all be on one page (and those that aren’t using them will be able to not print that page). The Python code for inserting page breaks in cheatsheet.py is a bit odd (sorry!), the docs should make it clear.

Also, if you didn’t know there is a list of ops with missing documentation in appendix B, it’s a surprisingly short list! But there are 3 grid ops in there that you might have missed.


#299

Small question: Is there a reason why the OPs for i2c connectivity to things other than the telex-modules (e.g. Just Friends, w/, Ansible) aren’t included in the alt + h help pages? Or is it just because nobody wrote them so far? If so, could you point me to where I’d have to add these pages? I wouldn’t mind writing them and I find that those are the OPs that I forget most of all, so I think it would be useful to have them in there.


#300

i’ll see if i can tweak it.

yeah, the main reason is that nobody added them. do you have the toolchain set up? if you do the file you want is https://github.com/scanner-darkly/teletype/blob/grid2/module/help_mode.c (pointing to my branch as it has the telex help screens added as well as other new ops, please use this branch until it’s merged to master).

makes sense, i’ll separate.

G.XYP, G.XYP.X, G.XYP.Y are there but i don’t want to document them yet as they’re unfinished (pushing this to 3.1).

going to add docs for IN.CAL.RESET and PARAM.CAL.RESET

for P.ADD, P.ADDW, P.SUB, P.SUBW, PN.ADD, PN.ADDW, PN.SUB, PN.SUBW, TIF not sure why it’s reporting them - likely because they have special chars in the name (P.ADD is actually P.+ etc and TIF is ?). the docs are there, it’s just not matching them. was going to ping you about this one - not really sure where to look!


#301

I do not. It does seem easy enough to get it right, though. Would you mind compiling and testing it if I just edited the file and sent a pull request without testing it first? If you’re too busy (totally understandable if so), I can also try to get the toolchain up and running, but can’t guarantee I’ll get that done quickly. In any case, I’ll start writing :slight_smile:


#302

with the help file i find you have to tweak it by testing it on teletype, otherwise it’s hard to say where line breaks should be placed for better readability. see if you can set up the toolchain, if not i can add it.

this should probably go to next version, for this release i’m trying to limit it to very small changes and bugfixes for 3.0 features.


#303

Yeah, as I begun changing the script just now, I did realize quickly that I’d probably have to test it a bit. I’ll try to get everything set up.

One quick question: Maximum line length is 32 characters? The longest line I could find in the help pages so far was 30, but it looks on teletype as if there was some extra space there.


#304

it really depends, as it’s not a monospace font something like I takes less space than W, so it’s different between different lines. you could test to a certain extent just by typing in a script or live screen (just be aware they will limit to 31 characters while help screen doesn’t enforce max line length so in theory it can be longer as long as it fits on the screen)


#305

@x2mirko - i’ve tested your change, looks good, i’ve merged the PR. thanks for your help with this! i made a couple of small changes (lines that didn’t fit) and combined just friends and w/ pages - they’re not too long and we’ll have more ops in the future, so trying to optimize scrolling.

here is the updated version. @apeirophobe - i also tried making the cursor slightly brighter - i think it looks good but want to hear what others think.

3.0 RC6

teletype.zip (165.1 KB)
teletype.hex (560.7 KB)

and with this i am “officially” declaring code freeze for 3.0 with the exception of bug fixes for new 3.0 features. we do need to release this at some point :slight_smile:


#306

Wow, I certainly wasn’t expecting the cursor enhancement … especially that quickly! Thank you very much for all your work. Looking forward to digging deeper into 3.0.
Thanks!


#307

Small issue and I’m not sure what can be done about it: I just tried WS.REC without a parameter with a w/ with an old firmware on it. That immediately made Teletype freeze until reboot. I suppose it’s waiting for an answer via i2c that it doesn’t get because my w/ didn’t understand the command? After I updated w/ to the most current firmware, everything works fine. Not sure if this is even considered an issue or it’s on the user to make sure to run compatible firmware on all devices. Just thought I’d mention it.


#308

Thanks for squeezing the cursor change in. Looking forward to checking that out. I sometimes struggle with “where is the cursor” too, so this should actually be a pretty big usability improvement.


#309

that shouldn’t cause tt to freeze… it’s possible there is something in the older version of w/ that actually tries to respond and causes this. glad it’s working with the latest w/ firmware!

as a general rule, you don’t need to keep every device up-to-date (unless a newer version includes ops you want to use), this shouldn’t cause i2c issues, unless we’re talking about really old firmwares that had less reliable i2c implementation… in any case if there are any issues always a good idea to try and update the firmware!


#310

the docs have been updated - @rikrak and @sam, thank you for your feedback! and special thanks to @jlmitch5 for help with generating the docs (and pushing me to rewrite the grid integration section)

teletype.pdf
teletype.html
cheatsheet.pdf