Teletype 3.0



Are the w/ ops in this beta?


no - the w/ code hasn’t been merged to teletype master yet. once it’s merged i’ll post a new beta shortly after.


I keep forgetting to mention this …

I am on the previous build (B537759) and can’t upgrade for a couple of days due to being in the middle of a patch, but I wanted to report an issue I ran across last week that I have not seen anyone mention before: when in the pattern screen, pressing CTRL immediately puts a value of “31” in the current position. I found through use of the CTRL-Fx trigger muting command.

It’s possible this was noticed and fixed in the latest build–if so, sorry about the obsolete bug report! Thanks again for all the wonderful work. :slight_smile:


Was your Param knob all of the way CW? :slight_smile:

Pressing CTRL while in Pattern view inputs the current position of the Param knob, scaled 0-31. Or at least that is what it is doing on my TT. Though, I can’t find any mention of it in the docs… and I am not sure why it is 0-31.


yeah it caught me off guard too! it was added a long time ago actually. iirc CTRL will set the current pattern value to PARAM knob scaled to 0-31 and CTRL-SHIFT will set to PARAM without scaling.


Yes! I just tested it with the param knob in various positions and it behaves as @scanner_darkly describes above.

We appear to have a keystroke collision here! Muting is super valuable, maybe move it to shift-Fx? Shift keys are larger than CTRL keys, so this would be helpful.


that’s a bigger change in behaviour - it probably makes more sense to use different key combos for tracker instead. maybe instead of CTRL make it CTRL-ALT?



for folks who want to try grid integration - do not connect your grid directly to teletype!!! doing so might result in damage to your teletype and/or grid! grid MUST be powered externally!!!


I have a question about W.

I was using x to count and wrap. I then used W eq x 15: to trigger an external rest. This command seemed to set x at 15 and add a pause, or really just double the pulse at 15. I guess I don’t understand W. Is that expected behavior?



W condition: command will execute the command while the condition is true.

if you do W EQ X 15: command it will execute the command while X equals 15. if just before this line X is not 15 then it won’t execute at all (since the condition is not true). if X equals 15 it will execute, but then if you don’t modify X in the command X will stay at 15 so it’ll get stuck in an endless loop, repeating the command over and over again.

there is a safety mechanism for such scenario built into W - if it loops 10,000 times then it will continue to the next line, which is probably what you’re seeing.


How would you execute a clean, single trigger when the count hits 15? You’re right, I’ve noticed what looks like multiple triggers firing when it gets to the goal count…presumably because of varying speeds of the counting script and the script with the trigger command. But I usually make sure that the counter and the reset trigger are running at the same speed; either in the same script or both triggered by M, for instance.

One thing I definitely notice that helps is adjusting the length of the trigger time. I think my Varigate reset likes getting about 30ms pulse.


sounds like you want IF EQ X 15: ...


Yea, was using that initially, but had some other problems, so tried W. Switched back to IF.

Tnx, @scanner_darkly


the difference is: IF means execute the command if the condition is true and proceed to the next line. W means execute the command while the condition is true, and only proceed when either the condition is not true anymore, or 10,000 repetitions are reached.


How much power does Grid consume at peak (all leds on at max)


20 characters of quotes


calling for community help - it’d be a huge help if somebody could test all the pattern ops. i just found a couple of bugs - setting pattern start and end doesn’t update length, and doing P.PREV when pattern length is 0 decrements the current index and makes it negative. these bugs existed for a while (confirmed with an older version), which is what makes me think there might be more.


I have some free time today. I’ll spend some time trying to break patterns.

I was going to PM you today re 2.3 anyway, so I’ll drop you a line later.


so i’ve been secretly working on this typewriter mode…


I don’t know if this is a Teletype or Ansible glitch, but when I switch Teletype Scenes and call a different Ansible/Levels preset, the link between the two gets frozen. I have to restart the case.