Teletype 3.0



by link frozen do you mean both devices still work but ansible doesn’t react to teletype, or do they freeze as well? is it reproducible each time? how many devices do you have on i2c? are you using the i2c backpack?

also, does it happen only with that command or other i2c commands as well?


Both units still respond to input and work, but they don’t communicate.

It is intermittent, but switching makes them go dark about 90% of the time.

Two Ansible, Telex in and out modules, and ER301. I am using the backpack.

Sometime, but much less frequently, I lose communication from the Telex Input module.


“makes them go dark” - do you mean the loss of communication or something else?

when it loses communication with ansible can it still communicate with telex and/or er-301?


Loss of communication. Teletype still works and Ansible appears to still work: Arc is responsive, just stops relaying it’s info to Teletype. Telex and 301 still communicate.

BTW, my crashing issue (Teletype freeze requiring disconnect from 301) was resolved by cleaning up my commands. I must have had some sort of loop or double call situation. Hasn’t crashed in days with steady use.


sounds like it’s either a bug with that specific ansible command or perhaps a bad contact - can you double check your i2c cable that connects ansible?

also when it happens again can you try switching ansible to a different mode and try some ops for that mode and see if that works?


@scanner_darkly Forgive me if this has been answered elsewhere, but if I wanted to play around with the new Kria Ops, am I right to assume I’ll need to wait until the Grid/TT fix is in place before I can access the beta?


i’ll send you a PM. if anybody else needs it just PM me and i’ll send you the link.


A question for @freqout or other Kria/Just Type experts, which I hope I’m putting in the right spot.

I installed 2.3 earlier today to play with the incredible Kria ops, but I can’t get KR.CV to allocate usable notes to JF in Synthesis mode using JF.VOX — tried N, V, VV without success. Given that the KR.CV values are quite big, do I need to LSH to a specific range?

I’m sure I’m missing something obvious.


hmm… I haven’t used KR.CV for a while, but my hunch is that they are meant to be used without N, V or VV. Something like:

CV 1 KR.CV 1

or whatever the corresponding Just Type command would be.


Ah! Thanks for the follow-up — will give that a shot.


JF.VOX n KR.CV n V n

Where the first n is the channel. The second is the Kria track and the third is velocity.
Have JF in Synthesis mode and switched to sound/transient. I was just playing with it this morning, but ran into a few errrors if understanding along the way/nothing happened. Can vouch for this one.


With the imminent firmware update for w/ upcoming, I wondered how far off we are having this integrated into 2.3?


Worked like a charm - thanks!


my plan is to post one final beta that has everything that i’d like to have in 2.3. i have about 2-3 weeks of work left. at this point if W/ changes are posted i’ll incorporate them as well. as far as i know they haven’t been posted yet.


It would be really neat if the euclidiean operators info was added to the alt+h help page on the teletype! If that hasn’t been done already~


Amazing. Seriously impressed by the continued development of TT. Thank you.


i’ve added an issue:
likely won’t make it to 2.3 - it really needs to be wrapped up soon.


I’ve been working on getting the Telex ops into the help file. I can include the Euclidean operator too.

I know zero about git but can send either the edited file or a diff.


that’d be really helpful, thank you! you can just send the edited file.


Done, the TXo has an incredible 150 lines of extremely terse docs.

Besides the ER operator, I added some others that were missing: PARAM.SCALE, EXP, and such. I didn’t conduct a full review of commands in the online docs, so others may very well be missing.

I’m not 100% that 18 chars will fit to the right of the separator so I flagged the few that ran that long with comments.

I just need to know where to send it.