Teletype CV calibration?

I have recently noticed that the CV outputs are quite out of tune. CV3 is fine but the other 3 are off by differing amounts. CV 2 is not in tune for even one octave whereas CV 1 starts to drift around the third octave. I tried using CV.OFF to tune each output and it works to some degree but on the channels that are really bad the CV.OFF value only works for an octave or so then it is flat again and it needs a larger CV.OFF value. For example, CV 2 needed CV.OFF 30 for the first octave and CV.OFF 100 for the third. I saw a thread that mentioned this a while back but no mention of a fix that I saw. So, any help getting this sorted would be awesome!

1 Like

Bumping this, not too big a deal but it’d be nice to know if this is possible.

bumping this also, seems a bit ridiculous having to put a quantiser after CV outputs in order to get correct note voltages…

made a git issue for it.

I found that my teletype with one txo expander is way off in pitch. I calibrated the txo according to instructions in the manual, but it seems the same method doesn’t work on the “build-in” CV outs on the teletype. Please tell me it’s possible to calibrate the CVs as well, and how :expressionless:

I have found myself calibrating alot of voltage sources in the past and an additional “scew” parameter (or measuring two voltages) would be even better than a simple offset, since often a CV out is not the same amount of flat/sharp in all octaves…

This is the procedure I followed for the internal CV:

To calibrate your TXo outputs, follow these steps. Before you start, let your expander warm up for a few minutes. It won’t take long - but you want to make sure that it is calibrated at a more representative temperature.
Then, first adjust your offset (CV.OFF) until the output is at zero volts (0). For example:
CV.OFF 1 8
Once that output measures at zero volts, you want to lock it in as the calibration by calling the following
You will find that the offset is now zero, but the output is at the value that you targeted during your prior adjustment. To reset to normal (and forget this calibration offset), use the TO.CV.RESET command.

Seems the issue is closed on github. Does this mean it will be in a coming release of the firmware?

The issue looks open when I view it.

i’ll be working on this issue shortly, along with a calibration method for ansible. thanks for bringing this issue back up— best to prioritize according to requests


That’ll be amazing! Hope it makes it into a firmware soon-ish! I’m like 30 cents flat on one output :confused:

EDIT: And if possible, note that a simple offset might not be enough, scaling might also be needed. Two point calibration as is very common in digital eurorack modules seems like a good compromise between something the user can easily perform and is relatively straightforward to implement.