Teletype docs enhancements (redesign in progress)


#181

yeah, whatever makes sense, just thought it’s cleaner from history point of view if a PR is done against master. either way works for me! i’ve merged @GoneCaving PR already.


#182

Sorry, my bad, I typed that reply too quickly.

The question was aimed at @scanner_darkly (which he has answered). I was asking if I could build on top of the changes that you had made, rather than make edits which might conflict with yours on the master branch.


#183

https://github.com/scanner-darkly/teletype/pull/5

Also, in case you didn’t know, Appendix B in the generated documentation will list any OPs without docs.

(Actually, just looked at them and seen that $ is missing a proper symbol.)

edit: pushed change to add $ as an alias to SCRIPT to the docs.


#184

great, thanks @sam, merged the PR. will give it a try!


#185

Oh man, Hello Worlded GitHub and the Teletype docs today, gold star for me! Gonna fuss with the LaTeX stuff and report back if I get anything useful.


#186

you might want to use my branch if you want to include the latest changes from @GoneCaving and @sam - let me know if you need help with setting that up. my branch is here: https://github.com/scanner-darkly/teletype/tree/grid2


#187

Yup, I forked your branch after realizing that I was going to have to duplicate @sam’s work if I wanted pandoc to cooperate :sweat_smile:


#188

yep you can just clone my fork. might be better to create your own fork of monome/teletype though and then set up my fork as a remote - this will allow you to get my changes but make pull requests against the main repository in the future (which will be the case once my grid2 branch is merged).

let’s say you create your own fork, so now you have alanza/teletype. you can clone it locally with:
git clone https://github.com/alanza/teletype.git --recursive

then add my fork as a remote:
git remote add scanner https://github.com/scanner-darkly/teletype.git

then fetch my branches, i usually just use git fetch -all so i don’t have to pull from each remote separately. you can now switch to my branch with:

git checkout scanner/grid2

(you might also need to update submodule with git submodule update). at this point you can create a local branch here and work from that.


#189

anybody wants to volunteer writing a section on saving/loading to/from USB? we don’t have anything in the manual right now. if somebody could do a write up i’ll include it in 2.3 release.


#190

I haven’t done it myself, so I don’t want to overpromise, but if it’s not difficult I’m happy to


#191

uhhhh, how exactly do you do this thing? I’ve tried loading scenes a few different ways to no avail. I’m about to go root around in the Github to see if there’s any help there as well.


#192

When you sync to USB, first scripts are saved TT->USB, then scripts are sync’d USB->TT. When scripts are saved to USB, they are in the format tt##s.txt. Any scripts on the USB in the format tt##.txt (no “s”) then overwrite that slot.


#193

okay, with my middle-school knowledge of C, it seems like there’s an event handler for putting Teletype in disk mode, but that there should be some kind of screen feedback there, so somehow I am not entering disk mode? I’m gonna root around for another USB stick. I’ve tried this one at startup and not, with long presses on the button and not, in MacOS formatting and FAT. no cigar: I have no scripts on my Teletype and have been trying to load the defaults on via USB.

Thanks for the info @desolationjones! I was pretty sure that was the order of events. Just haven’t been able to get mine to sync at all.


#194

When I inserted the USB stick it automatically went to disk mode, did a flash to USB transfer, then went back to regular mode. No extra button press needed.


#195

ah! I have been able to get it to work with two other USB sticks! Is it possible that 16GB is too big for Teletype to talk to?


#196

Yeah I think max FAT32 filesystem is 4GB? Or maybe I’m misremembering.


#197

I’ve used 16GB sticks with no problem. Note that there is a 2 or 3 second pause after inserting before the display acknowledges it is writing to disk.


#198

I submitted a PR (my first ever :see_no_evil:) against the grid2 branch with a little section added under Quickstart!


#199

I’ve been using a 64Gb USB 3.0. A bit overkill maybe? :slight_smile: But it works.


#200

Well, good to know! My current guess is that because I had previously formatted the non-working disk as MacOS-whatsit, the permissions are all screwy and above Teletype’s pay grade. The other drives I tried were 4 and 1 GB, respectively, hence the previous hypothesis.