Teletype docs enhancements (redesign in progress)


#281

thank you, the new alphabetical list looks great!!

yeah as i was looking at it i thought the left column could be narrower, and sure enough the reason is grid ops. i agree it would be good to shorten them somehow, but maybe we could find a way to do so without affecting readability. my concern with non descriptive names is it will mean jumping back and forth between the op and the description a lot, which is especially bad for ops with lots of parameters.

maybe i could shorten them a bit without affecting readability? so instead of:

G.FDX id x y w h type level script columns rows

it could be

G.FDX id x y w h typ lev scr col row

also would be good to split jf/telex descriptions into short and long descriptions - something like JF.QT x takes a lot of space in the alphabetical list right now. perhaps somebody could volunteer to go over them and change?


#282

I can do this! I’ll have some time this weekend.


#283

excellent! ping me whenever if you need help with anything, i’m doing a coding marathon this weekend so will be at computer most of the time (excluding evenings).


#284

awesome, let me know if you want things built to that staging link or anything.


#285

I am not sure what you mean by refresh. Just tested it again with iPad and iPhone and it is the same on both devices, just the blue list and tapping one of the links brings me back to the very same page.

I am pretty sure it worked with the previous version though. I just cannot find a working previous version now. Are the links from this thread all the same? :thinking:


#286

@Leverkusen should be. link is https://teletype-docs.now.sh


#287

okay Git hygiene question; is editing whatever version of the 3.0 docs okay, or is there a particular branch I should fork from?


#288

heads up, i’ve just merged @alphacactus’s PR which includes new doc for J and K variables, if you use master branch make sure to pull the latest!


#289

@jlmitch5 I just noticed, the table has left column label "OP includes set notation and aliases". The latter part of that should (a) not be bolded (my goto here would be smaller font, italics and parentheses but maybe that’s overkill) and (b) maybe something should be done so it doesn’t increase the width of the left column quite so severely.

You guys I am learning so much Git by doing this it’s great. And once I’m actually up and editing I’ll learn so much more Teletype!


#290

is it all right if I also editorialize away from x y z for OP argument letters in some instances? Especially in cases where another letter or short string would be more descriptive, I think this will help the documentation’s legibility.

I say “is it all right”, but I’m going ahead and making that change on my branch xD


#291

Seems to me like there’s already a precedent for doing this - at least in the cheat sheet / command reference. Grid ops don’t really follow the x y z pattern. E.g.

G.BTX id x y w h type level script columns rows

I think it would make some of them more readable.


#292

this would be great, as it would also improve consistency between different ops.

for grid ops x and y specifically mean the x/y control coordinates, so made sense to name the parameters accordingly (and i thought w and h are pretty self explanatory in this context too).

i had more than one occasion of “oh didn’t know there was an op for that!” while looking at the code :slight_smile:


#293

@tehn PR up! I can fix PDF building as part of this PR or right after, whichever works. Let me know if you need anything.

@alanza thanks for the feedback, I fixed the header, I think:


#294

Thanks a ton for your efforts here!


#295

I still can’t use this on neither my iPhone nor the iPad. I am on iOS 9 on both of them and I am sure there was a previous version, that worked though.


#296

I’ll see if I can pull up a cross browser testing tool and check iOS 9. Latest does work on iOS 12 for sure.

I removed all newer style js I was using when I cleaned up the code, so I’m puzzled as to what it could be.

If you have the ability to pull up the console on safari and tell me if you see any error messages, that would be helpful.


#297

actually, pretty sure I know what’s wrong—need to convert forEach to standard for loops. I moved that code from an isolated script tag to the main area, which is why it would have worked before and stopped working once I made that change. I’ll let you know when I’ve made that update


#298

@Leverkusen I updated that code and pushed the changes. Could you check again? Thanks for following back up on that!


#299

It works on the iPhone now. The link you provided always brings me to the expanded menu, tapping a heading there brings me to the right chapter.

On the iPad I see the same expanded menu and it is not blue anymore as it was in the screenshot I posted above. Tapping on the headers/links does nothing but I can collapse the menu now by tapping on the cross and than I have the full documentation. I tried if I get to different points of the documentations when I tap the menu headers before I close the menu but I always get to the beginning.

Both devices are on the same version of iOS 9 so it might be the iPad that is wrong here somehow.


#300

Awesome glad it works better. I will see if I can figure out about the iPad issue.