Teletype keyboard issues


#1

hey all! hope tuesday is treating you well. i’ve done some searching and haven’t found another thread describing this particular issue, so here goes:

i’ve got a teletype in my 104hp pittsburgh modular move case (which has a solid power supply, etc). about a month ago, the keyboard functionality stopped being quite so reliable—an hour or so into a session, the keyboard would stop responding. re-seating the USB cable had no effect. the unit otherwise kept operating though and i could interact with it through the button and the param knob.

recently, the situation worsened. i can no longer get a keyboard to register with it at all. worried that the USB bus was misbehaving, i tried a firmware update (i was a few versions behind) and the update went through with no issues. i didn’t have to re-seat the USB cable or anything—the AVR was picked up by my mac and the flash was successful. i repeated this a few times.

does anyone have any idea what might be up or how i might debug it? i’m a programmer with limited EE savvy, so i’m happy to follow more specific debugging instructions if necessary!

thanks!

edit: tagging @tehn for visibility

double edit: as referenced below, i’ve tested the keyboard w/ my computer and it functions normally.


#2

Do you have any other USB keyboards to test with? Specifically it needs to be one without a USB hub built into it.

Alternatively… can you try connecting the keyboard to a computer and report if it has any problems when used there.


#3

ah, i should have noted! the keyboard functions totally normally when plugged in to my mac. no functionality missing. thanks for the quick follow up. i don’t have any other low power keyboards at the moment, but i will try to find one to test with.


#4

the usb circuitry is pretty isolated. given your firmware flash works, i’d say the pins are all connected properly.

my first assumption would be something with the keyboard (which is by no means high quality), but that’s strange that it works fine with your computer. as sam said, testing with another keyboard is the best next step.

to clarify, it just suddenly stops responding? does it come back immediately upon a restart?


#5

It does seem a bit weird that flashing works, but the keyboard doesn’t.

Is it possible that it could be an issue with the USB ID pin (that determines host or device)… For flashing, the Teletype would come up in device mode, but with a keyboard it would need to be in host mode. Alternatively could a short in the keyboard cabling cause the Teletype to come up in device mode.


#6

it used to stop responding and would eventually come back after a restart + many reinsertions of the USB cable. at this point i can’t get the teletype to recognize a keyboard at all. i’ve tried plugging it in before turning on the modular as well as after.


#7

was there any change in behaviour after you updated the firmware?


#8

there wasn’t w/ the keyboard, though it was heartening to see that the flash via USB was functioning.


#9

ok—feel like i’m going insane here. the teletype is working without issue… i can re-seat the USB cable many times and the keyboard seems to be operational. could it perhaps have been some sort of grime in the USB port? i’ll investigate this further and be sure to keep y’all posted if the issue returns. it did plague me for about a month of regular use.


#10

Upon arrival, the keyboard that came with my TT was funky. The slightest movement of the USB cable would cause it to stop working. Was afraid it was the TT itself early on, but after connecting a different keyboard - everything worked fine.

TLDR; Be sure to try a different keyboard.


#11

yeah, was quite confused because the keyboard was functioning w/ other equipment. i’m going to look into a sturdier passive keyboard!

thanks for the patience everyone :slight_smile: just had my first TT jam in a month and it felt so right.


#12

Ok, so I don’t have a Teletype, but I just had to jump in here. The school that I teach technology at uses the exact same keyboards for the 2nd grade students (tiny hands). Every so often, random keys stop functioning on certain keyboards. We initially started replacing keyboards, but one of us finally figured out that unplugging and plugging the keyboard back in gets those “faulty” keys up and running again. Crazy; right? Hope that helps in some small way…


#13

i had weird keyboard issues (using the keyboard that comes with tt) where it would stop responding at some point, but unplugging and replugging usually helped. also noticed a bit of a slowdown when typing sometimes, but this could’ve been due to running heavy scripts at the time (testing i2c). but i’ve been using the same keyboard with 2 different teletypes in 2 different cases lately with no issues. i wonder if this has anything to do with what scripts are running at the time, and if the power load plays any role at all.


#14

ok, all… sorry to dredge this up again, but my teletype has reverted back to its previous state. can’t get the keyboard to work with it at all. the keyboard still functions without issue when plugged in to a laptop, so i’m not sure that the keyboard itself is the issue. the teletype is still running the last scene loaded on it, so the unit seems otherwise functional.

i’m willing to buy a passive keyboard, but i definitely wouldn’t buy the same one if it’s known to be the source of so many issues—as i’ve learned many times at this point, a loss of keyboard session when developing a scene means a lost scene!

for extra information, i’m running a pittsburgh modular move 104 case with:

teletype, meadowphysics, rene, sto, three sisters, optomix, music thing spring reverb, intellijel ujack. everything else is functioning completely normally. i could imagine a scenario where, between rene and teletype, current draw was too much and the usb to the keyboard wasn’t getting the power it needs. i’ll experiment with removing a few modules.

any ideas?

edit: i disconnected the rene and sto from the power supply and it still wouldn’t function. moved it to another case and the keyboard worked for a moment before stopping again.


#15

Any further luck on this? I’ve had the same problem for a while. The keyboard would often stop working in the middle of a session and I’d have to unplug & replug a bunch and keep my fingers crossed.

I recently got the microsoft wireless keyboard that was being discussed here: Mechanical keyboard for teletype? and it was working a little bit but was definitely not plug and play. It only worked with USB dongle in at strange positions which seemed to be a little different each time (if it ended up working at all).

I recently updated to 2.3 beta (which worked fine on the first try) but neither keyboard has worked since.

I’ll keep trouble shooting and try with the old firmware again but was wondering if you had any suggestions.


#16

yeah, I just got my teletype new a couple of weeks ago. The keyboard wasn’t recognizing the space bar? It was weird. Then I plugged in and out a few times then it did. That was the first week.

I also am having the same experience with it randomly going out. It’s almost as if the USB isn’t properly connected? that space bar works now aside from the random complete keyboard blackouts.

Shot an email asking if it was the keyboard or something but didn’t hear back.


#17

the keyboards have proven to be not very high quality. e-mail info@monome.org and i can send you a new one.


#18

I can recommend getting a 60% or 40% wired mechanical keyboard as a small, reliable alternative to the chiclet keyboard. There are some really lovely ones but I’m happy with my cheap but cheerful sub £30 one from Amazon. Search for Qisan Mechanical Keyboard. It uses Cherry key switches which are quite clicky.


#19

no worries, as long as it’s just the keyboard! thank you though. been overdue for a snazzy 87 key


#20

Can anyone recommend a specific keyboard on the Amazon US site? I too have a few keys that stick/don’t register reliably. I see this:


… but not sure if the LEDs would cause an issue with power etc.