Teletype keyboard issues

Have you made sure that there is no system noise associated with dis/connecting hardware?

Additionally I might suspect that a cheap KVM switch could short out the USB port briefly while being toggled. This could open the resettable polyfuse for a brief moment. I don’t feel like this should affect your firewire interface unless your firewire port is protected by the same fuse as the USB.

Windows does play a sound for USB device (dis)connection. That seems unlikely to be the cause though, since turning on my Microbrute (which is connected over USB) after I’ve already got other things going doesn’t seem to matter (except that my DAW won’t recognize it as a MIDI input device that way).

It’s a Logitech keyboard with a driver for fancy lighting stuff, gaming profiles I don’t use etc. so it’s possible something about that is tying up I/O for a couple of seconds.

Hmm… I notice the transport in Maschine actually stops briefly when I flip the switch. But it’s not due to temporarily losing its connection to the Maschine hardware, since I can unplug that without disturbing it and switching the keyboard still does.

It’s also not the “Logitech Gaming Software” driver.

I guess I’ll just have to make sure I don’t switch the keyboard while I’m recording something, and it’s probably okay image

Just ran into the same issue as @robbbiecloset, I’ve submitted a PR to update the relevant study:

Yay, first day with Teletype, and my first monome related PR!

1 Like

Beat me to it! :sweat_smile:

I’m sure there will be other opportunities.

:sweat_smile: I found this thread after submitting the PR, low hanging fruit hehe.

anybody already tried to connect a wireless keyboard (the ones with usb dongle)?

try forum search for a bunch more possibly

any reason why some work and others not?

Logitech keyboards with a Unifying receiver dongle work well with it. You have to pair it using a computer first, but then you can just plug it into the Teletype USB port afterwards.

I’m using mine with a K780 keyboard which can switch between three devices.

I’m the guy with the Microsoft keyboard. It works great, I have been using it all this time with no trouble.

ok, thanks for the advice, I’ve ordered the Microsoft keyboard, will let you know how it goes:)

New Teletype owner here. Can’t get a keyboard to work with it. I’ve tried two, both work fine with my Windows boxes. Keyboard 1 likes to stick… keys just reppppppppppppppppeat at random, sometimes don’t work at all. Keyboard 2 - the one that came with the Teletype - works great except for the Enter key, which works not at all. Again, no problems on other computers

Teletype version 3. Clearly from looking at previous messages I am not alone in this. I am inclined to believe this is an inherent design flaw in Teletype. Are there any steps that I can take to get a keyboard to work with this, other than trial and error?

I haven’t had issues with the keyboard that came with Teletype, so I’m not too up to date on the details, but I think there are a couple options. Some fixes have been made in recent firmwares to address dropped/repeated keys, so you might try updating to the latest beta, or waiting for the 3.1 release that the Teletype devs are planning on making soon (likely within a week or two). If you’re up to compiling the firmware yourself (I recommend this Docker image) I think you might also try tweaking the HID polling frequency for your specific keyboard and letting us know what works and for what model of keyboard. I think broadly that the trouble here probably arises from there being lots of behavior variation between different keyboards and the limited hardware resources on Teletype kind of necessitate adopting a simpler approach than full-fledged operating systems are able to use, but I also have basically zero first-hand experience with HID stacks in general or Teletype’s specifically.

e-mail and i can send you another!

Thank you everyone. Given the impending release of 3.1 I will wait on both offers. I could figure out how to do the compile but that is not something I want to spend my limited free time on. @tehn, thank you for the offer on the kbd but again I will wait a bit. Testing with a third keyboard tonight.

And later: the third keyboard works. This is a full-size HP keyboard, brand new (all my keyboards come from the spares pile at work). The two that don’t are the K-1000 mini-keyboard that came with the Teletype, and another mini-keyboard from work.

Looking forward to 3.1. I will report back on these keyboards then; maybe I’ll install the beta this weekend. Very much looking forward to the output calibration as well, that was the next item on my list of things to ask about.

Another happy new Teletype owner here. Well, almost happy. I also got some strange behaviour with the included keyboard:

When typing the letter T in live mode, the command TR gets displayed. Not sure if this is some kind of auto completion mechanism, but it also happens when I for example try typing the second T

Also, when typing the letters I or P (e. g. when entering TR.PULSE or TR.TIME), the module starts switching between the different scripts.

There seems to be some other weird behaviour for different keys, but I’m not very familiar with the TT yet, so it’s a bit hard to describe.

The keyboard from my computer (Logitech K280e) seems to work fine. However, since it has a German QWERTZ-layout, it’s a bit tricky to use (and also does not fit into my little synth-corner, so I have to hold it in my hands all the time…).

So if someone has maybe experienced the same problems and found a solution or workaround I’d be very happy to hear about it!

I would suggest testing the TT keyboard with a computer to see if it is a defect keyboard

if so email help@monome and I can send another!

ongoing issue w/ tt version 3.0 (as others previously mention) - regardless of keyboard (i have tried a few), they all lose connectivity to tt after about an hour of inactivity and/or sporadically cease to type during a session. it’s not a big deal as reconnecting the usb cable eventually solves the issue, but is there a more permanent solution to this?